aboutsummaryrefslogtreecommitdiffstats
path: root/net/ossp-sa
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2004-04-14 02:26:51 +0800
committerarved <arved@FreeBSD.org>2004-04-14 02:26:51 +0800
commit0ad7f07e84f17124aa5a0ac483b77bd13ce02a14 (patch)
tree599620c699513958e6a296fccecec43d3c320570 /net/ossp-sa
parent454518e6a22e8a1ab22b9c1a3dbc7d3c89a455fa (diff)
downloadfreebsd-ports-gnome-0ad7f07e84f17124aa5a0ac483b77bd13ce02a14.tar.gz
freebsd-ports-gnome-0ad7f07e84f17124aa5a0ac483b77bd13ce02a14.tar.zst
freebsd-ports-gnome-0ad7f07e84f17124aa5a0ac483b77bd13ce02a14.zip
Fix build on amd64 by using va_copy
Diffstat (limited to 'net/ossp-sa')
-rw-r--r--net/ossp-sa/Makefile8
-rw-r--r--net/ossp-sa/files/patch-ts.c14
2 files changed, 15 insertions, 7 deletions
diff --git a/net/ossp-sa/Makefile b/net/ossp-sa/Makefile
index fa7ea2fb3155..7c7b0bf8d0ab 100644
--- a/net/ossp-sa/Makefile
+++ b/net/ossp-sa/Makefile
@@ -25,10 +25,4 @@ USE_LIBTOOL_VER= 15
INSTALLS_SHLIB= yes
MAN3+= sa.3
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "amd64"
-BROKEN= "Does not compile on amd64"
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/ossp-sa/files/patch-ts.c b/net/ossp-sa/files/patch-ts.c
new file mode 100644
index 000000000000..2fc4064b1726
--- /dev/null
+++ b/net/ossp-sa/files/patch-ts.c
@@ -0,0 +1,14 @@
+--- ts.c.orig Tue Apr 13 20:23:45 2004
++++ ts.c Tue Apr 13 20:24:18 2004
+@@ -206,7 +206,11 @@
+
+ if (format == NULL)
+ return NULL;
++#ifdef __amd64__
++ va_copy(ap2,ap);
++#else
+ ap2 = ap;
++#endif
+ if ((n = ts_suite_mvxprintf(NULL, 0, format, ap)) == -1)
+ return NULL;
+ if ((buffer = (char *)malloc(n+1)) == NULL)