aboutsummaryrefslogtreecommitdiffstats
path: root/net/p5-EasyTCP
diff options
context:
space:
mode:
authorkevlo <kevlo@FreeBSD.org>2002-02-15 15:46:51 +0800
committerkevlo <kevlo@FreeBSD.org>2002-02-15 15:46:51 +0800
commit4d022578be992caca55c8a3eef310f9b09261f7c (patch)
tree3eca8ba45f7c85e493f9a7ed43e84b1fbc470b9d /net/p5-EasyTCP
parent11ceb5376dc6092c8f343b821b38951ea41941c2 (diff)
downloadfreebsd-ports-gnome-4d022578be992caca55c8a3eef310f9b09261f7c.tar.gz
freebsd-ports-gnome-4d022578be992caca55c8a3eef310f9b09261f7c.tar.zst
freebsd-ports-gnome-4d022578be992caca55c8a3eef310f9b09261f7c.zip
Initial import of p5-EasyTCP 0.08
This is an easily create TCP/IP clients and servers. PR: 34254 Submitted by: Seamus Venasse <svenasse@polaris.ca>
Diffstat (limited to 'net/p5-EasyTCP')
-rw-r--r--net/p5-EasyTCP/Makefile26
-rw-r--r--net/p5-EasyTCP/distinfo1
-rw-r--r--net/p5-EasyTCP/pkg-comment1
-rw-r--r--net/p5-EasyTCP/pkg-descr12
-rw-r--r--net/p5-EasyTCP/pkg-plist27
5 files changed, 67 insertions, 0 deletions
diff --git a/net/p5-EasyTCP/Makefile b/net/p5-EasyTCP/Makefile
new file mode 100644
index 000000000000..6b684d3881fc
--- /dev/null
+++ b/net/p5-EasyTCP/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: EasyTCP
+# Date created: 24 Jan 2002
+# Whom: Seamus Venasse <svenasse@polaris.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= EasyTCP
+PORTVERSION= 0.08
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/M/MN/MNAGUIB
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= svenasse@polaris.ca
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+PERL_CONFIGURE= yes
+
+MAN3= Net::EasyTCP.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/net/p5-EasyTCP/distinfo b/net/p5-EasyTCP/distinfo
new file mode 100644
index 000000000000..0e6afdf72d5f
--- /dev/null
+++ b/net/p5-EasyTCP/distinfo
@@ -0,0 +1 @@
+MD5 (EasyTCP-0.08.tar.gz) = 0f25606b94e6fc11ad43ae9d20cd64dd
diff --git a/net/p5-EasyTCP/pkg-comment b/net/p5-EasyTCP/pkg-comment
new file mode 100644
index 000000000000..df08811750c6
--- /dev/null
+++ b/net/p5-EasyTCP/pkg-comment
@@ -0,0 +1 @@
+Easily create TCP/IP clients and servers
diff --git a/net/p5-EasyTCP/pkg-descr b/net/p5-EasyTCP/pkg-descr
new file mode 100644
index 000000000000..4d48333adc78
--- /dev/null
+++ b/net/p5-EasyTCP/pkg-descr
@@ -0,0 +1,12 @@
+Net::EasyTCP - Easily create TCP/IP clients and servers
+
+* One easy module to create both clients and servers
+* Object Oriented interface
+* Event-based callbacks in server mode
+* Internal protocol to take care of all the common transport problems
+* Transparent encryption
+* Transparent compression
+
+WWW: http://search.cpan.org/search?dist=EasyTCP
+
+Seamus Venasse <svenasse@polaris.ca>
diff --git a/net/p5-EasyTCP/pkg-plist b/net/p5-EasyTCP/pkg-plist
new file mode 100644
index 000000000000..697efce2cc02
--- /dev/null
+++ b/net/p5-EasyTCP/pkg-plist
@@ -0,0 +1,27 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/EasyTCP/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/Net/EasyTCP.pm
+lib/perl5/site_perl/%%PERL_VER%%/auto/Net/EasyTCP/autosplit.ix
+lib/perl5/site_perl/%%PERL_VER%%/auto/Net/EasyTCP/callback.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/Net/EasyTCP/clients.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/Net/EasyTCP/close.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/Net/EasyTCP/compression.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/Net/EasyTCP/data.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/Net/EasyTCP/disconnect.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/Net/EasyTCP/encryption.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/Net/EasyTCP/mode.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/Net/EasyTCP/new.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/Net/EasyTCP/receive.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/Net/EasyTCP/remoteip.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/Net/EasyTCP/remoteport.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/Net/EasyTCP/running.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/Net/EasyTCP/send.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/Net/EasyTCP/serial.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/Net/EasyTCP/setcallback.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/Net/EasyTCP/socket.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/Net/EasyTCP/start.al
+lib/perl5/site_perl/%%PERL_VER%%/auto/Net/EasyTCP/stop.al
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/auto/Net/EasyTCP 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/auto/Net 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Net 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/EasyTCP 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net 2>/dev/null || true