aboutsummaryrefslogtreecommitdiffstats
path: root/net/p5-IO-INET6
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2005-07-30 08:32:53 +0800
committerleeym <leeym@FreeBSD.org>2005-07-30 08:32:53 +0800
commit38fb3bcffd44ea9d8c44d57ba45f26271f08a79a (patch)
treef204de3faf591a007f0ca2220120320eef73aeb6 /net/p5-IO-INET6
parentc7235071ff232e103620d7e1c14a76a5a9279b49 (diff)
downloadfreebsd-ports-gnome-38fb3bcffd44ea9d8c44d57ba45f26271f08a79a.tar.gz
freebsd-ports-gnome-38fb3bcffd44ea9d8c44d57ba45f26271f08a79a.tar.zst
freebsd-ports-gnome-38fb3bcffd44ea9d8c44d57ba45f26271f08a79a.zip
- fix the problem caused by ports/84292
Pointy hat to: leeym PR: 84313 Submitted by: maintainer
Diffstat (limited to 'net/p5-IO-INET6')
-rw-r--r--net/p5-IO-INET6/Makefile9
-rw-r--r--net/p5-IO-INET6/files/5.005_03.diff32
2 files changed, 40 insertions, 1 deletions
diff --git a/net/p5-IO-INET6/Makefile b/net/p5-IO-INET6/Makefile
index 9f0799b4a7da..0f885107c300 100644
--- a/net/p5-IO-INET6/Makefile
+++ b/net/p5-IO-INET6/Makefile
@@ -7,6 +7,7 @@
PORTNAME= IO-Socket-INET6
PORTVERSION= 2.51
+PORTREVISION= 1
CATEGORIES= net perl5 ipv6
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= IO
@@ -22,4 +23,10 @@ MAN3= IO::Socket::INET6.3
PERL_CONFIGURE= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500600
+EXTRA_PATCHES= ${PATCHDIR}/5.005_03.diff
+.endif
+
+.include <bsd.port.post.mk>
+
diff --git a/net/p5-IO-INET6/files/5.005_03.diff b/net/p5-IO-INET6/files/5.005_03.diff
new file mode 100644
index 000000000000..10dc9fa57dae
--- /dev/null
+++ b/net/p5-IO-INET6/files/5.005_03.diff
@@ -0,0 +1,32 @@
+
+$FreeBSD$
+
+--- INET6.pm.orig
++++ INET6.pm
+@@ -10,7 +10,7 @@
+ package IO::Socket::INET6;
+
+ use strict;
+-our(@ISA, $VERSION);
++use vars qw(@ISA $VERSION);
+ use IO::Socket;
+ use Socket;
+ use Socket6;
+@@ -22,7 +22,7 @@
+ $VERSION = "2.51";
+ #Purpose: allow protocol independent protocol and original interface.
+
+-my $EINVAL = exists(&Errno::EINVAL) ? Errno::EINVAL() : 1;
++my $EINVAL = defined(&Errno::EINVAL) ? Errno::EINVAL() : 1;
+
+ IO::Socket::INET6->register_domain( AF_INET6 );
+
+@@ -190,7 +190,7 @@
+ }
+
+ if ($arg->{ReusePort}) {
+- $sock->sockopt(SO_REUSEPORT,1) or
++ $sock->sockopt(0x0200,1) or
+ return _error($sock, $!, "sockopt: $!");
+ }
+