aboutsummaryrefslogtreecommitdiffstats
path: root/net/p5-JavaScript-RPC
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2014-11-26 21:08:24 +0800
committermat <mat@FreeBSD.org>2014-11-26 21:08:24 +0800
commit9debac461b7729b783ca5a0f5e46461ddac07173 (patch)
tree0d350fe6ad6a2fe3222d838f3c72856c78cd449f /net/p5-JavaScript-RPC
parenteedda7c96f5b61bbadc957164c030b26a221e965 (diff)
downloadfreebsd-ports-gnome-9debac461b7729b783ca5a0f5e46461ddac07173.tar.gz
freebsd-ports-gnome-9debac461b7729b783ca5a0f5e46461ddac07173.tar.zst
freebsd-ports-gnome-9debac461b7729b783ca5a0f5e46461ddac07173.zip
Change the way Perl modules are installed, update the default Perl to 5.18.
Before, we had: site_perl : lib/perl5/site_perl/5.18 site_perl/perl_arch : lib/perl5/site_perl/5.18/mach perl_man3 : lib/perl5/5.18/man/man3 Now we have: site_perl : lib/perl5/site_perl site_arch : lib/perl5/site_perl/mach/5.18 perl_man3 : lib/perl5/site_perl/man/man3 Modules without any .so will be installed at the same place regardless of the Perl version, minimizing the upgrade when the major Perl version is changed. It uses a version dependent directory for modules with compiled bits. As PERL_ARCH is no longer needed in plists, it has been removed from PLIST_SUB. The USE_PERL5=fixpacklist keyword is removed, the .packlist file is now always removed, as is perllocal.pod. The old site_perl and site_perl/arch directories have been kept in the default Perl @INC for all Perl ports, and will be phased out as these old Perl versions expire. PR: 194969 Differential Revision: https://reviews.freebsd.org/D1019 Exp-run by: antoine Reviewed by: perl@ Approved by: portmgr
Diffstat (limited to 'net/p5-JavaScript-RPC')
-rw-r--r--net/p5-JavaScript-RPC/Makefile1
-rw-r--r--net/p5-JavaScript-RPC/pkg-plist6
2 files changed, 1 insertions, 6 deletions
diff --git a/net/p5-JavaScript-RPC/Makefile b/net/p5-JavaScript-RPC/Makefile
index b4f1e3c97327..7ca8c84e278f 100644
--- a/net/p5-JavaScript-RPC/Makefile
+++ b/net/p5-JavaScript-RPC/Makefile
@@ -3,6 +3,7 @@
PORTNAME= JavaScript-RPC
PORTVERSION= 0.3
+PORTREVISION= 1
CATEGORIES= net perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
diff --git a/net/p5-JavaScript-RPC/pkg-plist b/net/p5-JavaScript-RPC/pkg-plist
index aada130cf03c..f9a14dffb465 100644
--- a/net/p5-JavaScript-RPC/pkg-plist
+++ b/net/p5-JavaScript-RPC/pkg-plist
@@ -2,9 +2,3 @@
%%PERL5_MAN3%%/JavaScript::RPC::Server::CGI.3.gz
%%SITE_PERL%%/JavaScript/RPC.pm
%%SITE_PERL%%/JavaScript/RPC/Server/CGI.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/JavaScript/RPC/.packlist
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/JavaScript/RPC
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/JavaScript
-@dirrmtry %%SITE_PERL%%/JavaScript/RPC/Server
-@dirrmtry %%SITE_PERL%%/JavaScript/RPC
-@dirrmtry %%SITE_PERL%%/JavaScript