aboutsummaryrefslogtreecommitdiffstats
path: root/net/p5-Net-EPP-Client/Makefile
diff options
context:
space:
mode:
authoraaron <aaron@FreeBSD.org>2006-02-19 12:59:42 +0800
committeraaron <aaron@FreeBSD.org>2006-02-19 12:59:42 +0800
commit84ade4ac8846a36d6d2b212eab38189c42bfe21d (patch)
treec1c1cb96381264370b7181f3dc04c902e0e672fa /net/p5-Net-EPP-Client/Makefile
parentfaa637010d01f6233f4ffa20df121b77058bb263 (diff)
downloadfreebsd-ports-gnome-84ade4ac8846a36d6d2b212eab38189c42bfe21d.tar.gz
freebsd-ports-gnome-84ade4ac8846a36d6d2b212eab38189c42bfe21d.tar.zst
freebsd-ports-gnome-84ade4ac8846a36d6d2b212eab38189c42bfe21d.zip
Adding port net/p5-Net-EPP-Client, a client library for the TCP transport for EPP, the Extensible Provisioning Protocol.
Approved by: tobez (implicit)
Diffstat (limited to 'net/p5-Net-EPP-Client/Makefile')
-rw-r--r--net/p5-Net-EPP-Client/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/net/p5-Net-EPP-Client/Makefile b/net/p5-Net-EPP-Client/Makefile
new file mode 100644
index 000000000000..68721ccd56b8
--- /dev/null
+++ b/net/p5-Net-EPP-Client/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: Net-EPP-Client
+# Date created: 18 Feb 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-EPP-Client
+PORTVERSION= 0.05
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Client library for the TCP transport for EPP
+
+BUILD_DEPENDS= ${SITE_PERL}/IO/Socket/SSL.pm:${PORTSDIR}/security/p5-IO-Socket-SSL \
+ ${SITE_PERL}/${PERL_ARCH}/XML/LibXML.pm:${PORTSDIR}/textproc/p5-XML-LibXML \
+ ${SITE_PERL}/Net/EPP/Frame.pm:${PORTSDIR}/net/p5-Net-EPP-Frame
+RUN_DEPENDS+= ${BUILD_DEPENDS}
+
+MAN3= Net::EPP::Client.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>