aboutsummaryrefslogtreecommitdiffstats
path: root/net/p5-Net-EPP-Client
diff options
context:
space:
mode:
authoraaron <aaron@FreeBSD.org>2006-02-19 12:59:42 +0800
committeraaron <aaron@FreeBSD.org>2006-02-19 12:59:42 +0800
commit84ade4ac8846a36d6d2b212eab38189c42bfe21d (patch)
treec1c1cb96381264370b7181f3dc04c902e0e672fa /net/p5-Net-EPP-Client
parentfaa637010d01f6233f4ffa20df121b77058bb263 (diff)
downloadfreebsd-ports-gnome-84ade4ac8846a36d6d2b212eab38189c42bfe21d.tar.gz
freebsd-ports-gnome-84ade4ac8846a36d6d2b212eab38189c42bfe21d.tar.zst
freebsd-ports-gnome-84ade4ac8846a36d6d2b212eab38189c42bfe21d.zip
Adding port net/p5-Net-EPP-Client, a client library for the TCP transport for EPP, the Extensible Provisioning Protocol.
Approved by: tobez (implicit)
Diffstat (limited to 'net/p5-Net-EPP-Client')
-rw-r--r--net/p5-Net-EPP-Client/Makefile27
-rw-r--r--net/p5-Net-EPP-Client/distinfo3
-rw-r--r--net/p5-Net-EPP-Client/pkg-descr17
-rw-r--r--net/p5-Net-EPP-Client/pkg-plist7
4 files changed, 54 insertions, 0 deletions
diff --git a/net/p5-Net-EPP-Client/Makefile b/net/p5-Net-EPP-Client/Makefile
new file mode 100644
index 000000000000..68721ccd56b8
--- /dev/null
+++ b/net/p5-Net-EPP-Client/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: Net-EPP-Client
+# Date created: 18 Feb 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-EPP-Client
+PORTVERSION= 0.05
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Client library for the TCP transport for EPP
+
+BUILD_DEPENDS= ${SITE_PERL}/IO/Socket/SSL.pm:${PORTSDIR}/security/p5-IO-Socket-SSL \
+ ${SITE_PERL}/${PERL_ARCH}/XML/LibXML.pm:${PORTSDIR}/textproc/p5-XML-LibXML \
+ ${SITE_PERL}/Net/EPP/Frame.pm:${PORTSDIR}/net/p5-Net-EPP-Frame
+RUN_DEPENDS+= ${BUILD_DEPENDS}
+
+MAN3= Net::EPP::Client.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-EPP-Client/distinfo b/net/p5-Net-EPP-Client/distinfo
new file mode 100644
index 000000000000..a200088b27ae
--- /dev/null
+++ b/net/p5-Net-EPP-Client/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-EPP-Client-0.05.tar.gz) = e97754aae96b7e502c251693b5da4be0
+SHA256 (Net-EPP-Client-0.05.tar.gz) = 7bf95e94b0d249134a4eb15348de002389a62c279d2708dfde84f633d2a97600
+SIZE (Net-EPP-Client-0.05.tar.gz) = 10927
diff --git a/net/p5-Net-EPP-Client/pkg-descr b/net/p5-Net-EPP-Client/pkg-descr
new file mode 100644
index 000000000000..4353c273df4a
--- /dev/null
+++ b/net/p5-Net-EPP-Client/pkg-descr
@@ -0,0 +1,17 @@
+EPP is the Extensible Provisioning Protocol. EPP (defined in RFC 3730) is
+an application layer client-server protocol for the provisioning and
+management of objects stored in a shared central repository. Specified in
+XML, the protocol defines generic object management operations and an
+extensible framework that maps protocol operations to objects. As of
+writing, its only well-developed application is the provisioning of
+Internet domain names, hosts, and related contact details.
+
+RFC 3734 defines a TCP based transport model for EPP, and this module
+implements a client for that model. You can establish and manage EPP
+connections and send and receive responses over this connection.
+
+Net::EPP::Client also provides some time-saving features, such as being
+able to provide request and response frames as Net::EPP::Frame objects.
+
+WWW: http://search.cpan.org/dist/Net-EPP-Client
+Author: Gavin Brown <epp@centralnic.com>
diff --git a/net/p5-Net-EPP-Client/pkg-plist b/net/p5-Net-EPP-Client/pkg-plist
new file mode 100644
index 000000000000..206119dfddaf
--- /dev/null
+++ b/net/p5-Net-EPP-Client/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Net/EPP/Client.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/EPP/Client/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/EPP/Client
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/EPP
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrmtry %%SITE_PERL%%/Net/EPP
+@dirrmtry %%SITE_PERL%%/Net