aboutsummaryrefslogtreecommitdiffstats
path: root/net/p5-Net-EPP
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2009-11-11 18:50:18 +0800
committerwen <wen@FreeBSD.org>2009-11-11 18:50:18 +0800
commit42159e1f2373fabed05b129e53ca8b4061a59845 (patch)
tree6fdf40ae3043ca2237dce79103006afcbd10b036 /net/p5-Net-EPP
parent70e82a6fff703a0ed4d1b8a2e8d72270a39cd25a (diff)
downloadfreebsd-ports-gnome-42159e1f2373fabed05b129e53ca8b4061a59845.tar.gz
freebsd-ports-gnome-42159e1f2373fabed05b129e53ca8b4061a59845.tar.zst
freebsd-ports-gnome-42159e1f2373fabed05b129e53ca8b4061a59845.zip
- Update to 0.13
Diffstat (limited to 'net/p5-Net-EPP')
-rw-r--r--net/p5-Net-EPP/Makefile49
-rw-r--r--net/p5-Net-EPP/distinfo6
-rw-r--r--net/p5-Net-EPP/pkg-plist51
3 files changed, 95 insertions, 11 deletions
diff --git a/net/p5-Net-EPP/Makefile b/net/p5-Net-EPP/Makefile
index 047594e34852..85fa43691599 100644
--- a/net/p5-Net-EPP/Makefile
+++ b/net/p5-Net-EPP/Makefile
@@ -1,12 +1,12 @@
-# New ports collection makefile for: Net-EPP
+# New ports collection makefile for: Net-EPP-Client
# Date created: 18 Feb 2006
# Whom: Aaron Dalton <aaron@FreeBSD.org>
#
# $FreeBSD$
#
-PORTNAME= Net-EPP-Client
-PORTVERSION= 0.07
+PORTNAME= Net-EPP
+PORTVERSION= 0.13
CATEGORIES= net perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -16,12 +16,49 @@ COMMENT= Client library for the TCP transport for EPP
BUILD_DEPENDS= ${SITE_PERL}/IO/Socket/SSL.pm:${PORTSDIR}/security/p5-IO-Socket-SSL \
${SITE_PERL}/${PERL_ARCH}/XML/LibXML.pm:${PORTSDIR}/textproc/p5-XML-LibXML \
- ${SITE_PERL}/Net/EPP/Frame.pm:${PORTSDIR}/net/p5-Net-EPP-Frame
+ p5-Digest-SHA1>=2.12:${PORTSDIR}/security/p5-Digest-SHA1
RUN_DEPENDS+= ${SITE_PERL}/IO/Socket/SSL.pm:${PORTSDIR}/security/p5-IO-Socket-SSL \
${SITE_PERL}/${PERL_ARCH}/XML/LibXML.pm:${PORTSDIR}/textproc/p5-XML-LibXML \
- ${SITE_PERL}/Net/EPP/Frame.pm:${PORTSDIR}/net/p5-Net-EPP-Frame
+ p5-Digest-SHA1>=2.12:${PORTSDIR}/security/p5-Digest-SHA1
-MAN3= Net::EPP::Client.3
+MAN3= Net::EPP::Client.3 \
+ Net::EPP::Frame.3 \
+ Net::EPP::Frame::Command::Create::Domain.3 \
+ Net::EPP::Protocol.3 \
+ Net::EPP::ResponseCodes.3 \
+ Net::EPP::Simple.3 \
+ Net::EPP::Frame::Command.3 \
+ Net::EPP::Frame::Command::Check.3 \
+ Net::EPP::Frame::Command::Check::Contact.3 \
+ Net::EPP::Frame::Command::Check::Domain.3 \
+ Net::EPP::Frame::Command::Check::Host.3 \
+ Net::EPP::Frame::Command::Create.3 \
+ Net::EPP::Frame::Command::Create::Contact.3 \
+ Net::EPP::Frame::Command::Delete.3 \
+ Net::EPP::Frame::Command::Delete::Contact.3 \
+ Net::EPP::Frame::Command::Delete::Domain.3 \
+ Net::EPP::Frame::Command::Delete::Host.3 \
+ Net::EPP::Frame::Command::Info.3 \
+ Net::EPP::Frame::Command::Info::Contact.3 \
+ Net::EPP::Frame::Command::Info::Domain.3 \
+ Net::EPP::Frame::Command::Info::Host.3 \
+ Net::EPP::Frame::Command::Login.3 \
+ Net::EPP::Frame::Command::Logout.3 \
+ Net::EPP::Frame::Command::Poll.3 \
+ Net::EPP::Frame::Command::Renew.3 \
+ Net::EPP::Frame::Command::Transfer.3 \
+ Net::EPP::Frame::Command::Update.3 \
+ Net::EPP::Frame::Command::Update::Contact.3 \
+ Net::EPP::Frame::Command::Update::Domain.3 \
+ Net::EPP::Frame::Command::Update::Host.3 \
+ Net::EPP::Frame::Greeting.3 \
+ Net::EPP::Frame::Hello.3 \
+ Net::EPP::Frame::ObjectSpec.3 \
+ Net::EPP::Frame::Response.3 \
+ Net::EPP::Frame::Command::Poll::Req.3 \
+ Net::EPP::Frame::Command::Transfer::Domain.3 \
+ Net::EPP::Frame::Command::Transfer::Contact.3 \
+ Net::EPP::Frame::Command::Poll::Ack.3
PERL_CONFIGURE= yes
diff --git a/net/p5-Net-EPP/distinfo b/net/p5-Net-EPP/distinfo
index ff4de4b874bb..21d0536ce954 100644
--- a/net/p5-Net-EPP/distinfo
+++ b/net/p5-Net-EPP/distinfo
@@ -1,3 +1,3 @@
-MD5 (Net-EPP-Client-0.07.tar.gz) = 550e90db037fdd00253b3a6ccf542aa1
-SHA256 (Net-EPP-Client-0.07.tar.gz) = d79c578b0ac8771f88f31f5b814e5a699290f89bada8e310b83371d146085b5e
-SIZE (Net-EPP-Client-0.07.tar.gz) = 11024
+MD5 (Net-EPP-0.13.tar.gz) = 2e003a75b9e1103f42b2546fff0030c1
+SHA256 (Net-EPP-0.13.tar.gz) = 200951b58e2cd2cc2e73d8a89968e6f2d9085e8c787f9642603b2b633b478aec
+SIZE (Net-EPP-0.13.tar.gz) = 32437
diff --git a/net/p5-Net-EPP/pkg-plist b/net/p5-Net-EPP/pkg-plist
index 206119dfddaf..127407406452 100644
--- a/net/p5-Net-EPP/pkg-plist
+++ b/net/p5-Net-EPP/pkg-plist
@@ -1,7 +1,54 @@
%%SITE_PERL%%/Net/EPP/Client.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/EPP/Client/.packlist
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/EPP/Client
+%%SITE_PERL%%/Net/EPP/Frame/Command/Create/Domain.pm
+%%SITE_PERL%%/Net/EPP/Frame/Command/Create/Host.pm
+%%SITE_PERL%%/Net/EPP/Protocol.pm
+%%SITE_PERL%%/Net/EPP/ResponseCodes.pm
+%%SITE_PERL%%/Net/EPP/Simple.pm
+%%SITE_PERL%%/Net/EPP.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/EPP/.packlist
+%%SITE_PERL%%/Net/EPP/Frame.pm
+%%SITE_PERL%%/Net/EPP/Frame/Command.pm
+%%SITE_PERL%%/Net/EPP/Frame/Command/Check.pm
+%%SITE_PERL%%/Net/EPP/Frame/Command/Check/Contact.pm
+%%SITE_PERL%%/Net/EPP/Frame/Command/Check/Domain.pm
+%%SITE_PERL%%/Net/EPP/Frame/Command/Check/Host.pm
+%%SITE_PERL%%/Net/EPP/Frame/Command/Create.pm
+%%SITE_PERL%%/Net/EPP/Frame/Command/Create/Contact.pm
+%%SITE_PERL%%/Net/EPP/Frame/Command/Delete.pm
+%%SITE_PERL%%/Net/EPP/Frame/Command/Delete/Contact.pm
+%%SITE_PERL%%/Net/EPP/Frame/Command/Delete/Domain.pm
+%%SITE_PERL%%/Net/EPP/Frame/Command/Delete/Host.pm
+%%SITE_PERL%%/Net/EPP/Frame/Command/Info.pm
+%%SITE_PERL%%/Net/EPP/Frame/Command/Info/Contact.pm
+%%SITE_PERL%%/Net/EPP/Frame/Command/Info/Domain.pm
+%%SITE_PERL%%/Net/EPP/Frame/Command/Info/Host.pm
+%%SITE_PERL%%/Net/EPP/Frame/Command/Login.pm
+%%SITE_PERL%%/Net/EPP/Frame/Command/Logout.pm
+%%SITE_PERL%%/Net/EPP/Frame/Command/Poll.pm
+%%SITE_PERL%%/Net/EPP/Frame/Command/Poll/Req.pm
+%%SITE_PERL%%/Net/EPP/Frame/Command/Poll/Ack.pm
+%%SITE_PERL%%/Net/EPP/Frame/Command/Renew.pm
+%%SITE_PERL%%/Net/EPP/Frame/Command/Transfer.pm
+%%SITE_PERL%%/Net/EPP/Frame/Command/Transfer/Domain.pm
+%%SITE_PERL%%/Net/EPP/Frame/Command/Transfer/Contact.pm
+%%SITE_PERL%%/Net/EPP/Frame/Command/Update.pm
+%%SITE_PERL%%/Net/EPP/Frame/Command/Update/Contact.pm
+%%SITE_PERL%%/Net/EPP/Frame/Command/Update/Domain.pm
+%%SITE_PERL%%/Net/EPP/Frame/Command/Update/Host.pm
+%%SITE_PERL%%/Net/EPP/Frame/Greeting.pm
+%%SITE_PERL%%/Net/EPP/Frame/Hello.pm
+%%SITE_PERL%%/Net/EPP/Frame/ObjectSpec.pm
+%%SITE_PERL%%/Net/EPP/Frame/Response.pm
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/EPP
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrm %%SITE_PERL%%/Net/EPP/Frame/Command/Update
+@dirrm %%SITE_PERL%%/Net/EPP/Frame/Command/Info
+@dirrm %%SITE_PERL%%/Net/EPP/Frame/Command/Delete
+@dirrm %%SITE_PERL%%/Net/EPP/Frame/Command/Create
+@dirrm %%SITE_PERL%%/Net/EPP/Frame/Command/Check
+@dirrm %%SITE_PERL%%/Net/EPP/Frame/Command/Poll
+@dirrm %%SITE_PERL%%/Net/EPP/Frame/Command/Transfer
+@dirrm %%SITE_PERL%%/Net/EPP/Frame/Command
+@dirrm %%SITE_PERL%%/Net/EPP/Frame
@dirrmtry %%SITE_PERL%%/Net/EPP
@dirrmtry %%SITE_PERL%%/Net