aboutsummaryrefslogtreecommitdiffstats
path: root/net/p5-Net-Frame-Simple
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2016-10-16 04:40:36 +0800
committerpi <pi@FreeBSD.org>2016-10-16 04:40:36 +0800
commit48f597ec095eab00471102abc329466cda6b6eb9 (patch)
tree459e7392ea34440841fb6fee103dfc3c8be8b969 /net/p5-Net-Frame-Simple
parent8f9a5513371e7360b17797ddb280a6e5296dee65 (diff)
downloadfreebsd-ports-gnome-48f597ec095eab00471102abc329466cda6b6eb9.tar.gz
freebsd-ports-gnome-48f597ec095eab00471102abc329466cda6b6eb9.tar.zst
freebsd-ports-gnome-48f597ec095eab00471102abc329466cda6b6eb9.zip
New port: net/p5-Net-Frame-Simple
Frame crafting made easy This module is part of Net::Frame frame crafting framework. It is totally optional, but can make playing with the network far easier. Basically, it hides the complexity of frame forging, sending, and receiving, by providing helper methods, which will analyze internally how to assemble frames and find responses to probes. For example, it will take care of computing lengths and checksums, and matching a response frame to the requesting frame. WWW: http://search.cpan.org/dist/Net-Frame-Simple/
Diffstat (limited to 'net/p5-Net-Frame-Simple')
-rw-r--r--net/p5-Net-Frame-Simple/Makefile22
-rw-r--r--net/p5-Net-Frame-Simple/distinfo3
-rw-r--r--net/p5-Net-Frame-Simple/pkg-descr13
-rw-r--r--net/p5-Net-Frame-Simple/pkg-plist2
4 files changed, 40 insertions, 0 deletions
diff --git a/net/p5-Net-Frame-Simple/Makefile b/net/p5-Net-Frame-Simple/Makefile
new file mode 100644
index 000000000000..eacd958ad008
--- /dev/null
+++ b/net/p5-Net-Frame-Simple/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= Net-Frame-Simple
+PORTVERSION= 1.07
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Base framework for frame crafting
+
+LICENSE= ART10
+
+BUILD_DEPENDS= p5-Net-Frame>=1.16:net/p5-Net-Frame \
+ p5-Class-Gomor>=1.03:devel/p5-Class-Gomor
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USES= perl5
+USE_PERL5= configure
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-Frame-Simple/distinfo b/net/p5-Net-Frame-Simple/distinfo
new file mode 100644
index 000000000000..2094249fdb91
--- /dev/null
+++ b/net/p5-Net-Frame-Simple/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1476561188
+SHA256 (Net-Frame-Simple-1.07.tar.gz) = 4ea46c0d9cb4a2dace4d3d022cb1c3e80dc9d645ae38c124ee485cfdc828814e
+SIZE (Net-Frame-Simple-1.07.tar.gz) = 10944
diff --git a/net/p5-Net-Frame-Simple/pkg-descr b/net/p5-Net-Frame-Simple/pkg-descr
new file mode 100644
index 000000000000..58fccd558cba
--- /dev/null
+++ b/net/p5-Net-Frame-Simple/pkg-descr
@@ -0,0 +1,13 @@
+Frame crafting made easy
+
+This module is part of Net::Frame frame crafting framework. It is
+totally optional, but can make playing with the network far easier.
+
+Basically, it hides the complexity of frame forging, sending, and
+receiving, by providing helper methods, which will analyze internally
+how to assemble frames and find responses to probes.
+
+For example, it will take care of computing lengths and checksums,
+and matching a response frame to the requesting frame.
+
+WWW: http://search.cpan.org/dist/Net-Frame-Simple/
diff --git a/net/p5-Net-Frame-Simple/pkg-plist b/net/p5-Net-Frame-Simple/pkg-plist
new file mode 100644
index 000000000000..8fe9f4e1ea14
--- /dev/null
+++ b/net/p5-Net-Frame-Simple/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_PERL%%/Net/Frame/Simple.pm
+%%PERL5_MAN3%%/Net::Frame::Simple.3.gz