aboutsummaryrefslogtreecommitdiffstats
path: root/net/p5-Net-Google-Calendar
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2006-06-21 03:10:56 +0800
committermat <mat@FreeBSD.org>2006-06-21 03:10:56 +0800
commit0456059c7a036599b2ff330a1f6639164146222b (patch)
tree18b30a33c944266081e4b0679622d801b1701a21 /net/p5-Net-Google-Calendar
parent74a4f0eda5311ab6a55874d90e5ee9563c97813c (diff)
downloadfreebsd-ports-gnome-0456059c7a036599b2ff330a1f6639164146222b.tar.gz
freebsd-ports-gnome-0456059c7a036599b2ff330a1f6639164146222b.tar.zst
freebsd-ports-gnome-0456059c7a036599b2ff330a1f6639164146222b.zip
Fixes empty gd:* fields in get_events() result.
This is caused by an improper type casting from XML::Atom::Entry to Net::Google::Calendar::Entry. PR: 99192 Submitted by: maintainer
Diffstat (limited to 'net/p5-Net-Google-Calendar')
-rw-r--r--net/p5-Net-Google-Calendar/Makefile1
-rw-r--r--net/p5-Net-Google-Calendar/files/patch-Entry37
2 files changed, 38 insertions, 0 deletions
diff --git a/net/p5-Net-Google-Calendar/Makefile b/net/p5-Net-Google-Calendar/Makefile
index c888090de53a..0706c52a3bfa 100644
--- a/net/p5-Net-Google-Calendar/Makefile
+++ b/net/p5-Net-Google-Calendar/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Net-Google-Calendar
DISTVERSION= 0.2_devel
+PORTREVISION= 1
CATEGORIES= net perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Net
diff --git a/net/p5-Net-Google-Calendar/files/patch-Entry b/net/p5-Net-Google-Calendar/files/patch-Entry
new file mode 100644
index 000000000000..3b5e8339c2b0
--- /dev/null
+++ b/net/p5-Net-Google-Calendar/files/patch-Entry
@@ -0,0 +1,37 @@
+diff -ur lib/Net/Google/Calendar/Entry.pm lib/Net/Google/Calendar/Entry.pm
+--- lib/Net/Google/Calendar/Entry.pm Thu Jun 15 17:42:23 2006
++++ lib/Net/Google/Calendar/Entry.pm Tue Jun 20 00:50:28 2006
+@@ -45,10 +45,19 @@
+ my ($class, %opts) = @_;
+
+ my $self = $class->SUPER::new( Version => '1.0', %opts );
+- $self->category('', { scheme => 'http://schemas.google.com/g/2005#kind', term => 'http://schemas.google.com/g/2005#event' } );
+
+- $self->{_gd_ns} = XML::Atom::Namespace->new(gd => 'http://schemas.google.com/g/2005');
++ $self->_initialize();
++
+ return $self;
++}
++
++sub _initialize
++{
++ my $self = shift;
++
++ $self->category('', { scheme => 'http://schemas.google.com/g/2005#kind', term => 'http://schemas.google.com/g/2005#event' } );
++
++ $self->{_gd_ns} = XML::Atom::Namespace->new(gd => 'http://schemas.google.com/g/2005');
+ }
+
+ =head2 id [id]
+diff -ur lib/Net/Google/Calendar.pm lib/Net/Google/Calendar.pm
+--- lib/Net/Google/Calendar.pm Tue Jun 20 01:32:37 2006
++++ lib/Net/Google/Calendar.pm Tue Jun 20 00:59:16 2006
+@@ -293,7 +293,7 @@
+ my $atom = $r->content;
+
+ my $feed = XML::Atom::Feed->new(\$atom);
+- return map { bless $_, 'Net::Google::Calendar::Entry' } $feed->entries;
++ return map { bless $_, 'Net::Google::Calendar::Entry'; $_->_initialize(); $_ } $feed->entries;
+ }
+
+