aboutsummaryrefslogtreecommitdiffstats
path: root/net/p5-Net-Interface
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2006-09-27 16:58:08 +0800
committerclsung <clsung@FreeBSD.org>2006-09-27 16:58:08 +0800
commit656f1ddc772e7430aace3a87696e685a454565a8 (patch)
tree30295d9bc090116bd2adf2690114e3bbf6b42243 /net/p5-Net-Interface
parent1538779424c42d25db1bb17e6832727bc8f3c132 (diff)
downloadfreebsd-ports-gnome-656f1ddc772e7430aace3a87696e685a454565a8.tar.gz
freebsd-ports-gnome-656f1ddc772e7430aace3a87696e685a454565a8.tar.zst
freebsd-ports-gnome-656f1ddc772e7430aace3a87696e685a454565a8.zip
Add p5-Net-Interface 0.08, perl extension to access network interfaces.
PR: ports/103108 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Diffstat (limited to 'net/p5-Net-Interface')
-rw-r--r--net/p5-Net-Interface/Makefile22
-rw-r--r--net/p5-Net-Interface/distinfo3
-rw-r--r--net/p5-Net-Interface/pkg-descr6
-rw-r--r--net/p5-Net-Interface/pkg-plist8
4 files changed, 39 insertions, 0 deletions
diff --git a/net/p5-Net-Interface/Makefile b/net/p5-Net-Interface/Makefile
new file mode 100644
index 000000000000..8ccb2551c68c
--- /dev/null
+++ b/net/p5-Net-Interface/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-Net-Interface
+# Date created: 2006-09-11
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Interface
+PORTVERSION= 0.08
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= Perl extension to access network interfaces
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::Interface.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-Interface/distinfo b/net/p5-Net-Interface/distinfo
new file mode 100644
index 000000000000..688e486737ba
--- /dev/null
+++ b/net/p5-Net-Interface/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-Interface-0.08.tar.gz) = c4995cf4ffa219b47ca601764f6680da
+SHA256 (Net-Interface-0.08.tar.gz) = 242d37dc0c18491429d3e71a442e2ef231f4f085ec5914c8dbfcd809ddd0f529
+SIZE (Net-Interface-0.08.tar.gz) = 10037
diff --git a/net/p5-Net-Interface/pkg-descr b/net/p5-Net-Interface/pkg-descr
new file mode 100644
index 000000000000..e77e783e9ce5
--- /dev/null
+++ b/net/p5-Net-Interface/pkg-descr
@@ -0,0 +1,6 @@
+Net::Interface is designed to make the use of ifconfig(1) and friends
+unnecessary from within Perl. It provides methods to get at set all
+the attributes of an interface, and even create new logical or
+physical interfaces (if your O/S supports it).
+
+WWW: http://search.cpan.org/dist/Net-Interface/
diff --git a/net/p5-Net-Interface/pkg-plist b/net/p5-Net-Interface/pkg-plist
new file mode 100644
index 000000000000..8fefe47433af
--- /dev/null
+++ b/net/p5-Net-Interface/pkg-plist
@@ -0,0 +1,8 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/Net/Interface.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Interface/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Interface/Interface.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Interface/Interface.so
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Net
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Interface
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net