aboutsummaryrefslogtreecommitdiffstats
path: root/net/p5-Net-Riak
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2010-11-24 13:19:50 +0800
committerpgollucci <pgollucci@FreeBSD.org>2010-11-24 13:19:50 +0800
commitbdb19278dac576ddb2e93d35392167b5938284fe (patch)
treedd6466a83f5282d1da9c115f9793356feb4a496c /net/p5-Net-Riak
parent198344c8d0fa41c4393546a76cffab4fa3288dba (diff)
downloadfreebsd-ports-gnome-bdb19278dac576ddb2e93d35392167b5938284fe.tar.gz
freebsd-ports-gnome-bdb19278dac576ddb2e93d35392167b5938284fe.tar.zst
freebsd-ports-gnome-bdb19278dac576ddb2e93d35392167b5938284fe.zip
Interface to Riak.
WWW: http://search.cpan.org/dist/Net-Riak/ PR: ports/152277 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Diffstat (limited to 'net/p5-Net-Riak')
-rw-r--r--net/p5-Net-Riak/Makefile39
-rw-r--r--net/p5-Net-Riak/distinfo2
-rw-r--r--net/p5-Net-Riak/pkg-descr3
-rw-r--r--net/p5-Net-Riak/pkg-plist21
4 files changed, 65 insertions, 0 deletions
diff --git a/net/p5-Net-Riak/Makefile b/net/p5-Net-Riak/Makefile
new file mode 100644
index 000000000000..0e39711f59a9
--- /dev/null
+++ b/net/p5-Net-Riak/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: p5-Net-Riak
+# Date created: 2010-11-15
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Riak
+PORTVERSION= 0.11
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Interface to Riak
+
+RUN_DEPENDS= p5-JSON>0:${PORTSDIR}/converters/p5-JSON \
+ p5-Moose>0:${PORTSDIR}/devel/p5-Moose \
+ p5-URI>0:${PORTSDIR}/net/p5-URI \
+ p5-libwww>0:${PORTSDIR}/www/p5-libwww
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::Riak.3 \
+ Net::Riak::Bucket.3 \
+ Net::Riak::Client.3 \
+ Net::Riak::Link.3 \
+ Net::Riak::LinkPhase.3 \
+ Net::Riak::MapReduce.3 \
+ Net::Riak::MapReducePhase.3 \
+ Net::Riak::Object.3 \
+ Net::Riak::Role::Base.3 \
+ Net::Riak::Role::Hosts.3 \
+ Net::Riak::Role::MapReduce.3 \
+ Net::Riak::Role::REST.3 \
+ Net::Riak::Role::Replica.3 \
+ Net::Riak::Role::UserAgent.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-Riak/distinfo b/net/p5-Net-Riak/distinfo
new file mode 100644
index 000000000000..fc3de947f1a0
--- /dev/null
+++ b/net/p5-Net-Riak/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Net-Riak-0.11.tar.gz) = 93c2ab6e9d25663dff507dda4b2398fea4990f10a6037cadf92c358c390a90f1
+SIZE (Net-Riak-0.11.tar.gz) = 24571
diff --git a/net/p5-Net-Riak/pkg-descr b/net/p5-Net-Riak/pkg-descr
new file mode 100644
index 000000000000..7cea4bf7f35b
--- /dev/null
+++ b/net/p5-Net-Riak/pkg-descr
@@ -0,0 +1,3 @@
+Interface to Riak.
+
+WWW: http://search.cpan.org/dist/Net-Riak/
diff --git a/net/p5-Net-Riak/pkg-plist b/net/p5-Net-Riak/pkg-plist
new file mode 100644
index 000000000000..a8de4cabebe9
--- /dev/null
+++ b/net/p5-Net-Riak/pkg-plist
@@ -0,0 +1,21 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Riak/.packlist
+%%SITE_PERL%%/Net/Riak.pm
+%%SITE_PERL%%/Net/Riak/Bucket.pm
+%%SITE_PERL%%/Net/Riak/Client.pm
+%%SITE_PERL%%/Net/Riak/Link.pm
+%%SITE_PERL%%/Net/Riak/LinkPhase.pm
+%%SITE_PERL%%/Net/Riak/MapReduce.pm
+%%SITE_PERL%%/Net/Riak/MapReducePhase.pm
+%%SITE_PERL%%/Net/Riak/Object.pm
+%%SITE_PERL%%/Net/Riak/Role/Base.pm
+%%SITE_PERL%%/Net/Riak/Role/Hosts.pm
+%%SITE_PERL%%/Net/Riak/Role/MapReduce.pm
+%%SITE_PERL%%/Net/Riak/Role/REST.pm
+%%SITE_PERL%%/Net/Riak/Role/Replica.pm
+%%SITE_PERL%%/Net/Riak/Role/UserAgent.pm
+@dirrmtry %%SITE_PERL%%/Net/Riak/Role
+@dirrmtry %%SITE_PERL%%/Net/Riak
+@dirrmtry %%SITE_PERL%%/Net
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Riak
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net