aboutsummaryrefslogtreecommitdiffstats
path: root/net/p5-Net-SSH-Perl
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2012-06-05 17:46:27 +0800
committeraz <az@FreeBSD.org>2012-06-05 17:46:27 +0800
commit4574ffe9036b84f48419470da75f7ec3409a0708 (patch)
treef3f5dc48c578bd7cf17f03507f70413a51ccd1c5 /net/p5-Net-SSH-Perl
parent53f74cd8d74f4194faedfb24f1e97bc6be94ca1e (diff)
downloadfreebsd-ports-gnome-4574ffe9036b84f48419470da75f7ec3409a0708.tar.gz
freebsd-ports-gnome-4574ffe9036b84f48419470da75f7ec3409a0708.tar.zst
freebsd-ports-gnome-4574ffe9036b84f48419470da75f7ec3409a0708.zip
- Remove SITE_PERL from *_DEPENDS
Diffstat (limited to 'net/p5-Net-SSH-Perl')
-rw-r--r--net/p5-Net-SSH-Perl/Makefile24
1 files changed, 12 insertions, 12 deletions
diff --git a/net/p5-Net-SSH-Perl/Makefile b/net/p5-Net-SSH-Perl/Makefile
index 08d18a8cf8c5..fc37700d0c88 100644
--- a/net/p5-Net-SSH-Perl/Makefile
+++ b/net/p5-Net-SSH-Perl/Makefile
@@ -15,17 +15,17 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl5 module implements both the SSH1 and SSH2 protocols
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/String/CRC32.pm:${PORTSDIR}/devel/p5-String-CRC32 \
- ${SITE_PERL}/${PERL_ARCH}/Math/GMP.pm:${PORTSDIR}/math/p5-Math-GMP \
- ${SITE_PERL}/Digest/HMAC_MD5.pm:${PORTSDIR}/security/p5-Digest-HMAC \
- ${SITE_PERL}/Digest/HMAC_SHA1.pm:${PORTSDIR}/security/p5-Digest-HMAC \
- ${SITE_PERL}/Crypt/DSA.pm:${PORTSDIR}/security/p5-Crypt-DSA \
- ${SITE_PERL}/Crypt/DH.pm:${PORTSDIR}/security/p5-Crypt-DH \
- ${SITE_PERL}/${PERL_ARCH}/Math/Pari.pm:${PORTSDIR}/math/p5-Math-Pari \
- ${SITE_PERL}/Convert/PEM.pm:${PORTSDIR}/converters/p5-Convert-PEM \
- ${SITE_PERL}/${PERL_ARCH}/Crypt/IDEA.pm:${PORTSDIR}/security/p5-Crypt-IDEA \
- ${SITE_PERL}/Digest/BubbleBabble.pm:${PORTSDIR}/security/p5-Digest-BubbleBabble \
- ${SITE_PERL}/Crypt/RSA.pm:${PORTSDIR}/security/p5-Crypt-RSA
+BUILD_DEPENDS= p5-String-CRC32>=0:${PORTSDIR}/devel/p5-String-CRC32 \
+ p5-Math-GMP>=0:${PORTSDIR}/math/p5-Math-GMP \
+ p5-Digest-HMAC>=0:${PORTSDIR}/security/p5-Digest-HMAC \
+ p5-Digest-HMAC>=0:${PORTSDIR}/security/p5-Digest-HMAC \
+ p5-Crypt-DSA>=0:${PORTSDIR}/security/p5-Crypt-DSA \
+ p5-Crypt-DH>=0:${PORTSDIR}/security/p5-Crypt-DH \
+ p5-Math-Pari>=0:${PORTSDIR}/math/p5-Math-Pari \
+ p5-Convert-PEM>=0:${PORTSDIR}/converters/p5-Convert-PEM \
+ p5-Crypt-IDEA>=0:${PORTSDIR}/security/p5-Crypt-IDEA \
+ p5-Digest-BubbleBabble>=0:${PORTSDIR}/security/p5-Digest-BubbleBabble \
+ p5-Crypt-RSA>=0:${PORTSDIR}/security/p5-Crypt-RSA
RUN_DEPENDS:= ${BUILD_DEPENDS}
MAN3= Net::SSH::Perl.3 \
@@ -78,7 +78,7 @@ GMP_DESC= Use the optimized Math::BigInt::GMP backend
.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MGMP}
-GMP_DEPEND= ${SITE_PERL}/${PERL_ARCH}/Math/BigInt/GMP.pm:${PORTSDIR}/math/p5-Math-BigInt-GMP
+GMP_DEPEND= p5-Math-BigInt-GMP>=0:${PORTSDIR}/math/p5-Math-BigInt-GMP
BUILD_DEPENDS+= ${GMP_DEPEND}
RUN_DEPENDS+= ${GMP_DEPEND}
.endif