aboutsummaryrefslogtreecommitdiffstats
path: root/net/p5-Net-SSH2
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2007-03-02 09:46:20 +0800
committerclsung <clsung@FreeBSD.org>2007-03-02 09:46:20 +0800
commitdfe6dce16c216a6bacab5f1ae4796b7b39d04e67 (patch)
treecc9b9e6f8c487ecd05b53de80564142a6ff2a5c9 /net/p5-Net-SSH2
parent4bc008822e95a8bf031cb2f59bc48078d57f64b9 (diff)
downloadfreebsd-ports-gnome-dfe6dce16c216a6bacab5f1ae4796b7b39d04e67.tar.gz
freebsd-ports-gnome-dfe6dce16c216a6bacab5f1ae4796b7b39d04e67.tar.zst
freebsd-ports-gnome-dfe6dce16c216a6bacab5f1ae4796b7b39d04e67.zip
Add p5-Net-SSH2 0.10, support for the SSH 2 protocol via libSSH2.
PR: ports/109702 Submitted by: Jin-Shan Tseng <tjs at cdpa.nsysu.edu.tw>
Diffstat (limited to 'net/p5-Net-SSH2')
-rw-r--r--net/p5-Net-SSH2/Makefile27
-rw-r--r--net/p5-Net-SSH2/distinfo3
-rw-r--r--net/p5-Net-SSH2/pkg-descr12
-rw-r--r--net/p5-Net-SSH2/pkg-plist16
4 files changed, 58 insertions, 0 deletions
diff --git a/net/p5-Net-SSH2/Makefile b/net/p5-Net-SSH2/Makefile
new file mode 100644
index 000000000000..f3f82335d9a0
--- /dev/null
+++ b/net/p5-Net-SSH2/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-Net-SSH2
+# Date created: 2007-03-01
+# Whom: Jin-Shan Tseng <tjs@cdpa.nsysu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-SSH2
+PORTVERSION= 0.10
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tjs@cdpa.nsysu.edu.tw
+COMMENT= Support for the SSH 2 protocol via libSSH2
+
+LIB_DEPENDS= ssh2.0:${PORTSDIR}/security/libssh2
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::SSH2.3 Net::SSH2::Channel.3 \
+ Net::SSH2::Dir.3 Net::SSH2::File.3 \
+ Net::SSH2::Listener.3 Net::SSH2::PublicKey.3 \
+ Net::SSH2::SFTP.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-SSH2/distinfo b/net/p5-Net-SSH2/distinfo
new file mode 100644
index 000000000000..13526e4a93ef
--- /dev/null
+++ b/net/p5-Net-SSH2/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-SSH2-0.10.tar.gz) = e28a317480814895b955bb3342a10f34
+SHA256 (Net-SSH2-0.10.tar.gz) = 280fbd486bdda45734d5348aabb4dd2333d6987c4b5e7c4f87efcdcf3810475b
+SIZE (Net-SSH2-0.10.tar.gz) = 66547
diff --git a/net/p5-Net-SSH2/pkg-descr b/net/p5-Net-SSH2/pkg-descr
new file mode 100644
index 000000000000..116baa3c9367
--- /dev/null
+++ b/net/p5-Net-SSH2/pkg-descr
@@ -0,0 +1,12 @@
+Net::SSH2 is a perl interface to the libssh2 (http://www.libssh2.org) library.
+It supports the SSH2 protocol (there is no support for SSH1) with all of the
+key exchanges, ciphers, and compression of libssh2.
+
+Unless otherwise indicated, methods return a true value on success and false
+on failure; use the error method to get extended error information.
+
+The typical order is to create the SSH2 object, set up the connection methods
+you want to use, call connect, authenticate with one of the auth methods, then
+create channels on the connection to perform commands.
+
+WWW: http://search.cpan.org/dist/Net-SSH2/
diff --git a/net/p5-Net-SSH2/pkg-plist b/net/p5-Net-SSH2/pkg-plist
new file mode 100644
index 000000000000..ad2490192519
--- /dev/null
+++ b/net/p5-Net-SSH2/pkg-plist
@@ -0,0 +1,16 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/Net/SSH2.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Net/SSH2/Channel.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Net/SSH2/Dir.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Net/SSH2/File.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Net/SSH2/Listener.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Net/SSH2/PublicKey.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Net/SSH2/SFTP.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/SSH2/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/SSH2/SSH2.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/SSH2/SSH2.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/SSH2/autosplit.ix
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Net/SSH2
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Net
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/SSH2
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net