aboutsummaryrefslogtreecommitdiffstats
path: root/net/p5-Net-Subnet
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-10-26 19:08:02 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-10-26 19:08:02 +0800
commit8e7b4cdc7267cda5becbcfa12ea2be6b273eec6e (patch)
tree5f3dbcc32ee6f6ae6e0598524a93880fabf4088c /net/p5-Net-Subnet
parent35764a21de4c5103baf51485f284f3f9d4ca4297 (diff)
downloadfreebsd-ports-gnome-8e7b4cdc7267cda5becbcfa12ea2be6b273eec6e.tar.gz
freebsd-ports-gnome-8e7b4cdc7267cda5becbcfa12ea2be6b273eec6e.tar.zst
freebsd-ports-gnome-8e7b4cdc7267cda5becbcfa12ea2be6b273eec6e.zip
- Add p5-Net-Subnet 1.02
This is a simple but fast pure Perl module for determining whether a given IP address is in a given set of IP subnets. It's iterative, and it doesn't use any fancy tries, but because it uses simple bitwise operations on strings it's still very fast. All documented functions are exported by default. Subnets have to be given in "address/mask" or "address/length" (CIDR) format. The Socket and Socket6 modules are used to normalise addresses, which means that any of the address formats supported by inet_aton and inet_pton can be used with Net::Subnet. WWW: http://search.cpan.org/dist/Net-Subnet/ PR: ports/161335 Submitted by: Henk van Oers <hvo.pm@xs4all.nl>
Diffstat (limited to 'net/p5-Net-Subnet')
-rw-r--r--net/p5-Net-Subnet/Makefile26
-rw-r--r--net/p5-Net-Subnet/distinfo2
-rw-r--r--net/p5-Net-Subnet/pkg-descr13
-rw-r--r--net/p5-Net-Subnet/pkg-plist5
4 files changed, 46 insertions, 0 deletions
diff --git a/net/p5-Net-Subnet/Makefile b/net/p5-Net-Subnet/Makefile
new file mode 100644
index 000000000000..27dc2f66efdd
--- /dev/null
+++ b/net/p5-Net-Subnet/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-Net-Subnet
+# Date created: 2011-10-06
+# Whom: Henk van Oers <hvo.pm@xs4all.nl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Subnet
+PORTVERSION= 1.02
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Fast IP-in-subnet matcher for IPv4 and IPv6, CIDR or mask
+
+LICENSE= ART10
+
+BUILD_DEPENDS= p5-Socket6>=0.23:${PORTSDIR}/net/p5-Socket6
+RUN_DEPENDS= p5-Socket6>=0.23:${PORTSDIR}/net/p5-Socket6
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::Subnet.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-Subnet/distinfo b/net/p5-Net-Subnet/distinfo
new file mode 100644
index 000000000000..1ea3956e5374
--- /dev/null
+++ b/net/p5-Net-Subnet/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Net-Subnet-1.02.tar.gz) = 1ba32e2b33160eddfe3c210298a201a2d54d3e9a1d0095d5f173ece795db98f0
+SIZE (Net-Subnet-1.02.tar.gz) = 4103
diff --git a/net/p5-Net-Subnet/pkg-descr b/net/p5-Net-Subnet/pkg-descr
new file mode 100644
index 000000000000..47a4a31ccd41
--- /dev/null
+++ b/net/p5-Net-Subnet/pkg-descr
@@ -0,0 +1,13 @@
+This is a simple but fast pure Perl module for determining whether a given IP
+address is in a given set of IP subnets. It's iterative, and it doesn't use any
+fancy tries, but because it uses simple bitwise operations on strings it's still
+very fast.
+
+All documented functions are exported by default.
+
+Subnets have to be given in "address/mask" or "address/length" (CIDR) format.
+The Socket and Socket6 modules are used to normalise addresses, which means that
+any of the address formats supported by inet_aton and inet_pton can be used with
+Net::Subnet.
+
+WWW: http://search.cpan.org/dist/Net-Subnet/
diff --git a/net/p5-Net-Subnet/pkg-plist b/net/p5-Net-Subnet/pkg-plist
new file mode 100644
index 000000000000..8b0799359774
--- /dev/null
+++ b/net/p5-Net-Subnet/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Subnet/.packlist
+%%SITE_PERL%%/Net/Subnet.pm
+@dirrmtry %%SITE_PERL%%/Net
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Subnet
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net