aboutsummaryrefslogtreecommitdiffstats
path: root/net/p5-Net-Wake
diff options
context:
space:
mode:
authordougb <dougb@FreeBSD.org>2001-04-16 03:15:19 +0800
committerdougb <dougb@FreeBSD.org>2001-04-16 03:15:19 +0800
commit291e97eceac2c5b6d0fa3bc9bf12cf5194c3f2fa (patch)
tree841b20536c4d3f4a01ab6033a45714e3704a3a06 /net/p5-Net-Wake
parentadbacbeb424e2b62951925192a8dffebffffbc58 (diff)
downloadfreebsd-ports-gnome-291e97eceac2c5b6d0fa3bc9bf12cf5194c3f2fa.tar.gz
freebsd-ports-gnome-291e97eceac2c5b6d0fa3bc9bf12cf5194c3f2fa.tar.zst
freebsd-ports-gnome-291e97eceac2c5b6d0fa3bc9bf12cf5194c3f2fa.zip
Add p5-Net-Wake 0.01, Send Wake On Lan (WOL) packets to power on computers.
PR: 26595 Submitted by: Yoshihiko Sarumaru <mistral@imasy.or.jp>
Diffstat (limited to 'net/p5-Net-Wake')
-rw-r--r--net/p5-Net-Wake/Makefile22
-rw-r--r--net/p5-Net-Wake/distinfo1
-rw-r--r--net/p5-Net-Wake/pkg-comment1
-rw-r--r--net/p5-Net-Wake/pkg-descr15
-rw-r--r--net/p5-Net-Wake/pkg-plist5
5 files changed, 44 insertions, 0 deletions
diff --git a/net/p5-Net-Wake/Makefile b/net/p5-Net-Wake/Makefile
new file mode 100644
index 000000000000..e3a1cac9c2c2
--- /dev/null
+++ b/net/p5-Net-Wake/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-Net-Wake-0.01
+# Date created: 15 April 2001
+# Whom: Yoshihiko Sarumaru <mistral@imasy.or.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Wake
+PORTVERSION= 0.01
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= mistral@imasy.or.jp
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Net::Wake.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-Wake/distinfo b/net/p5-Net-Wake/distinfo
new file mode 100644
index 000000000000..4f9a0783eff8
--- /dev/null
+++ b/net/p5-Net-Wake/distinfo
@@ -0,0 +1 @@
+MD5 (Net-Wake-0.01.tar.gz) = f6b9d89888153ef4f8c0e55456f6c80e
diff --git a/net/p5-Net-Wake/pkg-comment b/net/p5-Net-Wake/pkg-comment
new file mode 100644
index 000000000000..52cc5b4241da
--- /dev/null
+++ b/net/p5-Net-Wake/pkg-comment
@@ -0,0 +1 @@
+Send Wake On Lan (WOL) packets to power on computers
diff --git a/net/p5-Net-Wake/pkg-descr b/net/p5-Net-Wake/pkg-descr
new file mode 100644
index 000000000000..0d54bd75af9b
--- /dev/null
+++ b/net/p5-Net-Wake/pkg-descr
@@ -0,0 +1,15 @@
+This package sends wake-on-lan packets to turn on machines
+that are wake-on-lan capable.
+
+For now there is only one function in this package:
+
+Net::Wake::by_udp(host, mac_address, [port]);
+
+You can power on PCs by
+perl -e 'use Net::Wake; Net::Wake::by_udp("192.168.0.1", "xx:xx:xx:xx:xx:xx");'
+
+You can also specify broadcast address for `host'. It is useful in a
+intelligent network.
+
+--
+Yoshihiko Sarumaru <mistral@imasy.or.jp>
diff --git a/net/p5-Net-Wake/pkg-plist b/net/p5-Net-Wake/pkg-plist
new file mode 100644
index 000000000000..f7a2486892f7
--- /dev/null
+++ b/net/p5-Net-Wake/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/Net/Wake.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/Wake/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/Wake
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Net 2>/dev/null || true