aboutsummaryrefslogtreecommitdiffstats
path: root/net/p5-Net-Z3950-ZOOM/Makefile
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2006-12-24 00:04:33 +0800
committerdemon <demon@FreeBSD.org>2006-12-24 00:04:33 +0800
commitf021072bd14ddfb426921f22a7122d49d643a7a7 (patch)
tree3b8946ac92cb8d60713ebad0b72d09bfb6482b53 /net/p5-Net-Z3950-ZOOM/Makefile
parentbb1fc4154c78e981cd5a6c5daa8e6ffdb3620476 (diff)
downloadfreebsd-ports-gnome-f021072bd14ddfb426921f22a7122d49d643a7a7.tar.gz
freebsd-ports-gnome-f021072bd14ddfb426921f22a7122d49d643a7a7.tar.zst
freebsd-ports-gnome-f021072bd14ddfb426921f22a7122d49d643a7a7.zip
New port: p5-Net-Z3950-ZOOM.
A perl interface to the Z39.50 Object-Orientation Model (ZOOM).
Diffstat (limited to 'net/p5-Net-Z3950-ZOOM/Makefile')
-rw-r--r--net/p5-Net-Z3950-ZOOM/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/net/p5-Net-Z3950-ZOOM/Makefile b/net/p5-Net-Z3950-ZOOM/Makefile
new file mode 100644
index 000000000000..0634dded1c27
--- /dev/null
+++ b/net/p5-Net-Z3950-ZOOM/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-Net-Z3950-ZOOM
+# Date created: 22 December 2006
+# Whom: Dmitry Sivachenko <demon@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Z3950-ZOOM
+PORTVERSION= 1.14
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= demon@FreeBSD.org
+COMMENT= A perl interface to the Z39.50 Object-Orientation Model (ZOOM)
+
+LIB_DEPENDS= yaz.2:${PORTSDIR}/net/yaz
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::Z3950::ZOOM.3 ZOOM.3
+
+CONFLICTS= p5-Net-Z3950-[0-9]*
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl version 5.6.0 or above
+.endif
+
+.include <bsd.port.post.mk>