aboutsummaryrefslogtreecommitdiffstats
path: root/net/p5-Net/Makefile
diff options
context:
space:
mode:
authorjfitz <jfitz@FreeBSD.org>1996-10-24 16:32:22 +0800
committerjfitz <jfitz@FreeBSD.org>1996-10-24 16:32:22 +0800
commitf8ad1fd6fa6b5c9d530d6290eba0132769a1a6ce (patch)
treeb166f7aa4a792f8c1340e36feadfe629a807a90f /net/p5-Net/Makefile
parenta2aebc96a1e9e8cc628dc5af6373124aaf0196b2 (diff)
downloadfreebsd-ports-gnome-f8ad1fd6fa6b5c9d530d6290eba0132769a1a6ce.tar.gz
freebsd-ports-gnome-f8ad1fd6fa6b5c9d530d6290eba0132769a1a6ce.tar.zst
freebsd-ports-gnome-f8ad1fd6fa6b5c9d530d6290eba0132769a1a6ce.zip
perl5 modules to access and use network protocols.
Diffstat (limited to 'net/p5-Net/Makefile')
-rw-r--r--net/p5-Net/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/net/p5-Net/Makefile b/net/p5-Net/Makefile
new file mode 100644
index 000000000000..a77d7b9d42a2
--- /dev/null
+++ b/net/p5-Net/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: p5-Net
+# Version required: 1.01
+# Date created: September 30th 1996
+# Whom: James FitzGibbon <jfitz@FreeBSD.org>
+#
+# $Id$
+#
+
+DISTNAME= libnet-1.01
+PKGNAME= p5-Net-1.01
+CATEGORIES+= net
+MASTER_SITES= ftp://ftp.digital.com/pub/plan/perl/CPAN/modules/by-module/Net/ \
+ ftp://ftp.cdrom.com/pub/perl/CPAN/modules/by-module/Net/ \
+ ftp://ftp.cis.ufl.edu/pub/perl/CPAN/modules/by-module/Net/ \
+ ftp://ftp.leo.org/pub/comp/programming/languages/perl/CPAN/modules/by-module/Net/ \
+ ftp://ftp.demon.co.uk/pub/mirrors/perl/CPAN/modules/by-module/Net/ \
+ ftp://ftp.lab.kdd.co.jp/lang/perl/CPAN/modules/by-module/Net/
+
+MAINTAINER= jfitz@FreeBSD.ORG
+
+BUILD_DEPENDS= perl5.003:${PORTSDIR}/lang/perl5 \
+ ${PREFIX}/lib/perl5/IO::Socket.pm:${PORTSDIR}/net/p5-IO
+
+do-configure:
+ @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PREFIX}/bin/perl Makefile.PL
+
+post-install:
+.if !defined(NOMANCOMPRESS)
+ @ for file in Net::Time Net::DummyInetd Net::NNTP Net::SNPP Net::POP3 Net::Cmd Net::SMTP Net::Domain Net::FTP Net::Netrc Net::Telnet; do \
+ gzip -9nf ${PREFIX}/lib/perl5/man/man3/$$file.3; \
+ done
+.endif
+
+.include <bsd.port.mk>