aboutsummaryrefslogtreecommitdiffstats
path: root/net/p5-S3
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2007-05-04 10:31:45 +0800
committerclsung <clsung@FreeBSD.org>2007-05-04 10:31:45 +0800
commit768880629ad2daf403cfb1588c4a5bd77da46b8d (patch)
treeff97f416fb44512cf5937b00e38469fdcd5a790d /net/p5-S3
parentff82cc42d910925ab7cde7714778287ff8bdd44f (diff)
downloadfreebsd-ports-gnome-768880629ad2daf403cfb1588c4a5bd77da46b8d.tar.gz
freebsd-ports-gnome-768880629ad2daf403cfb1588c4a5bd77da46b8d.tar.zst
freebsd-ports-gnome-768880629ad2daf403cfb1588c4a5bd77da46b8d.zip
Add p5-S3 20061002, a library in Perl for working with the Amazon S3
REST interface. PR: ports/112291 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Diffstat (limited to 'net/p5-S3')
-rw-r--r--net/p5-S3/Makefile35
-rw-r--r--net/p5-S3/distinfo3
-rw-r--r--net/p5-S3/pkg-descr3
-rw-r--r--net/p5-S3/pkg-plist12
4 files changed, 53 insertions, 0 deletions
diff --git a/net/p5-S3/Makefile b/net/p5-S3/Makefile
new file mode 100644
index 000000000000..842a8331a84c
--- /dev/null
+++ b/net/p5-S3/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: p5-S3
+# Date created: 2007-04-30
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= S3
+PORTVERSION= 20061002
+CATEGORIES= net perl5
+MASTER_SITES= http://developer.amazonwebservices.com/connect/servlet/KbServlet/download/133-102-760/
+PKGNAMEPREFIX= p5-
+DISTNAME= s3-example-perl-library
+
+MAINTAINER= gslin@gslin.org
+COMMENT= A library in Perl for working with the Amazon S3 REST interface
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Crypt/SSLeay.pm:${PORTSDIR}/security/p5-Crypt-SSLeay \
+ ${SITE_PERL}/Digest/HMAC_SHA1.pm:${PORTSDIR}/security/p5-Digest-HMAC\
+ ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/URI/Escape.pm:${PORTSDIR}/net/p5-URI \
+ ${SITE_PERL}/XML/Simple.pm:${PORTSDIR}/textproc/p5-XML-Simple
+
+NO_BUILD= yes
+USE_PERL5_RUN= yes
+USE_ZIP= yes
+WRKSRC= ${WRKDIR}/s3-example-libraries/perl
+
+do-install:
+ ${MKDIR} ${PREFIX}/${SITE_PERL_REL}/S3
+ ${INSTALL_DATA} ${WRKSRC}/S3/* ${PREFIX}/${SITE_PERL_REL}/S3
+ ${INSTALL_DATA} ${WRKSRC}/S3.pm ${PREFIX}/${SITE_PERL_REL}
+ ${INSTALL_SCRIPT} ${WRKSRC}/s3-*.pl ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/net/p5-S3/distinfo b/net/p5-S3/distinfo
new file mode 100644
index 000000000000..f5b06beefe89
--- /dev/null
+++ b/net/p5-S3/distinfo
@@ -0,0 +1,3 @@
+MD5 (s3-example-perl-library.zip) = 45eaf4dd76b51e01341ffbdbfc38f371
+SHA256 (s3-example-perl-library.zip) = 2f2c421129808ce78c0db3b621dc2d15632930cae6553aaf951a683bc5052ddc
+SIZE (s3-example-perl-library.zip) = 15791
diff --git a/net/p5-S3/pkg-descr b/net/p5-S3/pkg-descr
new file mode 100644
index 000000000000..dc0bd8c47120
--- /dev/null
+++ b/net/p5-S3/pkg-descr
@@ -0,0 +1,3 @@
+A library in Perl for working with the Amazon S3 REST interface.
+
+WWW: http://developer.amazonwebservices.com/connect/entry!default.jspa?externalID=133
diff --git a/net/p5-S3/pkg-plist b/net/p5-S3/pkg-plist
new file mode 100644
index 000000000000..3291339d0131
--- /dev/null
+++ b/net/p5-S3/pkg-plist
@@ -0,0 +1,12 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/S3.pm
+%%SITE_PERL%%/S3/AWSAuthConnection.pm
+%%SITE_PERL%%/S3/GetResponse.pm
+%%SITE_PERL%%/S3/ListAllMyBucketsResponse.pm
+%%SITE_PERL%%/S3/ListBucketResponse.pm
+%%SITE_PERL%%/S3/QueryStringAuthGenerator.pm
+%%SITE_PERL%%/S3/Response.pm
+%%SITE_PERL%%/S3/S3Object.pm
+bin/s3-driver.pl
+bin/s3-test.pl
+@dirrmtry %%SITE_PERL%%/S3