aboutsummaryrefslogtreecommitdiffstats
path: root/net/p5-S3
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2015-03-14 01:29:58 +0800
committeradamw <adamw@FreeBSD.org>2015-03-14 01:29:58 +0800
commit3285716aaeafc0b799b7d0f09455fb838f7423eb (patch)
tree31d423e420103f6111ac7dcc29da77612438b7a3 /net/p5-S3
parent0e44743df6c6b7c3f4bc9ebe5b47c9868ff2ca6d (diff)
downloadfreebsd-ports-gnome-3285716aaeafc0b799b7d0f09455fb838f7423eb.tar.gz
freebsd-ports-gnome-3285716aaeafc0b799b7d0f09455fb838f7423eb.tar.zst
freebsd-ports-gnome-3285716aaeafc0b799b7d0f09455fb838f7423eb.zip
Clean up the rest of the perl@ Makefiles a bit.
- Remove dependencies on modules distributed as part of perl core - Remove references to FreeBSD < 8 and perl < 5.16 - Ensure that DOCS and EXAMPLES options exist for ports installing PORTDOCS or PORTEXAMPLES - Reduce unnecessary inclusions of bsd.port.options.mk by using OPTIONS helpers and the like - Fix some cases where dependencies were only assigned to BUILD_DEPENDS - Fix a few of the cases where dependencies were only assigned to RUN_DEPENDS. This one happens in many, many ports. I only applied it in cases where it interfered with 'make test' but it should maybe be done more generally. - Mute ${MKDIR} in installation - Parethesize compound commands - In www/p5-URI-Fetch, remove the ZLIB option that wasn't used
Diffstat (limited to 'net/p5-S3')
-rw-r--r--net/p5-S3/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/net/p5-S3/Makefile b/net/p5-S3/Makefile
index a55bfab87512..879d942f2915 100644
--- a/net/p5-S3/Makefile
+++ b/net/p5-S3/Makefile
@@ -23,7 +23,7 @@ USE_PERL5= run
WRKSRC= ${WRKDIR}/s3-example-libraries/perl
do-install:
- ${MKDIR} ${STAGEDIR}${PREFIX}/${SITE_PERL_REL}/S3
+ @${MKDIR} ${STAGEDIR}${PREFIX}/${SITE_PERL_REL}/S3
${INSTALL_DATA} ${WRKSRC}/S3/* ${STAGEDIR}${PREFIX}/${SITE_PERL_REL}/S3
${INSTALL_DATA} ${WRKSRC}/S3.pm ${STAGEDIR}${PREFIX}/${SITE_PERL_REL}
${INSTALL_SCRIPT} ${WRKSRC}/s3-*.pl ${STAGEDIR}${PREFIX}/bin