aboutsummaryrefslogtreecommitdiffstats
path: root/net/pear-Net_GeoIP
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2018-03-09 03:48:41 +0800
committermat <mat@FreeBSD.org>2018-03-09 03:48:41 +0800
commit3de11f75e95b0f2dda0d4e2d1bed3fca9fd4925e (patch)
treea942b9de6ec3ced252f123bf8a905b18d685aa72 /net/pear-Net_GeoIP
parentbd4297a179c7edf0fe5800bb82c677771f17923c (diff)
downloadfreebsd-ports-gnome-3de11f75e95b0f2dda0d4e2d1bed3fca9fd4925e.tar.gz
freebsd-ports-gnome-3de11f75e95b0f2dda0d4e2d1bed3fca9fd4925e.tar.zst
freebsd-ports-gnome-3de11f75e95b0f2dda0d4e2d1bed3fca9fd4925e.zip
Introduce PHP flavors.
Ports using USES=php:phpize, php:ext, php:zend, and php:pecl are now flavored. They will automatically get flavors (php56, php70, php71, php72) depending of the versions they support (set with IGNORE_WITH_PHP). As a consequence, ports using USES=pear and USES=horde are also flavored. PR: 226242 Submitted by: mat Exp-run by: antoine Approved by: portmgr Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D14208
Diffstat (limited to 'net/pear-Net_GeoIP')
-rw-r--r--net/pear-Net_GeoIP/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/net/pear-Net_GeoIP/Makefile b/net/pear-Net_GeoIP/Makefile
index 8abd569655e9..8d2a2a4b47d9 100644
--- a/net/pear-Net_GeoIP/Makefile
+++ b/net/pear-Net_GeoIP/Makefile
@@ -10,10 +10,10 @@ DISTNAME= Net_GeoIP-1.0.0RC1
MAINTAINER= joneum@FreeBSD.org
COMMENT= Library to perform geo-location lookups of IP addresses
-BUILD_DEPENDS= ${PEARDIR}/Cache.php:sysutils/pear-Cache \
- ${PEARDIR}/XML/Serializer.php:devel/pear-XML_Serializer
-RUN_DEPENDS= ${PEARDIR}/Cache.php:sysutils/pear-Cache \
- ${PEARDIR}/XML/Serializer.php:devel/pear-XML_Serializer
+BUILD_DEPENDS= ${PEARDIR}/Cache.php:sysutils/pear-Cache@${PHP_FLAVOR} \
+ ${PEARDIR}/XML/Serializer.php:devel/pear-XML_Serializer@${PHP_FLAVOR}
+RUN_DEPENDS= ${PEARDIR}/Cache.php:sysutils/pear-Cache@${PHP_FLAVOR} \
+ ${PEARDIR}/XML/Serializer.php:devel/pear-XML_Serializer@${PHP_FLAVOR}
USES= pear