aboutsummaryrefslogtreecommitdiffstats
path: root/net/pear-XML_RPC
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2007-02-09 17:11:09 +0800
committerale <ale@FreeBSD.org>2007-02-09 17:11:09 +0800
commitf19113d8652ebb5a860ff22a5fc07a7346769fe3 (patch)
treeccc2c8a2feade5974211eec66d2476f9d01feebe /net/pear-XML_RPC
parent2d44f2fde85653d81d8932497d42f6eb7aac8b2f (diff)
downloadfreebsd-ports-gnome-f19113d8652ebb5a860ff22a5fc07a7346769fe3.tar.gz
freebsd-ports-gnome-f19113d8652ebb5a860ff22a5fc07a7346769fe3.tar.zst
freebsd-ports-gnome-f19113d8652ebb5a860ff22a5fc07a7346769fe3.zip
Add the PEAR-ified version of Useful Inc's XML-RPC for PHP, since it's
not included anymore in base pear installation. It has support for HTTP/HTTPS transport, proxies and authentication. WWW: http://pear.php.net/package/XML_RPC/
Diffstat (limited to 'net/pear-XML_RPC')
-rw-r--r--net/pear-XML_RPC/Makefile29
-rw-r--r--net/pear-XML_RPC/distinfo3
-rw-r--r--net/pear-XML_RPC/pkg-descr5
3 files changed, 37 insertions, 0 deletions
diff --git a/net/pear-XML_RPC/Makefile b/net/pear-XML_RPC/Makefile
new file mode 100644
index 000000000000..e51b87b2c58f
--- /dev/null
+++ b/net/pear-XML_RPC/Makefile
@@ -0,0 +1,29 @@
+# Ports collection makefile for: pear-XML_RPC
+# Date created: 7 Feb 2007
+# Whom: Alex Dupre <ale@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML_RPC
+PORTVERSION= 1.5.1
+CATEGORIES= net devel pear
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= PHP implementation of the XML-RPC protocol
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+CATEGORY= XML
+FILES= RPC.php RPC/Server.php RPC/Dump.php
+TESTS= allgot.inc empty-value-struct.php empty-value.php \
+ extra-lines.php protoport.php test_Dump.php types.php
+
+post-extract:
+ @${MKDIR} ${WRKSRC}/RPC
+ @${MV} ${WRKSRC}/Server.php ${WRKSRC}/Dump.php ${WRKSRC}/RPC
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+.include <bsd.port.post.mk>
diff --git a/net/pear-XML_RPC/distinfo b/net/pear-XML_RPC/distinfo
new file mode 100644
index 000000000000..054cbcabdd3f
--- /dev/null
+++ b/net/pear-XML_RPC/distinfo
@@ -0,0 +1,3 @@
+MD5 (PEAR/XML_RPC-1.5.1.tgz) = 1b516162ad65971b5fd04a7c279627ec
+SHA256 (PEAR/XML_RPC-1.5.1.tgz) = a5b517eef799df148d6c85ab19e188715a22c069f4507dcb792e5efb7d0f117e
+SIZE (PEAR/XML_RPC-1.5.1.tgz) = 32215
diff --git a/net/pear-XML_RPC/pkg-descr b/net/pear-XML_RPC/pkg-descr
new file mode 100644
index 000000000000..2df4a18b393a
--- /dev/null
+++ b/net/pear-XML_RPC/pkg-descr
@@ -0,0 +1,5 @@
+A PEAR-ified version of Useful Inc's XML-RPC for PHP.
+
+It has support for HTTP/HTTPS transport, proxies and authentication.
+
+WWW: http://pear.php.net/package/XML_RPC/