aboutsummaryrefslogtreecommitdiffstats
path: root/net/perldap/Makefile
diff options
context:
space:
mode:
authorpaul <paul@FreeBSD.org>1999-05-26 06:47:01 +0800
committerpaul <paul@FreeBSD.org>1999-05-26 06:47:01 +0800
commita6e9b4d3fd6657f23911e4b485e4308bec3a57bb (patch)
treecdc72ab4730ad857748184073b5206618be0642f /net/perldap/Makefile
parentfe68a71b8f83486884abf2f9ffabd9b6dfa83ba8 (diff)
downloadfreebsd-ports-gnome-a6e9b4d3fd6657f23911e4b485e4308bec3a57bb.tar.gz
freebsd-ports-gnome-a6e9b4d3fd6657f23911e4b485e4308bec3a57bb.tar.zst
freebsd-ports-gnome-a6e9b4d3fd6657f23911e4b485e4308bec3a57bb.zip
Initial import of the Mozilla Perl interface to LDAP
Diffstat (limited to 'net/perldap/Makefile')
-rw-r--r--net/perldap/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/net/perldap/Makefile b/net/perldap/Makefile
new file mode 100644
index 000000000000..8d659e75b499
--- /dev/null
+++ b/net/perldap/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: perldap
+# Version required: 1.1b
+# Date created: 17 May 1999
+# Whom: paul
+#
+# $Id$
+#
+
+DISTNAME= perldap-1_2_2
+DISTFILES= perldap-1.2.2.tgz
+CATEGORIES= net
+MASTER_SITES= ftp://ftp.mozilla.org/pub/directory/perldap/
+
+MAINTAINER= paul@FreeBSD.ORG
+
+WRKSRC= ${WRKDIR}/perldap
+LIB_DEPENDS= ldap.1:${PORTSDIR}/net/ldapsdk
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Mozilla::LDAP::Conn.3 \
+ Mozilla::LDAP::LDIF.3 \
+ Mozilla::LDAP::Utils.3 \
+ Mozilla::LDAP::Entry.3 \
+ Mozilla::LDAP::API.3
+
+MAKE_ENV+= LDAPSDKDIR=/usr/local/mozilla/directory LDAPV3ON=yes LDAPSDKSSL=no
+
+do-configure:
+ @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
+
+.include <bsd.port.mk>