aboutsummaryrefslogtreecommitdiffstats
path: root/net/perldap
diff options
context:
space:
mode:
authorpaul <paul@FreeBSD.org>2001-04-18 02:37:39 +0800
committerpaul <paul@FreeBSD.org>2001-04-18 02:37:39 +0800
commit460976e2d72b2119a603d346fe07f437ae8954c4 (patch)
treec8f33ff2c8d3a0072153f6822e547b403321bdcd /net/perldap
parenteeea4e14bd3bfcfd82a7d137a9e131b7c7cf6efd (diff)
downloadfreebsd-ports-gnome-460976e2d72b2119a603d346fe07f437ae8954c4.tar.gz
freebsd-ports-gnome-460976e2d72b2119a603d346fe07f437ae8954c4.tar.zst
freebsd-ports-gnome-460976e2d72b2119a603d346fe07f437ae8954c4.zip
This port requires the Mozilla ldapsdk rather than the Openldap one.
Update the port to use the moz prefix before the library and header file names in order to pick up the Mozilla versions of those files. This change is necesary now that ldapsdk has been updated to use those prefixes to distinguish it from Openldap. PR: ports/22721 Submitted by: "Charles N. Owens" <owensc@enc.edu>
Diffstat (limited to 'net/perldap')
-rw-r--r--net/perldap/Makefile4
-rw-r--r--net/perldap/files/patch-0119
-rw-r--r--net/perldap/files/patch-0213
-rw-r--r--net/perldap/files/patch-0311
4 files changed, 45 insertions, 2 deletions
diff --git a/net/perldap/Makefile b/net/perldap/Makefile
index cac64c7b6ee0..50815198ecc0 100644
--- a/net/perldap/Makefile
+++ b/net/perldap/Makefile
@@ -14,7 +14,7 @@ EXTRACT_SUFX= .tar.gz
MAINTAINER= paul@FreeBSD.org
-LIB_DEPENDS= ldap.1:${PORTSDIR}/net/ldapsdk
+LIB_DEPENDS= mozldap.1:${PORTSDIR}/net/ldapsdk
WRKSRC= ${WRKDIR}/$(PORTNAME)-$(PORTVERSION)
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
@@ -24,7 +24,7 @@ MAN3= Mozilla::LDAP::Conn.3 \
Mozilla::LDAP::Entry.3 \
Mozilla::LDAP::API.3
-MAKE_ENV+= LDAPSDKDIR=${PREFIX}/mozilla/directory LDAPV3ON=yes LDAPSDKSSL=no
+MAKE_ENV+= LDAPSDKDIR=${PREFIX} LDAPV3ON=yes LDAPSDKSSL=no
do-configure:
@ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
diff --git a/net/perldap/files/patch-01 b/net/perldap/files/patch-01
new file mode 100644
index 000000000000..8ad30a4cbb1d
--- /dev/null
+++ b/net/perldap/files/patch-01
@@ -0,0 +1,19 @@
+--- Makefile.PL.orig Tue Aug 24 18:30:46 1999
++++ Makefile.PL Tue Aug 29 10:32:23 2000
+@@ -90,13 +90,13 @@
+
+
+ opendir(DIR,$lib_ldap);
+-@files = grep{/ldap|lber/} readdir(DIR);
++@files = grep{/mozldap|mozlber/} readdir(DIR);
+ closedir(DIR);
+
+ if (!((@ldaplib = grep{/ldapssl.*\.($libexts)$/} @files) && $ssl_def))
+ {
+- @ldaplib = grep{/ldap.*\.($libexts)$/} @files;
+- @lberlib = grep{/lber.*\.($libexts)$/} @files;
++ @ldaplib = grep{/mozldap.*\.($libexts)$/} @files;
++ @lberlib = grep{/mozlber.*\.($libexts)$/} @files;
+ }
+
+ if ($#ldaplib < 0)
diff --git a/net/perldap/files/patch-02 b/net/perldap/files/patch-02
new file mode 100644
index 000000000000..c1914a31e594
--- /dev/null
+++ b/net/perldap/files/patch-02
@@ -0,0 +1,13 @@
+--- API.xs.orig Thu Aug 24 22:13:31 2000
++++ API.xs Thu Aug 24 22:11:55 2000
+@@ -37,8 +37,8 @@
+ #endif
+
+ /* LDAP C SDK Include Files */
+-#include <lber.h>
+-#include <ldap.h>
++#include <mozlber.h>
++#include <mozldap.h>
+
+ /* SSL is only available in Binary */
+ #ifdef USE_SSL
diff --git a/net/perldap/files/patch-03 b/net/perldap/files/patch-03
new file mode 100644
index 000000000000..c4f4f9cc60ef
--- /dev/null
+++ b/net/perldap/files/patch-03
@@ -0,0 +1,11 @@
+--- constant.h.orig Thu Aug 24 22:13:54 2000
++++ constant.h Thu Aug 24 22:12:11 2000
+@@ -35,7 +35,7 @@
+ }
+ #endif
+
+-#include <ldap.h>
++#include <mozldap.h>
+
+ static int
+ not_here(s)