aboutsummaryrefslogtreecommitdiffstats
path: root/net/phpldapadmin
diff options
context:
space:
mode:
authormatthew <matthew@FreeBSD.org>2014-05-03 15:16:49 +0800
committermatthew <matthew@FreeBSD.org>2014-05-03 15:16:49 +0800
commit64d32688dbb91ef0fe3839f8871cb320d53791b9 (patch)
treed00c83dce0d772b126134ffda9f036d85ac29855 /net/phpldapadmin
parent80e5f5093f5bf544b46747a3fcbc9678ce49a865 (diff)
downloadfreebsd-ports-gnome-64d32688dbb91ef0fe3839f8871cb320d53791b9.tar.gz
freebsd-ports-gnome-64d32688dbb91ef0fe3839f8871cb320d53791b9.tar.zst
freebsd-ports-gnome-64d32688dbb91ef0fe3839f8871cb320d53791b9.zip
Finish off the incomplete conversion from 'password_hash' to
'password_hash_custom' in the previous update. Locally written patches.
Diffstat (limited to 'net/phpldapadmin')
-rw-r--r--net/phpldapadmin/Makefile2
-rw-r--r--net/phpldapadmin/files/patch-config__config.php.example20
-rw-r--r--net/phpldapadmin/files/patch-lib__PageRender.php2
-rw-r--r--net/phpldapadmin/files/patch-lib__TemplateRender.php11
-rw-r--r--net/phpldapadmin/files/patch-lib__ds_ldap.php2
-rw-r--r--net/phpldapadmin/files/patch-lib__ds_ldap_pla.php2
-rw-r--r--net/phpldapadmin/files/patch-lib__functions.php2
-rw-r--r--net/phpldapadmin/files/patch-tools__po__Makefile2
8 files changed, 37 insertions, 6 deletions
diff --git a/net/phpldapadmin/Makefile b/net/phpldapadmin/Makefile
index 29ede7ecbd56..cb2da8227113 100644
--- a/net/phpldapadmin/Makefile
+++ b/net/phpldapadmin/Makefile
@@ -3,7 +3,7 @@
PORTNAME= phpldapadmin
PORTVERSION= 1.2.3
-PORTREVISION= 5
+PORTREVISION= 6
PORTEPOCH= 1
CATEGORIES= net www
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-php5/${PORTVERSION}
diff --git a/net/phpldapadmin/files/patch-config__config.php.example b/net/phpldapadmin/files/patch-config__config.php.example
new file mode 100644
index 000000000000..a3a6025b29b8
--- /dev/null
+++ b/net/phpldapadmin/files/patch-config__config.php.example
@@ -0,0 +1,20 @@
+--- ./config/config.php.example.orig 2014-05-03 08:00:05.933577117 +0100
++++ ./config/config.php.example 2014-05-03 08:00:38.259564444 +0100
+@@ -379,7 +379,7 @@
+
+ /* Default password hashing algorithm. One of md5, ssha, sha, md5crpyt, smd5,
+ blowfish, crypt or leave blank for now default algorithm. */
+-// $servers->setValue('appearance','password_hash','md5');
++// $servers->setValue('appearance','password_hash_custom','md5');
+
+ /* If you specified 'cookie' or 'session' as the auth_type above, you can
+ optionally specify here an attribute to use when logging in. If you enter
+@@ -546,7 +546,7 @@
+ $servers->setValue('sasl','authz_id_replacement','$1');
+ $servers->setValue('sasl','props',null);
+
+-$servers->setValue('appearance','password_hash','md5');
++$servers->setValue('appearance','password_hash_custom','md5');
+ $servers->setValue('login','attr','dn');
+ $servers->setValue('login','fallback_dn',false);
+ $servers->setValue('login','class',null);
diff --git a/net/phpldapadmin/files/patch-lib__PageRender.php b/net/phpldapadmin/files/patch-lib__PageRender.php
index 3b171649855e..065f5875b479 100644
--- a/net/phpldapadmin/files/patch-lib__PageRender.php
+++ b/net/phpldapadmin/files/patch-lib__PageRender.php
@@ -1,5 +1,5 @@
--- ./lib/PageRender.php.orig 2012-10-01 07:54:14.000000000 +0100
-+++ ./lib/PageRender.php 2014-04-27 09:42:04.069744333 +0100
++++ ./lib/PageRender.php 2014-05-03 07:57:44.744575309 +0100
@@ -287,7 +287,7 @@
break;
diff --git a/net/phpldapadmin/files/patch-lib__TemplateRender.php b/net/phpldapadmin/files/patch-lib__TemplateRender.php
new file mode 100644
index 000000000000..610c5dbcfd3a
--- /dev/null
+++ b/net/phpldapadmin/files/patch-lib__TemplateRender.php
@@ -0,0 +1,11 @@
+--- ./lib/TemplateRender.php.orig 2014-05-03 07:58:18.076584893 +0100
++++ ./lib/TemplateRender.php 2014-05-03 07:59:18.859574787 +0100
+@@ -2466,7 +2466,7 @@
+ if ($val = $attribute->getValue($i))
+ $default = get_enc_type($val);
+ else
+- $default = $this->getServer()->getValue('appearance','password_hash');
++ $default = $this->getServer()->getValue('appearance','password_hash_custom');
+
+ if (! $attribute->getPostValue())
+ printf('<input type="hidden" name="post_value[%s][]" value="%s" />',$attribute->getName(),$i);
diff --git a/net/phpldapadmin/files/patch-lib__ds_ldap.php b/net/phpldapadmin/files/patch-lib__ds_ldap.php
index 5b188ef34e5d..b811aee6d4dc 100644
--- a/net/phpldapadmin/files/patch-lib__ds_ldap.php
+++ b/net/phpldapadmin/files/patch-lib__ds_ldap.php
@@ -1,5 +1,5 @@
--- ./lib/ds_ldap.php.orig 2012-10-01 07:54:14.000000000 +0100
-+++ ./lib/ds_ldap.php 2014-04-27 09:42:04.087756668 +0100
++++ ./lib/ds_ldap.php 2014-05-03 07:57:44.746572911 +0100
@@ -1116,13 +1116,24 @@
if (is_array($dn)) {
diff --git a/net/phpldapadmin/files/patch-lib__ds_ldap_pla.php b/net/phpldapadmin/files/patch-lib__ds_ldap_pla.php
index 707ede969058..775fa46c31d1 100644
--- a/net/phpldapadmin/files/patch-lib__ds_ldap_pla.php
+++ b/net/phpldapadmin/files/patch-lib__ds_ldap_pla.php
@@ -1,5 +1,5 @@
--- ./lib/ds_ldap_pla.php.orig 2012-10-01 07:54:14.000000000 +0100
-+++ ./lib/ds_ldap_pla.php 2014-04-27 09:42:04.099743918 +0100
++++ ./lib/ds_ldap_pla.php 2014-05-03 07:57:44.748572937 +0100
@@ -16,7 +16,7 @@
function __construct($index) {
parent::__construct($index);
diff --git a/net/phpldapadmin/files/patch-lib__functions.php b/net/phpldapadmin/files/patch-lib__functions.php
index b0bb5eedd2fe..bf7572fa379b 100644
--- a/net/phpldapadmin/files/patch-lib__functions.php
+++ b/net/phpldapadmin/files/patch-lib__functions.php
@@ -1,5 +1,5 @@
--- ./lib/functions.php.orig 2012-10-01 07:54:14.000000000 +0100
-+++ ./lib/functions.php 2014-04-27 09:42:04.122737345 +0100
++++ ./lib/functions.php 2014-05-03 07:57:44.751570981 +0100
@@ -2127,7 +2127,7 @@
* crypt, ext_des, md5crypt, blowfish, md5, sha, smd5, ssha, sha512, or clear.
* @return string The hashed password.
diff --git a/net/phpldapadmin/files/patch-tools__po__Makefile b/net/phpldapadmin/files/patch-tools__po__Makefile
index 69af00f03476..fde9a98d085d 100644
--- a/net/phpldapadmin/files/patch-tools__po__Makefile
+++ b/net/phpldapadmin/files/patch-tools__po__Makefile
@@ -1,5 +1,5 @@
--- ./tools/po/Makefile.orig 2012-10-01 07:54:14.000000000 +0100
-+++ ./tools/po/Makefile 2014-04-27 09:40:05.269794411 +0100
++++ ./tools/po/Makefile 2014-05-03 07:57:44.752575636 +0100
@@ -1,4 +1,3 @@
-#!/bin/bash
#