aboutsummaryrefslogtreecommitdiffstats
path: root/net/phpldapadmin
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2004-05-15 16:19:04 +0800
committerthierry <thierry@FreeBSD.org>2004-05-15 16:19:04 +0800
commit6b4c9542293b280493c04b7311e68deaacab9da3 (patch)
treec19438eac9851da06ba5dc12bd4931f472d63ead /net/phpldapadmin
parente67907c9fb0ca0f35515bbd61e56ea963690af3a (diff)
downloadfreebsd-ports-gnome-6b4c9542293b280493c04b7311e68deaacab9da3.tar.gz
freebsd-ports-gnome-6b4c9542293b280493c04b7311e68deaacab9da3.tar.zst
freebsd-ports-gnome-6b4c9542293b280493c04b7311e68deaacab9da3.zip
Add phpldapadmin 0.9.4b, a set of PHP-scripts to administer LDAP
servers over the web. PR: 66154 Submitted by: Matthew Seaman
Diffstat (limited to 'net/phpldapadmin')
-rw-r--r--net/phpldapadmin/Makefile56
-rw-r--r--net/phpldapadmin/distinfo2
-rw-r--r--net/phpldapadmin/pkg-descr11
-rw-r--r--net/phpldapadmin/pkg-message17
4 files changed, 86 insertions, 0 deletions
diff --git a/net/phpldapadmin/Makefile b/net/phpldapadmin/Makefile
new file mode 100644
index 000000000000..e6d92f49e342
--- /dev/null
+++ b/net/phpldapadmin/Makefile
@@ -0,0 +1,56 @@
+# New ports collection makefile for: phpLDAPadmin
+# Date created: 30 Apr 2004
+# Whom: Matthew Seaman
+#
+# $FreeBSD$
+#
+
+PORTNAME= phpldapadmin
+PORTVERSION= 0.9.4b
+CATEGORIES= net www
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= phpldapadmin
+
+MAINTAINER= m.seaman@infracaninophile.co.uk
+COMMENT= A set of PHP-scripts to administer LDAP servers over the web
+
+USE_PHP= yes
+WANT_PHP_WEB= yes
+NO_BUILD= yes
+
+WWWDIR?= www/${PORTNAME}
+
+MSG_SKEL= ${PKGDIR}/pkg-message
+PKGMESSAGE= ${WRKDIR}/pkg-message
+PLIST= ${WRKDIR}/plist
+PLIST_SUB+= WWWDIR=${WWWDIR}
+
+.SILENT:
+
+post-patch:
+ ${RM} -f ${PLIST}
+ cd ${WRKSRC} ; \
+ ${FIND} . ! -type d ! -name .cvsignore | ${SORT} | \
+ ${SED} "s,^.,%%WWWDIR%%," >${PLIST} ; \
+ ${FIND} . -type d | ${SORT} -r | \
+ ${SED} "s,^.,@dirrm %%WWWDIR%%," >>${PLIST}
+ ${SED} -e 's,%%WWWDIR%%,${WWWDIR},g' \
+ -e 's,%%PREFIX%%,${PREFIX},g' ${MSG_SKEL} > ${PKGMESSAGE}
+
+do-install:
+ cd ${WRKSRC} ; \
+ for src in $$( ${FIND} . ! -name .cvsignore ) ; do \
+ dst=${PREFIX}/${WWWDIR}$${src#.} ; \
+ if ${TEST} -d $$src ; then \
+ ${MKDIR} $$dst ; \
+ else \
+ ${INSTALL_DATA} $$src $$dst ; \
+ fi \
+ done
+
+post-install:
+ ${ECHO_MSG}
+ ${CAT} ${PKGMESSAGE}
+ ${ECHO_MSG}
+
+.include <bsd.port.mk>
diff --git a/net/phpldapadmin/distinfo b/net/phpldapadmin/distinfo
new file mode 100644
index 000000000000..7b559f5d01ab
--- /dev/null
+++ b/net/phpldapadmin/distinfo
@@ -0,0 +1,2 @@
+MD5 (phpldapadmin-0.9.4b.tar.gz) = 0aa6021da066c637e56354980dccddbe
+SIZE (phpldapadmin-0.9.4b.tar.gz) = 375889
diff --git a/net/phpldapadmin/pkg-descr b/net/phpldapadmin/pkg-descr
new file mode 100644
index 000000000000..80de707d442b
--- /dev/null
+++ b/net/phpldapadmin/pkg-descr
@@ -0,0 +1,11 @@
+phpLDAPadmin is a web-based LDAP client. It provides easy,
+anywhere-accessible, multi-language administration for your LDAP
+server. Its hierarchical tree-viewer and advanced search functionality
+make it intuitive to browse and administer your LDAP directory. Since
+it is a web application, this LDAP browser works on many platforms,
+making your LDAP server easily manageable from any
+location. phpLDAPadmin is the perfect LDAP browser for the LDAP
+professional and novice alike. Its user base consists mostly of LDAP
+administration professionals.
+
+WWW: http://phpldapadmin.sourceforge.net/
diff --git a/net/phpldapadmin/pkg-message b/net/phpldapadmin/pkg-message
new file mode 100644
index 000000000000..f820d15624b0
--- /dev/null
+++ b/net/phpldapadmin/pkg-message
@@ -0,0 +1,17 @@
+
+ phpLDAPadmin has been installed into:
+
+ %%PREFIX%%/%%WWWDIR%%
+
+ Please copy config.php.example to config.php and edit to suit
+ your needs.
+
+ To make phpLDAPadmin available through your web site, I suggest
+ that you add the following to httpd.conf:
+
+ Alias /phpldapadmin/ "%%PREFIX%%/%%WWWDIR%%/"
+
+ You will need a version of PHP with LDAP functionality enabled,
+ which is not the default. If necessary, enable the 'OPENLDAP'
+ option in the www/mod_php4 port's configuration screen and
+ reinstall PHP.