aboutsummaryrefslogtreecommitdiffstats
path: root/net/plb
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2003-02-27 05:17:36 +0800
committervanilla <vanilla@FreeBSD.org>2003-02-27 05:17:36 +0800
commit525b9b37eabdfc122132319909f255024cd4ed7b (patch)
tree728f4a6c59d639d3c5c5fa056b2b281ad8d801be /net/plb
parentce23b7158ea4b31f49c9e0d7b29c14bd35d2f6cd (diff)
downloadfreebsd-ports-gnome-525b9b37eabdfc122132319909f255024cd4ed7b.tar.gz
freebsd-ports-gnome-525b9b37eabdfc122132319909f255024cd4ed7b.tar.zst
freebsd-ports-gnome-525b9b37eabdfc122132319909f255024cd4ed7b.zip
Add plb, it's a high-performance software load balancer for the HTTP protocol.
PR: ports/48714 Submitted by: Frank Denis <j@pureftpd.org>
Diffstat (limited to 'net/plb')
-rw-r--r--net/plb/Makefile41
-rw-r--r--net/plb/distinfo1
-rw-r--r--net/plb/files/plb.sh.sample19
-rw-r--r--net/plb/pkg-descr8
-rw-r--r--net/plb/pkg-plist11
5 files changed, 80 insertions, 0 deletions
diff --git a/net/plb/Makefile b/net/plb/Makefile
new file mode 100644
index 000000000000..d88d9f21d851
--- /dev/null
+++ b/net/plb/Makefile
@@ -0,0 +1,41 @@
+# New ports collection Makefile for: plb
+# Date created: Feb 26, 2003
+# Whom: Frank Denis <j@pureftpd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= plb
+PORTVERSION= 0.3
+PORTREVISION= 0
+CATEGORIES= net ipv6
+MASTER_SITES= http://plb.sunsite.dk/files/
+
+MAINTAINER= j@pureftpd.org
+COMMENT= A high-performance HTTP load balancer
+
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libevent.a:${PORTSDIR}/devel/libevent
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --sysconfdir=${PREFIX}/etc
+
+MAN8= plb.8
+DOCS= AUTHORS CONTACT COPYING NEWS README THANKS TODO
+
+post-extract:
+ @${SED} -e "s=%%PREFIX%%=${PREFIX}=g" ${FILESDIR}/plb.sh.sample \
+ > ${WRKSRC}/plb.sh.sample
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/plb.conf ${PREFIX}/etc/plb.conf.sample
+ ${INSTALL_SCRIPT} ${WRKSRC}/plb.sh.sample ${PREFIX}/etc/rc.d/plb.sh.sample
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/plb
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${PREFIX}/share/doc/plb)
+.endif
+ @${ECHO_CMD}
+ @${ECHO_CMD} "Now you need to examine ${PREFIX}/etc/plb.conf.sample,"
+ @${ECHO_CMD} "to adapt it to your needs, and save it as ${PREFIX}/etc/plb.conf.sample."
+ @${ECHO_CMD}
+
+.include <bsd.port.mk>
diff --git a/net/plb/distinfo b/net/plb/distinfo
new file mode 100644
index 000000000000..771d839fdee7
--- /dev/null
+++ b/net/plb/distinfo
@@ -0,0 +1 @@
+MD5 (plb-0.3.tar.gz) = 74c1dee5387afc6cff169b0cf8767bbd
diff --git a/net/plb/files/plb.sh.sample b/net/plb/files/plb.sh.sample
new file mode 100644
index 000000000000..fcd8121c953f
--- /dev/null
+++ b/net/plb/files/plb.sh.sample
@@ -0,0 +1,19 @@
+#!/bin/sh
+
+case "$1" in
+
+start)
+ if [ -x %%PREFIX%%/bin/plb ]; then
+ %%PREFIX%%/bin/plb -B -c %%PREFIX%%/etc/plb.conf && echo -n ' plb'
+ fi
+ ;;
+
+stop)
+ kill $(cat /var/run/plb.pid)
+ rm -f /var/run/plb.pid
+ ;;
+*)
+ echo "$0 start | stop"
+ ;;
+
+esac
diff --git a/net/plb/pkg-descr b/net/plb/pkg-descr
new file mode 100644
index 000000000000..04701a37c081
--- /dev/null
+++ b/net/plb/pkg-descr
@@ -0,0 +1,8 @@
+Pure Load Balancer is a high-performance software load balancer for the
+HTTP protocol.
+
+It uses an asynchronous non-forking/non-blocking model, and provides
+fail-over abilities. When a backend server goes down, it automatically
+removes it from the server pool, and tries to bring it back to life later.
+
+WWW: http://plb.sunsite.dk/
diff --git a/net/plb/pkg-plist b/net/plb/pkg-plist
new file mode 100644
index 000000000000..42309fe13992
--- /dev/null
+++ b/net/plb/pkg-plist
@@ -0,0 +1,11 @@
+bin/plb
+etc/plb.conf.sample
+etc/rc.d/plb.sh.sample
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/CONTACT
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/THANKS
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%PORTDOCS%%@dirrm %%DOCSDIR%%