aboutsummaryrefslogtreecommitdiffstats
path: root/net/pppd23
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-04-11 01:36:02 +0800
committerkrion <krion@FreeBSD.org>2004-04-11 01:36:02 +0800
commit72527a6c26962eec63d8c7ce78e4139d140280f2 (patch)
treee87b317ca2a154f6a243603fb3950db717a8dbfe /net/pppd23
parent0530afff5a0952aab3aa7199e518e9e93629c350 (diff)
downloadfreebsd-ports-gnome-72527a6c26962eec63d8c7ce78e4139d140280f2.tar.gz
freebsd-ports-gnome-72527a6c26962eec63d8c7ce78e4139d140280f2.tar.zst
freebsd-ports-gnome-72527a6c26962eec63d8c7ce78e4139d140280f2.zip
Add pppd23 2.3.11,
This is port for version 2.3.11 of pppd (includes also chat and pppstats). Version 2.3.11 is last in 2.3 branch (last which supports BSD systems from box). Base system contains version 2.3.5 which is waaay outdated. Port is called pppd23 to distinct from possibly following port for 2.4.*. It seems that almost all PRs for basesystem pppd are fixed in 2.3.11. PR: ports/65398 Submitted by: Valentin Nechayev <netch@netch.kiev.ua>
Diffstat (limited to 'net/pppd23')
-rw-r--r--net/pppd23/Makefile21
-rw-r--r--net/pppd23/distinfo2
-rw-r--r--net/pppd23/files/patch-aa85
-rw-r--r--net/pppd23/pkg-descr4
-rw-r--r--net/pppd23/pkg-plist3
5 files changed, 115 insertions, 0 deletions
diff --git a/net/pppd23/Makefile b/net/pppd23/Makefile
new file mode 100644
index 000000000000..c98a98c4f4a3
--- /dev/null
+++ b/net/pppd23/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: pppd 2.3.11
+# Date created: 10 April 2004
+# Whom: netch@netch.kiev.ua
+#
+# $FreeBSD$
+#
+
+PORTNAME= pppd
+PORTVERSION= 2.3.11
+CATEGORIES= net
+MASTER_SITES= http://samba.anu.edu.au/ftp/ppp/
+DISTNAME= ppp-${PORTVERSION}
+
+MAINTAINER= netch@netch.kiev.ua
+COMMENT= PPP daemon which uses ppp line discipline
+
+GNU_CONFIGURE= yes
+MAN8= pppd.8 pppstats.8 chat.8
+MANCOMPRESSED= yes
+
+.include <bsd.port.mk>
diff --git a/net/pppd23/distinfo b/net/pppd23/distinfo
new file mode 100644
index 000000000000..16eb5b1510f4
--- /dev/null
+++ b/net/pppd23/distinfo
@@ -0,0 +1,2 @@
+MD5 (ppp-2.3.11.tar.gz) = c86725e90bba6f5677b98454690f65ea
+SIZE (ppp-2.3.11.tar.gz) = 795942
diff --git a/net/pppd23/files/patch-aa b/net/pppd23/files/patch-aa
new file mode 100644
index 000000000000..9176bfe2b8a3
--- /dev/null
+++ b/net/pppd23/files/patch-aa
@@ -0,0 +1,85 @@
+diff -rNu ../../0/ppp-2.3.11/chat/Makefile.bsd ./chat/Makefile.bsd
+--- ../../0/ppp-2.3.11/chat/Makefile.bsd Tue Oct 8 07:37:59 1996
++++ ./chat/Makefile.bsd Sat Apr 10 16:41:44 2004
+@@ -3,7 +3,6 @@
+ PROG= chat
+ SRCS= chat.c
+ MAN8= chat.8
+-MAN= chat.cat8
+ BINDIR= /usr/sbin
+
+ .include <bsd.prog.mk>
+diff -rNu ../../0/ppp-2.3.11/configure ./configure
+--- ../../0/ppp-2.3.11/configure Mon Nov 15 03:56:26 1999
++++ ./configure Sat Apr 10 16:41:44 2004
+@@ -59,7 +59,7 @@
+ 2.[01]*) state="known"; ksrc="freebsd-2.0";;
+ 2.2.[2-7]*) state="late"; ksrc="freebsd-2.0";;
+ 2.2.8*) state="known"; ksrc="freebsd-2.2.8";;
+- 3.[0-1]*) state="known"; ksrc="freebsd-3.0";;
++ [345].*) state="known"; ksrc="freebsd-3.0";;
+ esac;;
+ NeXTStep)
+ makext="NeXT";
+diff -rNu ../../0/ppp-2.3.11/freebsd-3.0/Makefile.top ./freebsd-3.0/Makefile.top
+--- ../../0/ppp-2.3.11/freebsd-3.0/Makefile.top Wed May 12 13:05:47 1999
++++ ./freebsd-3.0/Makefile.top Sat Apr 10 16:41:44 2004
+@@ -2,10 +2,19 @@
+ # ppp top level makefile for *bsd systems
+ #
+
++.if defined(PREFIX)
++.if $(PREFIX) == "/usr"
++MANDIR=/usr/share/man/man
++.else
++MANDIR=$(PREFIX)/man/man
++.endif
++BINDIR?= $(PREFIX)/sbin
++.else
+ BINDIR?= /usr/sbin
++.endif
+
+ SUBDIR= chat pppd pppstats
+-MAKE+= BINDIR=$(BINDIR)
++MAKE+= BINDIR=$(BINDIR) MANDIR=$(MANDIR)
+
+ kernel:
+ @sh -e freebsd-3.0/kinstall.sh
+diff -rNu ../../0/ppp-2.3.11/pppd/Makefile.bsd ./pppd/Makefile.bsd
+--- ../../0/ppp-2.3.11/pppd/Makefile.bsd Mon Apr 12 09:23:30 1999
++++ ./pppd/Makefile.bsd Sat Apr 10 16:42:06 2004
+@@ -9,10 +9,10 @@
+ PROG= pppd
+ SRCS= main.c magic.c fsm.c lcp.c ipcp.c upap.c chap.c md5.c ccp.c \
+ demand.c auth.c options.c utils.c sys-bsd.c
+-MAN= pppd.cat8
+ MAN8= pppd.8
+-BINMODE=4555
++BINMODE=4550
+ BINOWN= root
++BINGRP= dialer
+
+ LDADD= -lcrypt -lutil
+ DPADD= ${LIBCRYPT} ${LIBUTIL}
+diff -rNu ../../0/ppp-2.3.11/pppd/sys-bsd.c ./pppd/sys-bsd.c
+--- ../../0/ppp-2.3.11/pppd/sys-bsd.c Tue Aug 24 08:25:54 1999
++++ ./pppd/sys-bsd.c Sat Apr 10 16:41:44 2004
+@@ -22,7 +22,6 @@
+
+ #define RCSID "$Id: sys-bsd.c,v 1.46 1999/08/13 06:46:18 paulus Exp $"
+ /* $NetBSD: sys-bsd.c,v 1.1.1.3 1997/09/26 18:53:04 christos Exp $ */
+-#endif
+
+ /*
+ * TODO:
+diff -rNu ../../0/ppp-2.3.11/pppstats/Makefile.bsd ./pppstats/Makefile.bsd
+--- ../../0/ppp-2.3.11/pppstats/Makefile.bsd Wed Mar 25 04:21:17 1998
++++ ./pppstats/Makefile.bsd Sat Apr 10 16:41:44 2004
+@@ -4,7 +4,6 @@
+ SRCS= pppstats.c
+ CFLAGS+=-I../include -D_BITYPES
+ MAN8= pppstats.8
+-MAN= pppstats.cat8
+ BINDIR= /usr/sbin
+
+ .include <bsd.prog.mk>
diff --git a/net/pppd23/pkg-descr b/net/pppd23/pkg-descr
new file mode 100644
index 000000000000..845d9d0e899b
--- /dev/null
+++ b/net/pppd23/pkg-descr
@@ -0,0 +1,4 @@
+pppd is PPP protocol client/server which uses ppp line discipline
+(i.e. kernel mode PPP driver) on a serial link or another terminal.
+
+WWW: http://samba.anu.edu.au/ftp/ppp/
diff --git a/net/pppd23/pkg-plist b/net/pppd23/pkg-plist
new file mode 100644
index 000000000000..f6644cdd8988
--- /dev/null
+++ b/net/pppd23/pkg-plist
@@ -0,0 +1,3 @@
+sbin/pppd
+sbin/pppstats
+sbin/chat