aboutsummaryrefslogtreecommitdiffstats
path: root/net/pptpclient
diff options
context:
space:
mode:
authordannyboy <dannyboy@FreeBSD.org>2004-06-30 23:56:23 +0800
committerdannyboy <dannyboy@FreeBSD.org>2004-06-30 23:56:23 +0800
commit4e507d7b166b30e0862cd7ae71b0a58c3f195aac (patch)
tree19f90d0656ce094f45abcd71bfb6e7564fac1444 /net/pptpclient
parent951e89a42f94ba6ead4307fe14ef9f78b93830c5 (diff)
downloadfreebsd-ports-gnome-4e507d7b166b30e0862cd7ae71b0a58c3f195aac.tar.gz
freebsd-ports-gnome-4e507d7b166b30e0862cd7ae71b0a58c3f195aac.tar.zst
freebsd-ports-gnome-4e507d7b166b30e0862cd7ae71b0a58c3f195aac.zip
Update to 1.5.0.
Submitted by: maintainer
Diffstat (limited to 'net/pptpclient')
-rw-r--r--net/pptpclient/Makefile4
-rw-r--r--net/pptpclient/distinfo4
-rw-r--r--net/pptpclient/files/patch-ad11
3 files changed, 15 insertions, 4 deletions
diff --git a/net/pptpclient/Makefile b/net/pptpclient/Makefile
index a59958390c4d..fc85a8009739 100644
--- a/net/pptpclient/Makefile
+++ b/net/pptpclient/Makefile
@@ -6,11 +6,11 @@
#
PORTNAME= pptpclient
-PORTVERSION= 1.3.1
+PORTVERSION= 1.5.0
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= pptpclient
-DISTNAME= pptp-linux-1.3.1
+DISTNAME= pptp-linux-1.5.0
MAINTAINER= thomas@cuivre.fr.eu.org
COMMENT= PPTP client for establishing a VPN link with an NT server
diff --git a/net/pptpclient/distinfo b/net/pptpclient/distinfo
index 8ac2c9c2b799..4644616553bf 100644
--- a/net/pptpclient/distinfo
+++ b/net/pptpclient/distinfo
@@ -1,2 +1,2 @@
-MD5 (pptp-linux-1.3.1.tar.gz) = b24ca05422c0e62d7a26edbbec604a89
-SIZE (pptp-linux-1.3.1.tar.gz) = 215987
+MD5 (pptp-linux-1.5.0.tar.gz) = 281ee37788bdf3260426eca56a9af858
+SIZE (pptp-linux-1.5.0.tar.gz) = 223317
diff --git a/net/pptpclient/files/patch-ad b/net/pptpclient/files/patch-ad
new file mode 100644
index 000000000000..5185c0587c1b
--- /dev/null
+++ b/net/pptpclient/files/patch-ad
@@ -0,0 +1,11 @@
+--- pptp_gre.c.orig Tue Jun 22 15:10:30 2004
++++ pptp_gre.c Tue Jun 22 15:10:38 2004
+@@ -200,7 +200,7 @@
+ int optval, optlen = sizeof(optval);
+ warn("transmitted GRE packet triggered an ICMP destination unreachable, fragmentation needed, or exceeds the MTU of the network interface");
+ #define IP_MTU 14
+- if(getsockopt(fd, SOL_IP, IP_MTU, &optval, &optlen) < 0)
++ if(getsockopt(fd, IPPROTO_IP, IP_MTU, &optval, &optlen) < 0)
+ warn("getsockopt: %s", strerror(errno));
+ warn("getsockopt: IP_MTU: %d\n", optval);
+ return 0;