aboutsummaryrefslogtreecommitdiffstats
path: root/net/prosearch
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2011-02-25 22:36:21 +0800
committerale <ale@FreeBSD.org>2011-02-25 22:36:21 +0800
commit674124c7b3696b07b2851087af9d58ea5da2c382 (patch)
treec71b089d729c82ba36a0c65fbe9fd99c6c8e367f /net/prosearch
parenta4e4c29bd45e85cc35f346f6fbf269b1d01b4304 (diff)
downloadfreebsd-ports-gnome-674124c7b3696b07b2851087af9d58ea5da2c382.tar.gz
freebsd-ports-gnome-674124c7b3696b07b2851087af9d58ea5da2c382.tar.zst
freebsd-ports-gnome-674124c7b3696b07b2851087af9d58ea5da2c382.zip
Fix MySQL dependencies.
Diffstat (limited to 'net/prosearch')
-rw-r--r--net/prosearch/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/net/prosearch/Makefile b/net/prosearch/Makefile
index 66071601dc48..9bde58d88461 100644
--- a/net/prosearch/Makefile
+++ b/net/prosearch/Makefile
@@ -71,16 +71,14 @@ ${SITE_PERL}/${PERL_ARCH}/FCGI.pm:${PORTSDIR}/www/p5-FastCGI
.endif
.if defined(WITH_MYSQL)
-USE_MYSQL= YES
+USE_MYSQL= client
USE_PERL5_RUN= YES
-RUN_DEPENDS+=\
-${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql${MYSQL_VER}
+RUN_DEPENDS+=
+${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql
.endif
.if defined(WITH_DB) && defined(WITH_MYSQL)
-RUN_DEPENDS+=\
-${LOCALBASE}/libexec/mysqld:${PORTSDIR}/databases/mysql${MYSQL_VER}-server \
-mysqlhotcopy:${PORTSDIR}/databases/mysql${MYSQL_VER}-scripts
+USE_MYSQL= server
.endif
.if defined(WITH_PGSQL)