aboutsummaryrefslogtreecommitdiffstats
path: root/net/prosearch
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2012-06-30 22:39:14 +0800
committeraz <az@FreeBSD.org>2012-06-30 22:39:14 +0800
commitc4488f29abd1339c42a704fb50b07d1210e0f3bc (patch)
treea25208b0a392c23b33fbca24c07360b17a5572c2 /net/prosearch
parentb05a8fe37751aa289876d113a2ba1f68df128404 (diff)
downloadfreebsd-ports-gnome-c4488f29abd1339c42a704fb50b07d1210e0f3bc.tar.gz
freebsd-ports-gnome-c4488f29abd1339c42a704fb50b07d1210e0f3bc.tar.zst
freebsd-ports-gnome-c4488f29abd1339c42a704fb50b07d1210e0f3bc.zip
- Remove SITE_PERL from *_DEPENDS
Approved by: portmgr@ (bapt@)
Diffstat (limited to 'net/prosearch')
-rw-r--r--net/prosearch/Makefile24
1 files changed, 12 insertions, 12 deletions
diff --git a/net/prosearch/Makefile b/net/prosearch/Makefile
index d1ff86b4cc6a..57aac2e90665 100644
--- a/net/prosearch/Makefile
+++ b/net/prosearch/Makefile
@@ -49,16 +49,16 @@ OPTIONS=\
.include <bsd.port.pre.mk>
RUN_DEPENDS+=\
-${SITE_PERL}/lib/abs.pm:${PORTSDIR}/devel/p5-lib-abs
+p5-lib-abs>=0:${PORTSDIR}/devel/p5-lib-abs
.if defined(WITH_CRAWLER)
RUN_DEPENDS+=\
-${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
-${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI \
-${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
-${SITE_PERL}/${PERL_ARCH}/HTML/Entities.pm:${PORTSDIR}/www/p5-HTML-Parser \
+p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
+p5-URI>=0:${PORTSDIR}/net/p5-URI \
+p5-DBI>=0:${PORTSDIR}/databases/p5-DBI \
+p5-HTML-Parser>=0:${PORTSDIR}/www/p5-HTML-Parser \
nmap:${PORTSDIR}/security/nmap \
-${SITE_PERL}/Net/DirectConnect.pm:${PORTSDIR}/net-p2p/p5-Net-DirectConnect
+p5-Net-DirectConnect>=0:${PORTSDIR}/net-p2p/p5-Net-DirectConnect
.endif
.if defined(WITH_SAMBA)
@@ -90,7 +90,7 @@ ${LOCALBASE}/${APACHEMODDIR}/mod_perl.so:${PORTSDIR}/www/mod_perl2
.if defined(WITH_MOD_FASTCGI)
RUN_DEPENDS+=\
${LOCALBASE}/${APACHEMODDIR}/mod_fastcgi.so:${PORTSDIR}/www/mod_fastcgi \
-${SITE_PERL}/${PERL_ARCH}/FCGI.pm:${PORTSDIR}/www/p5-FCGI
+p5-FCGI>=0:${PORTSDIR}/www/p5-FCGI
.endif
.if defined(WITH_SPHINX)
@@ -102,7 +102,7 @@ searchd:${PORTSDIR}/textproc/sphinxsearch-devel
.if defined(WITH_MYSQL)
USE_MYSQL= client
RUN_DEPENDS+=\
-${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql
+p5-DBD-mysql>=0:${PORTSDIR}/databases/p5-DBD-mysql
.endif
.if defined(WITH_DB) && defined(WITH_MYSQL)
@@ -111,7 +111,7 @@ USE_MYSQL= server
.if defined(WITH_MARIA)
RUN_DEPENDS+=\
-${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql \
+p5-DBD-mysql>=0:${PORTSDIR}/databases/p5-DBD-mysql \
${LOCALBASE}bin/mysql:${PORTSDIR}/databases/mariadb-client
.endif
@@ -123,12 +123,12 @@ ${LOCALBASE}/libexec/mysqld:${PORTSDIR}/databases/mariadb-server
.if defined(WITH_PGSQL)
USE_PGSQL= yes
RUN_DEPENDS+=\
-${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg
+p5-DBD-Pg>=0:${PORTSDIR}/databases/p5-DBD-Pg
.endif
.if defined(WITH_PGPP)
RUN_DEPENDS+=\
-${SITE_PERL}/DBD/PgPP.pm:${PORTSDIR}/databases/p5-DBD-PgPP
+p5-DBD-PgPP>=0:${PORTSDIR}/databases/p5-DBD-PgPP
.endif
.if (defined(WITH_PGSQL) || defined(WITH_PGPP)) && defined(WITH_DB)
@@ -140,7 +140,7 @@ ${LOCALBASE}/bin/postgres:${PORTSDIR}/databases/postgresql${PGSQL_VER}-server
.if defined(WITH_SQLITE)
USE_SQLITE= yes
RUN_DEPENDS+=\
-${SITE_PERL}/${PERL_ARCH}/DBD/SQLite.pm:${PORTSDIR}/databases/p5-DBD-SQLite
+p5-DBD-SQLite>=0:${PORTSDIR}/databases/p5-DBD-SQLite
.endif
WRKSRC= ${WRKDIR}/search