aboutsummaryrefslogtreecommitdiffstats
path: root/net/proxy/Makefile
diff options
context:
space:
mode:
authorjasone <jasone@FreeBSD.org>2000-08-23 15:35:52 +0800
committerjasone <jasone@FreeBSD.org>2000-08-23 15:35:52 +0800
commitf5707c4de920d0d2e148d9eb333c500d53e5adda (patch)
tree3a7c583447db9fcf7de9a37b32cc1d6ba75097a0 /net/proxy/Makefile
parent5ec3727f7dab5e9c3642714eb022f2be5cae38a8 (diff)
downloadfreebsd-ports-gnome-f5707c4de920d0d2e148d9eb333c500d53e5adda.tar.gz
freebsd-ports-gnome-f5707c4de920d0d2e148d9eb333c500d53e5adda.tar.zst
freebsd-ports-gnome-f5707c4de920d0d2e148d9eb333c500d53e5adda.zip
Add ports for:
libstash - Algorithms and data structures library. libsock - TCP/IP networking library ncat - Like cat(1), but with sockets. proxy - Transparent logging proxy. All of these ports are part of a single source distribution, but they fit better into the ports scheme as separate ports.
Diffstat (limited to 'net/proxy/Makefile')
-rw-r--r--net/proxy/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/net/proxy/Makefile b/net/proxy/Makefile
new file mode 100644
index 000000000000..8e31e2f5f86a
--- /dev/null
+++ b/net/proxy/Makefile
@@ -0,0 +1,33 @@
+# New ports collection Makefile for: proxy
+# Date created: 22 August 2000
+# Whom: jasone
+#
+# $FreeBSD$
+#
+
+PORTNAME= proxy
+PORTVERSION= 1.0.0
+CATEGORIES= net
+DISTNAME= canonware-1.0.0
+MASTER_SITES= http://www.canonware.com/download/canonware/
+
+MAINTAINER= jasone@FreeBSD.org
+
+BUILD_DEPENDS= cook:${PORTSDIR}/devel/cook
+
+USE_AUTOCONF= yes
+GNU_CONFIGURE= yes
+
+MAN1= proxy.1
+MANCOMPRESSED= no
+
+do-build:
+ @(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} cook bin/proxy/src/proxy)
+
+do-install:
+ @(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} cook proxy_install_a)
+
+post-install:
+ @strip ${PREFIX}/bin/proxy
+
+.include <bsd.port.mk>