aboutsummaryrefslogtreecommitdiffstats
path: root/net/psi
diff options
context:
space:
mode:
authorpat <pat@FreeBSD.org>2002-07-28 13:35:42 +0800
committerpat <pat@FreeBSD.org>2002-07-28 13:35:42 +0800
commit536f0b01810ef5d9c23c854b0f3a0f68088dcc90 (patch)
treeb505f4776ef3d27e1c57ded657cfb1e083a43349 /net/psi
parent4e07f4b8f85a43eb1a71b3856b6412969e1eb400 (diff)
downloadfreebsd-ports-gnome-536f0b01810ef5d9c23c854b0f3a0f68088dcc90.tar.gz
freebsd-ports-gnome-536f0b01810ef5d9c23c854b0f3a0f68088dcc90.tar.zst
freebsd-ports-gnome-536f0b01810ef5d9c23c854b0f3a0f68088dcc90.zip
Add patch to fix missing line breaks in the chat box
Bump PORTREVISION PR: ports/40998 Submitted by: maintainer, Samuel Kesterson <samuelk@k-labs.com>
Diffstat (limited to 'net/psi')
-rw-r--r--net/psi/Makefile3
-rw-r--r--net/psi/files/patch-src::chatdlg.cpp24
-rw-r--r--net/psi/files/patch-src::ndns.cpp3
-rw-r--r--net/psi/files/template.patch-common.cpp2
4 files changed, 30 insertions, 2 deletions
diff --git a/net/psi/Makefile b/net/psi/Makefile
index eda5d03a6c28..6f569b1d8304 100644
--- a/net/psi/Makefile
+++ b/net/psi/Makefile
@@ -7,6 +7,7 @@
PORTNAME= psi
PORTVERSION= 0.8.6
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -23,7 +24,7 @@ MAKE_ARGS= QTDIR=${X11BASE}
EXTRA_PATCHES= ${WRKDIR}/patch-common.cpp
pre-patch:
- ${SED} s,%%PREFIX%%,${PREFIX}, ${PATCHDIR}/template.patch-common.cpp > \
+ ${SED} s,%%DATADIR%%,${DATADIR}, ${PATCHDIR}/template.patch-common.cpp > \
${WRKDIR}/patch-common.cpp
pre-build:
diff --git a/net/psi/files/patch-src::chatdlg.cpp b/net/psi/files/patch-src::chatdlg.cpp
new file mode 100644
index 000000000000..4c73eb0b316c
--- /dev/null
+++ b/net/psi/files/patch-src::chatdlg.cpp
@@ -0,0 +1,24 @@
+$FreeBSD$
+
+A workaround for a bug in qt-3.0.3. This patch file should be removed
+if we ever upgrade to qt-3.0.5
+
+--- src/chatdlg.cpp.orig Tue Jul 23 21:08:25 2002
++++ src/chatdlg.cpp Tue Jul 23 21:09:59 2002
+@@ -384,13 +384,13 @@
+
+ //t->setUpdatesEnabled(FALSE);
+ if(emote) {
+- t->append(QString("<font color=\"%1\">").arg(color) + QString("[%1]").arg(timestr) + QString(" *%1 ").arg(expandEntities(who)) + txt + "</font>");
++ t->append(QString("<BR><font color=\"%1\">").arg(color) + QString("[%1]").arg(timestr) + QString(" *%1 ").arg(expandEntities(who)) + txt + "</font>");
+ }
+ else {
+ if(option.chatSays)
+- t->append(QString("<font color=\"%1\">").arg(color) + QString("[%1] ").arg(timestr) + expandEntities(who) + QString(" says:</font><br>") + txt);
++ t->append(QString("<BR><font color=\"%1\">").arg(color) + QString("[%1] ").arg(timestr) + expandEntities(who) + QString(" says:</font><br>") + txt);
+ else
+- t->append(QString("<font color=\"%1\">").arg(color) + QString("[%1] &lt;").arg(timestr) + expandEntities(who) + QString("&gt;</font> ") + txt);
++ t->append(QString("<BR><font color=\"%1\">").arg(color) + QString("[%1] &lt;").arg(timestr) + expandEntities(who) + QString("&gt;</font> ") + txt);
+ }
+ if(!msg.subject.isEmpty()) {
+ t->append(QString("<b>") + tr("Subject:") + "</b> " + QString("%1").arg(expandEntities(msg.subject)));
diff --git a/net/psi/files/patch-src::ndns.cpp b/net/psi/files/patch-src::ndns.cpp
index 1a742aafc71e..8cd6c1d0f8d8 100644
--- a/net/psi/files/patch-src::ndns.cpp
+++ b/net/psi/files/patch-src::ndns.cpp
@@ -1,3 +1,6 @@
+$FreeBSD$
+
+
--- src/ndns.cpp.orig Thu Jul 11 18:49:42 2002
+++ src/ndns.cpp Thu Jul 11 18:40:24 2002
@@ -51,6 +51,7 @@
diff --git a/net/psi/files/template.patch-common.cpp b/net/psi/files/template.patch-common.cpp
index 0df99d5aab7c..cf3ef753838f 100644
--- a/net/psi/files/template.patch-common.cpp
+++ b/net/psi/files/template.patch-common.cpp
@@ -7,7 +7,7 @@ $FreeBSD$
QString getResourcesDir()
{
- return "/usr/local/psi";
-+ return "%%PREFIX%%/share/psi";
++ return "%%DATADIR%%";
}
QString getHomeDir()