aboutsummaryrefslogtreecommitdiffstats
path: root/net/py-timeoutsocket
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2007-04-23 16:57:03 +0800
committersat <sat@FreeBSD.org>2007-04-23 16:57:03 +0800
commit9ede5f5b9f862d029f777d761ba45f2d739cb624 (patch)
treec72a3ebeee1fbeb9ccb5e53a777c524ef359f8eb /net/py-timeoutsocket
parent8d916fc6275b79dbd1d82a45e56e4d4e8e5116b6 (diff)
downloadfreebsd-ports-gnome-9ede5f5b9f862d029f777d761ba45f2d739cb624.tar.gz
freebsd-ports-gnome-9ede5f5b9f862d029f777d761ba45f2d739cb624.tar.zst
freebsd-ports-gnome-9ede5f5b9f862d029f777d761ba45f2d739cb624.zip
Add port net/py-timeoutsocket:
timeoutsocket enables a timeout mechanism on all TCP connections. It does this by inserting a shim into the socket module. After this module has been imported, all socket creation goes through this shim. As a result, every TCP connection will support a timeout. The beauty of this method is that it immediately and transparently enables the entire python library to support timeouts on TCP sockets. WWW: http://www.timo-tasi.org/python/timeoutsocket.py Author: Timothy O'Malley <timo@alum.mit.edu>
Diffstat (limited to 'net/py-timeoutsocket')
-rw-r--r--net/py-timeoutsocket/Makefile20
-rw-r--r--net/py-timeoutsocket/distinfo3
-rw-r--r--net/py-timeoutsocket/pkg-descr10
-rw-r--r--net/py-timeoutsocket/pkg-plist3
4 files changed, 36 insertions, 0 deletions
diff --git a/net/py-timeoutsocket/Makefile b/net/py-timeoutsocket/Makefile
new file mode 100644
index 000000000000..8b44ccacc6e7
--- /dev/null
+++ b/net/py-timeoutsocket/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: timeoutsocket
+# Date created: 23 April 2007
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= timeoutsocket
+PORTVERSION= 1.23
+CATEGORIES= net python
+MASTER_SITES= CENKES
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Timeout mechanism for TCP connections
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+
+.include <bsd.port.mk>
diff --git a/net/py-timeoutsocket/distinfo b/net/py-timeoutsocket/distinfo
new file mode 100644
index 000000000000..d0ba700e9640
--- /dev/null
+++ b/net/py-timeoutsocket/distinfo
@@ -0,0 +1,3 @@
+MD5 (timeoutsocket-1.23.tar.gz) = b0377d66e8972924607ae084656d7c82
+SHA256 (timeoutsocket-1.23.tar.gz) = 754c991ff9d83d7566931311efe044c5483d4ad85099f0ab1155beb242626e53
+SIZE (timeoutsocket-1.23.tar.gz) = 4081
diff --git a/net/py-timeoutsocket/pkg-descr b/net/py-timeoutsocket/pkg-descr
new file mode 100644
index 000000000000..fd42d94db22a
--- /dev/null
+++ b/net/py-timeoutsocket/pkg-descr
@@ -0,0 +1,10 @@
+timeoutsocket enables a timeout mechanism on all TCP connections. It
+does this by inserting a shim into the socket module. After this module
+has been imported, all socket creation goes through this shim. As a
+result, every TCP connection will support a timeout.
+
+The beauty of this method is that it immediately and transparently
+enables the entire python library to support timeouts on TCP sockets.
+
+WWW: http://www.timo-tasi.org/python/timeoutsocket.py
+Author: Timothy O'Malley <timo@alum.mit.edu>
diff --git a/net/py-timeoutsocket/pkg-plist b/net/py-timeoutsocket/pkg-plist
new file mode 100644
index 000000000000..ec49c91bed66
--- /dev/null
+++ b/net/py-timeoutsocket/pkg-plist
@@ -0,0 +1,3 @@
+%%PYTHON_SITELIBDIR%%/timeoutsocket.py
+%%PYTHON_SITELIBDIR%%/timeoutsocket.pyc
+%%PYTHON_SITELIBDIR%%/timeoutsocket.pyo