aboutsummaryrefslogtreecommitdiffstats
path: root/net/py-tofu
diff options
context:
space:
mode:
authormnag <mnag@FreeBSD.org>2005-10-09 06:29:53 +0800
committermnag <mnag@FreeBSD.org>2005-10-09 06:29:53 +0800
commit3d6b03c47a499d16c428585708c15506a5d4817e (patch)
treed724d54848c4fb5da53894a9494a42fa4edefca8 /net/py-tofu
parent127b3bdb5894555f29875503f035b6c80a2c3319 (diff)
downloadfreebsd-ports-gnome-3d6b03c47a499d16c428585708c15506a5d4817e.tar.gz
freebsd-ports-gnome-3d6b03c47a499d16c428585708c15506a5d4817e.tar.zst
freebsd-ports-gnome-3d6b03c47a499d16c428585708c15506a5d4817e.zip
Tofu is a practical high-level network game engine, written
in Python and based on Twisted. Tofu is designed for games where players play one or several characters accross several levels. This includes jump'n run games, RPG or RTS, but not Tetris-like games or board game. It currently support client-server and single player mode; peer-to-peer mode may be added later. PR: 86956 Submitted by: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
Diffstat (limited to 'net/py-tofu')
-rw-r--r--net/py-tofu/Makefile35
-rw-r--r--net/py-tofu/distinfo2
-rw-r--r--net/py-tofu/pkg-descr13
-rw-r--r--net/py-tofu/pkg-plist19
4 files changed, 69 insertions, 0 deletions
diff --git a/net/py-tofu/Makefile b/net/py-tofu/Makefile
new file mode 100644
index 000000000000..3e5a36e144b3
--- /dev/null
+++ b/net/py-tofu/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: py-tofu
+# Date created: 2005-10-05
+# Whom: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tofu
+PORTVERSION= 0.2
+CATEGORIES= net python
+MASTER_SITES= http://download.gna.org/soya/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= Tofu-${PORTVERSION}
+EXTRACT_SUFX= .tar.bz2
+
+MAINTAINER= acardenas@bsd.org.pe
+COMMENT= Tofu is a practical high-level network game engine
+
+DIST_SUBDIR= python
+USE_BZIP2= yes
+USE_PYTHON= yes
+USE_TWISTED= yes
+USE_PYDISTUTILS= yes
+WRKSRC= ${WRKDIR}/Tofu-${PORTVERSION}
+EXAMPLESDIR= ${PREFIX}/share/examples/py-tofu
+
+.include <bsd.port.pre.mk>
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/demo/* ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/py-tofu/distinfo b/net/py-tofu/distinfo
new file mode 100644
index 000000000000..d2fe716cf6b2
--- /dev/null
+++ b/net/py-tofu/distinfo
@@ -0,0 +1,2 @@
+MD5 (python/Tofu-0.2.tar.bz2) = 95a337bc8f53a295c7f4bc7704634521
+SIZE (python/Tofu-0.2.tar.bz2) = 16123
diff --git a/net/py-tofu/pkg-descr b/net/py-tofu/pkg-descr
new file mode 100644
index 000000000000..516b835b6aa2
--- /dev/null
+++ b/net/py-tofu/pkg-descr
@@ -0,0 +1,13 @@
+Tofu is a practical high-level network game engine, written
+in Python and based on Twisted. Tofu is designed for games
+where players play one or several characters accross several
+levels.
+This includes jump'n run games, RPG or RTS, but not Tetris-like
+games or board game.
+
+It currently support client-server and single player mode;
+peer-to-peer mode may be added later.
+
+Tofu is Free Software, under the GNU LGPL license.
+
+WWW: http://home.gna.org/oomadness/en/tofu/index.html
diff --git a/net/py-tofu/pkg-plist b/net/py-tofu/pkg-plist
new file mode 100644
index 000000000000..6a95764c0e48
--- /dev/null
+++ b/net/py-tofu/pkg-plist
@@ -0,0 +1,19 @@
+lib/%%PYTHON_VERSION%%/site-packages/tofu/__init__.py
+lib/%%PYTHON_VERSION%%/site-packages/tofu/client.py
+lib/%%PYTHON_VERSION%%/site-packages/tofu/pickle_sec.py
+lib/%%PYTHON_VERSION%%/site-packages/tofu/server.py
+lib/%%PYTHON_VERSION%%/site-packages/tofu/single.py
+lib/%%PYTHON_VERSION%%/site-packages/tofu/__init__.pyc
+lib/%%PYTHON_VERSION%%/site-packages/tofu/client.pyc
+lib/%%PYTHON_VERSION%%/site-packages/tofu/pickle_sec.pyc
+lib/%%PYTHON_VERSION%%/site-packages/tofu/server.pyc
+lib/%%PYTHON_VERSION%%/site-packages/tofu/single.pyc
+lib/%%PYTHON_VERSION%%/site-packages/tofu/__init__.pyo
+lib/%%PYTHON_VERSION%%/site-packages/tofu/client.pyo
+lib/%%PYTHON_VERSION%%/site-packages/tofu/pickle_sec.pyo
+lib/%%PYTHON_VERSION%%/site-packages/tofu/server.pyo
+lib/%%PYTHON_VERSION%%/site-packages/tofu/single.pyo
+%%PORTDOCS%%%%EXAMPLESDIR%%/demo.py
+%%PORTDOCS%%%%EXAMPLESDIR%%/run_demo.py
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+@dirrm lib/%%PYTHON_VERSION%%/site-packages/tofu