aboutsummaryrefslogtreecommitdiffstats
path: root/net/py-xmlrpc
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2009-06-17 14:57:01 +0800
committersobomax <sobomax@FreeBSD.org>2009-06-17 14:57:01 +0800
commit175feaf49e8bc10b4bce3bb57058ee1c2aeb0ead (patch)
tree47d7ab2c46de9a3b6a97ba4545c6162e0f8513e8 /net/py-xmlrpc
parent403f6656097a2361e5734dca7513ccd0137b08a1 (diff)
downloadfreebsd-ports-gnome-175feaf49e8bc10b4bce3bb57058ee1c2aeb0ead.tar.gz
freebsd-ports-gnome-175feaf49e8bc10b4bce3bb57058ee1c2aeb0ead.tar.zst
freebsd-ports-gnome-175feaf49e8bc10b4bce3bb57058ee1c2aeb0ead.zip
Prevent precision loss when passing python's double values. Bump
PORTREVISION.
Diffstat (limited to 'net/py-xmlrpc')
-rw-r--r--net/py-xmlrpc/Makefile2
-rw-r--r--net/py-xmlrpc/files/patch-src_rpcUtils.c14
2 files changed, 15 insertions, 1 deletions
diff --git a/net/py-xmlrpc/Makefile b/net/py-xmlrpc/Makefile
index 623428c2ccfa..87e3a696b343 100644
--- a/net/py-xmlrpc/Makefile
+++ b/net/py-xmlrpc/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xmlrpc
PORTVERSION= 0.8.8.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net python
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= py-${PORTNAME}
diff --git a/net/py-xmlrpc/files/patch-src_rpcUtils.c b/net/py-xmlrpc/files/patch-src_rpcUtils.c
new file mode 100644
index 000000000000..dd35fa0ed57b
--- /dev/null
+++ b/net/py-xmlrpc/files/patch-src_rpcUtils.c
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- src/rpcUtils.c.orig
++++ src/rpcUtils.c
+@@ -276,7 +280,7 @@
+ double d;
+
+ d = PyFloat_AS_DOUBLE(value);
+- snprintf(buff, 255, "%f", d);
++ snprintf(buff, 255, "%.17f", d);
+ if ((buffConstant(sp, "<double>") == NULL)
+ or (buffConcat(sp, buff) == NULL)
+ or (buffConstant(sp, "</double>") == NULL))