aboutsummaryrefslogtreecommitdiffstats
path: root/net/quagga
diff options
context:
space:
mode:
authorzi <zi@FreeBSD.org>2011-10-18 22:43:45 +0800
committerzi <zi@FreeBSD.org>2011-10-18 22:43:45 +0800
commit8fa61f349d59aefe8bd04534b52e97f2f18d5111 (patch)
tree20222ef62baebe7d3b845f6aaa7652b0f8d0ec3e /net/quagga
parent75e742a3c26047b313aee8d7e3e74bba7fec5a3e (diff)
downloadfreebsd-ports-gnome-8fa61f349d59aefe8bd04534b52e97f2f18d5111.tar.gz
freebsd-ports-gnome-8fa61f349d59aefe8bd04534b52e97f2f18d5111.tar.zst
freebsd-ports-gnome-8fa61f349d59aefe8bd04534b52e97f2f18d5111.zip
- Resolve memory leak in bgpd
- Bump PORTREVISION WWW: http://lists.quagga.net/pipermail/quagga-users/2011-October/012529.html PR: ports/161668 Submitted by: Mike Tancsa <mike@sentex.net> Approved by: Boris Kovalenko <boris@tagnet.ru> (maintainer) Obtained from: quagga-users mailing list
Diffstat (limited to 'net/quagga')
-rw-r--r--net/quagga/Makefile1
-rw-r--r--net/quagga/files/patch-bgpd__bgp_attr.c10
2 files changed, 11 insertions, 0 deletions
diff --git a/net/quagga/Makefile b/net/quagga/Makefile
index 6502376250f1..c816e8ca2dcc 100644
--- a/net/quagga/Makefile
+++ b/net/quagga/Makefile
@@ -7,6 +7,7 @@
PORTNAME= quagga
PORTVERSION= 0.99.20
+PORTREVISION= 1
CATEGORIES= net ipv6
MASTER_SITES= http://quagga.net/download/ \
http://www.ru.quagga.net/download/ \
diff --git a/net/quagga/files/patch-bgpd__bgp_attr.c b/net/quagga/files/patch-bgpd__bgp_attr.c
new file mode 100644
index 000000000000..ed4b4eceb725
--- /dev/null
+++ b/net/quagga/files/patch-bgpd__bgp_attr.c
@@ -0,0 +1,10 @@
+--- ./bgpd/bgp_attr.c.orig 2011-10-18 10:12:39.000000000 -0400
++++ ./bgpd/bgp_attr.c 2011-10-18 10:13:01.000000000 -0400
+@@ -675,6 +675,7 @@
+ }
+
+ bgp_attr_unintern_sub (&tmp);
++ bgp_attr_extra_free (&tmp);
+ }
+
+ void