aboutsummaryrefslogtreecommitdiffstats
path: root/net/quagga
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2007-06-20 10:19:55 +0800
committeredwin <edwin@FreeBSD.org>2007-06-20 10:19:55 +0800
commitd2f61e13ba951b40a1e4eca7595a22ac006241c6 (patch)
tree132e9142574a94c4059aea9904e04427ca5e8c28 /net/quagga
parent04b79962f925847e95f2ed051972d58de4eec51a (diff)
downloadfreebsd-ports-gnome-d2f61e13ba951b40a1e4eca7595a22ac006241c6.tar.gz
freebsd-ports-gnome-d2f61e13ba951b40a1e4eca7595a22ac006241c6.tar.zst
freebsd-ports-gnome-d2f61e13ba951b40a1e4eca7595a22ac006241c6.zip
[patch] net/quagga - add optional delay after startup
I'm so tired of my machines rebooting and having to manually start half of the services because they were started when ospfd hadn't kicked in, so I added this quagga_delay to the rc.d file. PR: ports/113351 Submitted by: Edwin Groothuis <edwin@mavetju.org> Approved by: Boris Kovalenko <boris@tagnet.ru>
Diffstat (limited to 'net/quagga')
-rw-r--r--net/quagga/Makefile2
-rw-r--r--net/quagga/files/quagga.sh.in17
2 files changed, 14 insertions, 5 deletions
diff --git a/net/quagga/Makefile b/net/quagga/Makefile
index 914734f318d0..b05ca3c23187 100644
--- a/net/quagga/Makefile
+++ b/net/quagga/Makefile
@@ -7,7 +7,7 @@
PORTNAME= quagga
PORTVERSION= 0.99.7
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net ipv6
MASTER_SITES= http://quagga.net/download/ \
http://www.ru.quagga.net/download/ \
diff --git a/net/quagga/files/quagga.sh.in b/net/quagga/files/quagga.sh.in
index 9a28950558b3..b99665125cee 100644
--- a/net/quagga/files/quagga.sh.in
+++ b/net/quagga/files/quagga.sh.in
@@ -9,11 +9,14 @@
#quagga_enable="YES"
#
# You may also wish to use the following variables to fine-tune startup:
-#quagga_flags="-d"
-#quagga_daemons="zebra ripd ripngd ospfd ospf6d bgpd isisd"
+# quagga_flags="-d"
+# quagga_daemons="zebra ripd ripngd ospfd ospf6d bgpd isisd"
# Per daemon tuning may be done with daemon_name_flags
-#zebra_flags="-dP 0"
-#bgpd_flags="-dnrP 0" and so on
+# zebra_flags="-dP 0"
+# bgpd_flags="-dnrP 0" and so on
+# If you want to give the routing deamons a chance to catchup before
+# continueing, set quagga_delay to a certain amount of seconds.
+# quagga_delay="30"
#
#
# If the quagga daemons require additional shared libraries to start,
@@ -42,6 +45,7 @@ load_rc_config $name
: ${quagga_flags="-d"}
: ${quagga_daemons="zebra ripd ripngd ospfd ospf6d bgpd isisd"}
: ${quagga_extralibs_path=""}
+: ${quagga_delay="0"}
quagga_cmd=$1
@@ -78,3 +82,8 @@ for daemon in ${quagga_daemons}; do
eval flags=\$\{${daemon}_flags:-\"${quagga_flags}\"\}
run_rc_command "$1"
done
+
+if [ "${quagga_delay}" != "0" ]; then
+ echo "Sleeping ${quagga_delay} to obtain dynamic routing information..."
+ sleep ${quagga_delay}
+fi