aboutsummaryrefslogtreecommitdiffstats
path: root/net/queso/Makefile
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>1998-10-25 07:31:27 +0800
committerobrien <obrien@FreeBSD.org>1998-10-25 07:31:27 +0800
commited556d15c19af5bce0c823c47f65359edb846ebd (patch)
tree6431d35c50a88d6096f48b80ddacfb0f56813552 /net/queso/Makefile
parenteb38460b63c3f8b09a16aa2b65dc60ce52f9a9f5 (diff)
downloadfreebsd-ports-gnome-ed556d15c19af5bce0c823c47f65359edb846ebd.tar.gz
freebsd-ports-gnome-ed556d15c19af5bce0c823c47f65359edb846ebd.tar.zst
freebsd-ports-gnome-ed556d15c19af5bce0c823c47f65359edb846ebd.zip
QueSO determines a remote OS by sending simple TCP packets and analysing
the result.
Diffstat (limited to 'net/queso/Makefile')
-rw-r--r--net/queso/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/net/queso/Makefile b/net/queso/Makefile
new file mode 100644
index 000000000000..93fce753d6a2
--- /dev/null
+++ b/net/queso/Makefile
@@ -0,0 +1,37 @@
+# ex:ts=8
+# Ports collection makefile for: Queso
+# Version required: 980922
+# Date created: 13 Oct 1998
+# Whom: Wu Ching-hong <woju@freebsd.ee.ntu.edu.tw>
+# and David O'Brien (obrien@NUXI.com)
+#
+# $Id: Makefile,v 1.2 1997/01/25 18:08:40 obrien Exp $
+#
+
+DISTNAME= queso-980922
+CATEGORIES= net security
+MASTER_SITES= ftp://apostols.org/AposTools/snapshots/ \
+ ftp://ftp.ee.lbl.gov/ \
+ ftp://freebsd.ntu.edu.tw/freebsd/_distfiles/
+DISTFILES= queso-980922.tar.gz
+
+MAINTAINER= woju@freebsd.ee.ntu.edu.tw
+
+OSVERSION!= sysctl -n kern.osreldate
+GNU_CONFIGURE= yes
+
+.if ${OSVERSION} < 300004
+DISTFILES+= libpcap-0.4.tar.Z
+post-patch:
+ @cd ${WRKSRC}/../libpcap-0.4/; ./configure; make
+.endif
+
+post-install:
+ #${INSTALL_PROGRAM} ${WRKSRC}/queso ${PREFIX}/sbin
+ #${INSTALL_DATA} ${WRKSRC}/queso.conf ${PREFIX}/etc
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/queso
+ ${INSTALL_DATA} ${WRKSRC}/Documentation.txt ${PREFIX}/share/doc/queso
+.endif
+
+.include <bsd.port.mk>