aboutsummaryrefslogtreecommitdiffstats
path: root/net/rdesktop
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2012-10-09 10:11:46 +0800
committerobrien <obrien@FreeBSD.org>2012-10-09 10:11:46 +0800
commit38a490ba83be8cfde73b54dc62b8874d4a876afc (patch)
tree9d6a517cfa22d8f7569c5f5a091003c9b40a78dd /net/rdesktop
parent1baef13c7c943d65a6092cc9d65f6514527c6ff2 (diff)
downloadfreebsd-ports-gnome-38a490ba83be8cfde73b54dc62b8874d4a876afc.tar.gz
freebsd-ports-gnome-38a490ba83be8cfde73b54dc62b8874d4a876afc.tar.zst
freebsd-ports-gnome-38a490ba83be8cfde73b54dc62b8874d4a876afc.zip
During normal operation, rdesktop keeps a clipping rectangle set to the
size of the desktop. However, the clipping rectangle is not reset when the size of the desktop changes. This means that when the size of the desktop increases, the area outside the original size will not be drawn. Submitted by: des
Diffstat (limited to 'net/rdesktop')
-rw-r--r--net/rdesktop/Makefile2
-rw-r--r--net/rdesktop/files/patch-xwin.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/net/rdesktop/Makefile b/net/rdesktop/Makefile
index 6b44a09f213f..077bb1cc4cf3 100644
--- a/net/rdesktop/Makefile
+++ b/net/rdesktop/Makefile
@@ -7,7 +7,7 @@
PORTNAME= rdesktop
PORTVERSION= 1.7.1
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES= net comms ipv6
MASTER_SITES= SF
diff --git a/net/rdesktop/files/patch-xwin.c b/net/rdesktop/files/patch-xwin.c
new file mode 100644
index 000000000000..6fd0e978b9ff
--- /dev/null
+++ b/net/rdesktop/files/patch-xwin.c
@@ -0,0 +1,11 @@
+$FreeBSD$
+
+--- xwin.c.orig 2011-04-13 04:13:04.000000000 -0700
++++ xwin.c 2012-10-08 19:06:06.000000000 -0700
+@@ -2150,4 +2150,6 @@ ui_resize_window()
+ g_backstore = bs;
+ }
++
++ ui_reset_clip();
+ }
+