aboutsummaryrefslogtreecommitdiffstats
path: root/net/rdesktop
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2008-05-21 12:52:03 +0800
committerobrien <obrien@FreeBSD.org>2008-05-21 12:52:03 +0800
commit5897f18f74a5237b33db98e32915f925d468c6d6 (patch)
tree2e0537f901685d100e9b6fb8d885379c20cdcce2 /net/rdesktop
parent075f54150842204cf3be8d0b219a76224023fb77 (diff)
downloadfreebsd-ports-gnome-5897f18f74a5237b33db98e32915f925d468c6d6.tar.gz
freebsd-ports-gnome-5897f18f74a5237b33db98e32915f925d468c6d6.tar.zst
freebsd-ports-gnome-5897f18f74a5237b33db98e32915f925d468c6d6.zip
Upgrade to version 1.6.0.
Also enable IPv6 by default (define WITHOUT_IPV6 if this causes you trouble).
Diffstat (limited to 'net/rdesktop')
-rw-r--r--net/rdesktop/Makefile10
-rw-r--r--net/rdesktop/distinfo6
-rw-r--r--net/rdesktop/files/patch-rdpsnd_oss.c57
-rw-r--r--net/rdesktop/files/patch-xwin.c11
4 files changed, 10 insertions, 74 deletions
diff --git a/net/rdesktop/Makefile b/net/rdesktop/Makefile
index 39a58b2bd66c..5be8cf1cfbc7 100644
--- a/net/rdesktop/Makefile
+++ b/net/rdesktop/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= rdesktop
-PORTVERSION= 1.5.0
-PORTREVISION?= 3
-CATEGORIES= net comms
+PORTVERSION= 1.6.0
+PORTREVISION?= 0
+CATEGORIES= net comms ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -22,6 +22,10 @@ GNU_CONFIGURE= yes
DOCS= doc/AUTHORS doc/TODO doc/*.txt
MAN1= rdesktop.1
+.if !defined(WITHOUT_IPV6)
+CONFIGURE_ARGS+= --with-ipv6
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/rdesktop ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/doc/rdesktop.1 ${MAN1PREFIX}/man/man1
diff --git a/net/rdesktop/distinfo b/net/rdesktop/distinfo
index 1883a09001fc..0c2f142e6270 100644
--- a/net/rdesktop/distinfo
+++ b/net/rdesktop/distinfo
@@ -1,3 +1,3 @@
-MD5 (rdesktop-1.5.0.tar.gz) = 433546f60fc0f201e99307ba188369ed
-SHA256 (rdesktop-1.5.0.tar.gz) = 5ead17c3d29cb1028aeca485ee7a8c65694c1b02a1b7014c3da920b265a438aa
-SIZE (rdesktop-1.5.0.tar.gz) = 245137
+MD5 (rdesktop-1.6.0.tar.gz) = c6fcbed7f0ad7e60ac5fcb2d324d8b16
+SHA256 (rdesktop-1.6.0.tar.gz) = 35026eaa8e14ca8bd0ba3730926f14222f8452f2ac662623bbf1909d8b060979
+SIZE (rdesktop-1.6.0.tar.gz) = 284728
diff --git a/net/rdesktop/files/patch-rdpsnd_oss.c b/net/rdesktop/files/patch-rdpsnd_oss.c
deleted file mode 100644
index 636805eb85ec..000000000000
--- a/net/rdesktop/files/patch-rdpsnd_oss.c
+++ /dev/null
@@ -1,57 +0,0 @@
---- rdpsnd_oss.c.orig 2007-08-20 23:20:40.000000000 -0700
-+++ rdpsnd_oss.c 2007-08-20 23:21:51.000000000 -0700
-@@ -51,6 +51,35 @@
- } packet_queue[MAX_QUEUE];
- static unsigned int queue_hi, queue_lo;
-
-+/** Frees the first audio packet in the queue (that is, packet_queue[queue_lo]),
-+ * sending a completion notification back to the server.
-+ *
-+ * @return True if the packet queue has become empty; False otherwise.&nbsp;
-+ *
-+ * If the packet queue is not empty, queue_lo will point at the next packet to
-+ * play.
-+ */
-+static BOOL
-+packet_done(void)
-+{
-+ struct audio_packet *packet = &packet_queue[queue_lo++];
-+ queue_lo %= MAX_QUEUE;
-+ rdpsnd_send_completion(packet->tick, packet->index);
-+ free(packet->s.data);
-+ return (queue_lo == queue_hi);
-+}
-+
-+/** Discards all audio packets queued, sending completion notifications back to
-+ * the server as necessary.
-+ */
-+static void
-+clear_queue(void)
-+{
-+ while (queue_lo != queue_hi)
-+ packet_done();
-+ g_dsp_busy = False;
-+}
-+
- BOOL
- wave_out_open(void)
- {
-@@ -74,6 +103,7 @@
- wave_out_close(void)
- {
- close(g_dsp_fd);
-+ clear_queue();
- }
-
- BOOL
-@@ -277,9 +307,7 @@
-
- if (elapsed >= (duration * 85) / 100)
- {
-- rdpsnd_send_completion(packet->tick, packet->index);
-- free(out->data);
-- queue_lo = (queue_lo + 1) % MAX_QUEUE;
-+ packet_done();
- started = False;
- }
- else
diff --git a/net/rdesktop/files/patch-xwin.c b/net/rdesktop/files/patch-xwin.c
deleted file mode 100644
index 6d27fc9f1d90..000000000000
--- a/net/rdesktop/files/patch-xwin.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- xwin.c.orig Fri Jun 1 10:27:15 2007
-+++ xwin.c Fri Jun 1 10:28:26 2007
-@@ -3219,7 +3219,7 @@
- return;
-
- image = XCreateImage(g_display, g_visual, g_depth, ZPixmap, 0,
-- (char *) data, cx, cy, BitmapPad(g_display), cx * g_bpp / 8);
-+ (char *) data, cx, cy, g_bpp, 0);
-
- if (g_ownbackstore)
- {