aboutsummaryrefslogtreecommitdiffstats
path: root/net/rdesktop
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2002-06-30 09:47:07 +0800
committerdemon <demon@FreeBSD.org>2002-06-30 09:47:07 +0800
commitabb2acaf449095ba7bbdf8726662ae9467e9a846 (patch)
tree55227140adb9b51496786667e62df6f22c6d7677 /net/rdesktop
parentfeeb11801fddb690208b9350d61f8b8226438951 (diff)
downloadfreebsd-ports-gnome-abb2acaf449095ba7bbdf8726662ae9467e9a846.tar.gz
freebsd-ports-gnome-abb2acaf449095ba7bbdf8726662ae9467e9a846.tar.zst
freebsd-ports-gnome-abb2acaf449095ba7bbdf8726662ae9467e9a846.zip
USE_REINPLACE;
Chase library version of libgmp4; PR: 39975 Submitted by: "Chris Knight" <chris@aims.com.au> (maintainer)
Diffstat (limited to 'net/rdesktop')
-rw-r--r--net/rdesktop/Makefile21
1 files changed, 12 insertions, 9 deletions
diff --git a/net/rdesktop/Makefile b/net/rdesktop/Makefile
index 7c0c07ef3ed7..0e38d4ca1615 100644
--- a/net/rdesktop/Makefile
+++ b/net/rdesktop/Makefile
@@ -23,6 +23,7 @@ USE_XLIB= yes
USE_BZIP2= yes
USE_GMAKE= yes
USE_OPENSSL= yes
+USE_REINPLACE= yes
MAN1= rdesktop.1
ALL_TARGET=
@@ -30,24 +31,26 @@ ALL_TARGET=
.include <bsd.port.pre.mk>
.if ${OSVERSION} > 500023
-LIB_DEPENDS= gmp.5:${PORTSDIR}/math/libgmp4
+LIB_DEPENDS= gmp.6:${PORTSDIR}/math/libgmp4
.endif
do-patch:
@${EXTRACT_CMD} -dc ${_DISTDIR}/${PATCHFILES} | \
${PATCH} ${PATCH_DIST_ARGS}
.if ${OSVERSION} > 500023
- @${PERL} -pi.orig -e 's:-O2.*-Wall:${CFLAGS} -I${LOCALBASE}/include:g' \
+ @${REINPLACE_CMD} -e 's:-O2.*-Wall:${CFLAGS} -I${LOCALBASE}/include:g' \
${WRKSRC}/Makefile
- @${PERL} -pi.orig -e 's:-lgmp:-L${LOCALBASE}/lib -lgmp:g' \
+ @${REINPLACE_CMD} -e 's:-lgmp:-L${LOCALBASE}/lib -lgmp:g' \
${WRKSRC}/Makefile
.else
- @${PERL} -pi.orig -e 's:-O2.*-Wall:${CFLAGS}:g' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's:-O2.*-Wall:${CFLAGS}:g' ${WRKSRC}/Makefile
.endif
- @${PERL} -pi.orig -e 's:/usr/X11R6/:${X11BASE}/:g' ${WRKSRC}/Makefile
- @${PERL} -pi.orig -e 's:^PREFIX.*:PREFIX=${PREFIX}:g' ${WRKSRC}/Makefile
- @${PERL} -pi.orig -e 's:^install.*:install\: rdesktop:g' ${WRKSRC}/Makefile
- @${PERL} -pi.orig -e 's:^.*\(INSTALL\) rdp-srvr.*::g' ${WRKSRC}/Makefile
- @${PERL} -pi.orig -e 's:<endian.h>:<machine/endian.h>:g' ${WRKSRC}/rdesktop.h
+ @${REINPLACE_CMD} -e 's:/usr/X11R6/:${X11BASE}/:g' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's:^PREFIX.*:PREFIX=${PREFIX}:g' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's:^install.*:install\: rdesktop:g' \
+ ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's:^.*\(INSTALL\) rdp-srvr.*::g' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's:<endian.h>:<machine/endian.h>:g' \
+ ${WRKSRC}/rdesktop.h
.include <bsd.port.post.mk>