aboutsummaryrefslogtreecommitdiffstats
path: root/net/remmina
diff options
context:
space:
mode:
authoravl <avl@FreeBSD.org>2009-12-14 10:15:16 +0800
committeravl <avl@FreeBSD.org>2009-12-14 10:15:16 +0800
commit471123f5752e69644206521705de691edb2b9e75 (patch)
tree33d1c5e113b087397c5ae2d0cc6dc0ee9f15f893 /net/remmina
parent23b41201464396e8e40584d89077cf6470fc47e7 (diff)
downloadfreebsd-ports-gnome-471123f5752e69644206521705de691edb2b9e75.tar.gz
freebsd-ports-gnome-471123f5752e69644206521705de691edb2b9e75.tar.zst
freebsd-ports-gnome-471123f5752e69644206521705de691edb2b9e75.zip
- Update remmina to 0.7.0
- Connect remmina to the build - Disconnect grdc - Remove grdc, project was renamed
Diffstat (limited to 'net/remmina')
-rw-r--r--net/remmina/Makefile62
-rw-r--r--net/remmina/distinfo6
-rw-r--r--net/remmina/pkg-descr14
-rw-r--r--net/remmina/pkg-plist70
4 files changed, 114 insertions, 38 deletions
diff --git a/net/remmina/Makefile b/net/remmina/Makefile
index 075e3fe96fee..ecbd1f1249e2 100644
--- a/net/remmina/Makefile
+++ b/net/remmina/Makefile
@@ -5,50 +5,71 @@
# $FreeBSD$
#
-PORTNAME= grdc
-PORTVERSION= 0.6.0
+PORTNAME= remmina
+PORTVERSION= 0.7.0
CATEGORIES= net gnome
-MASTER_SITES= SF
+MASTER_SITES= SF/${PORTNAME}/0.7/
MAINTAINER= avl@FreeBSD.org
-COMMENT= GTK+/GNOME remote desktop client
+COMMENT= The GTK+ Remote Desktop Client
RUN_DEPENDS= rdesktop:${PORTSDIR}/net/rdesktop
OPTIONS= VNC "Build with VNC protocol support" off \
+ GNUTLS "Build VNC with GNUTLS encryption support" off \
+ XDMCP "Build with XDMCP protocol support" off \
SSH "Build with SSH tunneling support" off \
- GCRYPT "Build with libgcrypt support (only with SSH)" off \
+ GCRYPT "Build with libgcrypt support for password encryption" off \
TERM "Build with terminal support" off \
- AVAHI "Build with Avahi support" off
+ AVAHI "Build with Avahi support" off \
+ UNIQUE "Build with Unique-App support" off
MAKE_JOBS_SAFE= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_GETTEXT= yes
-USE_GNOME= gnomehack gnomeprefix glib20 gtk20
-CFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+USE_GNOME= glib20 gtk20 desktopfileutils
+INSTALLS_ICONS= yes
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
-CONFIGURE_ENV= CFLAGS="${CFLAGS}" \
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="${LDFLAGS}"
.include <bsd.port.pre.mk>
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.else
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.endif
+
.if defined(WITH_VNC)
-LIB_DEPENDS+= vncclient.0:${PORTSDIR}/net/libvncserver
+LIB_DEPENDS+= jpeg.10:${PORTSDIR}/graphics/jpeg
+.if defined(WITH_GNUTLS)
+LIB_DEPENDS+= gnutls:${PORTSDIR}/security/gnutls
+.endif
.else
CONFIGURE_ARGS+= --disable-vnc
.endif
+.if defined(WITH_XDMCP)
+RUN_DEPENDS+= Xephyr:${PORTSDIR}/x11-servers/xephyr
+.endif
+
.if defined(WITH_SSH)
-LIB_DEPENDS+= ssh.3:${PORTSDIR}/security/libssh
+LIB_DEPENDS+= ssh.4:${PORTSDIR}/security/libssh
+.if ${OSVERSION} >= 800040
+LDFLAGS+= -fstack-protector
+.endif
+.else
+CONFIGURE_ARGS+= --disable-ssh
+.endif
+
.if defined(WITH_GCRYPT)
LIB_DEPENDS+= gcrypt.16:${PORTSDIR}/security/libgcrypt
.else
CONFIGURE_ARGS+= --disable-gcrypt
.endif
-.else
-CONFIGURE_ARGS+= --disable-ssh
-.endif
.if defined(WITH_TERM)
USE_GNOME+= vte
@@ -62,8 +83,13 @@ LIB_DEPENDS+= avahi-ui.0:${PORTSDIR}/net/avahi-gtk
CONFIGURE_ARGS+= --disable-avahi
.endif
-post-patch:
- @${REINPLACE_CMD} -e 's|Exec=grdc|Exec=${LOCALBASE}/bin/grdc|' \
- ${WRKSRC}/src/grdc.desktop.in
+.if defined(WITH_UNIQUE)
+LIB_DEPENDS+= unique-1.0.2:${PORTSDIR}/x11-toolkits/unique
+.else
+CONFIGURE_ARGS+= --disable-unique
+.endif
+
+post-install:
+ @-update-desktop-database
.include <bsd.port.post.mk>
diff --git a/net/remmina/distinfo b/net/remmina/distinfo
index 599dd4f6ea17..8d1d9e744243 100644
--- a/net/remmina/distinfo
+++ b/net/remmina/distinfo
@@ -1,3 +1,3 @@
-MD5 (grdc-0.6.0.tar.gz) = df82963a6abc9e5b8e15f97e198eb751
-SHA256 (grdc-0.6.0.tar.gz) = 63c7d740ef9653b5f725406f24eff0a6288bb08446fef7208675bd00ed75eb18
-SIZE (grdc-0.6.0.tar.gz) = 245008
+MD5 (remmina-0.7.0.tar.gz) = 45f5a4597c144319873238bc4995d423
+SHA256 (remmina-0.7.0.tar.gz) = 8e7256facce54535bc998b4347519a49b38c8da9fee5e35bb0d7058ee00c8bd5
+SIZE (remmina-0.7.0.tar.gz) = 614790
diff --git a/net/remmina/pkg-descr b/net/remmina/pkg-descr
index 8332ba679326..fa23a7f47332 100644
--- a/net/remmina/pkg-descr
+++ b/net/remmina/pkg-descr
@@ -1,9 +1,12 @@
-Grdc is a remote desktop client based on GTK+ and GNOME.
+Remmina is a remote desktop client written in GTK+, aiming to be useful for
+system administrators and travellers, who need to work with lots of remote
+computers in front of either large monitors or tiny netbooks. Remmina supports
+multiple network protocols in an integrated and consistant user interface.
-The Grdc main program:
+The Remmina main program:
* A pure GTK+ 2.0 application!
- * Maintain a list of remote desktop files for most frequently used servers
+ * Maintain a list of remote desktop files, organized by groups
* Make quick connections by directly putting in the server name
* Remote desktops with higher resolutions are scrollable/scalable in both
window and fullscreen mode
@@ -11,6 +14,7 @@ The Grdc main program:
mouse moves over the screen edge.
* Floating toolbar in fullscreen mode, allows you to switch between modes,
toggle keyboard grabbing, minimize, etc.
- * Supported network protocols: RDP, VNC, SSH, Avahi
+ * Tabbed interface, optionally managed by groups
+ * Supported network protocols: RDP, VNC, XDMCP, SSH, Avahi
-WWW: http://grdc.sourceforge.net/
+WWW: http://remmina.sourceforge.net/
diff --git a/net/remmina/pkg-plist b/net/remmina/pkg-plist
index 93b25dd6bcf1..519ec93f6c24 100644
--- a/net/remmina/pkg-plist
+++ b/net/remmina/pkg-plist
@@ -1,14 +1,60 @@
-bin/grdc
-share/applications/grdc.desktop
-share/locale/el/LC_MESSAGES/grdc.mo
-share/locale/es/LC_MESSAGES/grdc.mo
-share/locale/pl/LC_MESSAGES/grdc.mo
-share/locale/zh_CN/LC_MESSAGES/grdc.mo
-share/pixmaps/grdc-rdp-ssh.png
-share/pixmaps/grdc-rdp.png
-share/pixmaps/grdc-ssh.png
-share/pixmaps/grdc-vnc-ssh.png
-share/pixmaps/grdc-vnc.png
-share/pixmaps/grdc.png
+bin/remmina
+share/applications/remmina.desktop
+%%DATADIR%%/icons/hicolor/16x16/actions/remmina-fit-window.png
+%%DATADIR%%/icons/hicolor/16x16/actions/remmina-leave-fullscreen.png
+%%DATADIR%%/icons/hicolor/16x16/actions/remmina-scale.png
+%%DATADIR%%/icons/hicolor/16x16/actions/remmina-scrolled-fullscreen.png
+%%DATADIR%%/icons/hicolor/16x16/actions/remmina-viewport-fullscreen.png
+%%DATADIR%%/icons/hicolor/16x16/actions/remmina-switch-page.png
+%%DATADIR%%/icons/hicolor/16x16/emblems/remmina-rdp.png
+%%DATADIR%%/icons/hicolor/16x16/emblems/remmina-rdp-ssh.png
+%%DATADIR%%/icons/hicolor/16x16/emblems/remmina-vnc.png
+%%DATADIR%%/icons/hicolor/16x16/emblems/remmina-vnc-ssh.png
+%%DATADIR%%/icons/hicolor/16x16/emblems/remmina-xdmcp.png
+%%DATADIR%%/icons/hicolor/16x16/emblems/remmina-xdmcp-ssh.png
+%%DATADIR%%/icons/hicolor/16x16/emblems/remmina-sftp.png
+%%DATADIR%%/icons/hicolor/22x22/actions/remmina-fit-window.png
+%%DATADIR%%/icons/hicolor/22x22/actions/remmina-leave-fullscreen.png
+%%DATADIR%%/icons/hicolor/22x22/actions/remmina-scale.png
+%%DATADIR%%/icons/hicolor/22x22/actions/remmina-scrolled-fullscreen.png
+%%DATADIR%%/icons/hicolor/22x22/actions/remmina-viewport-fullscreen.png
+%%DATADIR%%/icons/hicolor/22x22/actions/remmina-switch-page.png
+%%DATADIR%%/icons/hicolor/22x22/emblems/remmina-rdp.png
+%%DATADIR%%/icons/hicolor/22x22/emblems/remmina-rdp-ssh.png
+%%DATADIR%%/icons/hicolor/22x22/emblems/remmina-vnc.png
+%%DATADIR%%/icons/hicolor/22x22/emblems/remmina-vnc-ssh.png
+%%DATADIR%%/icons/hicolor/22x22/emblems/remmina-xdmcp.png
+%%DATADIR%%/icons/hicolor/22x22/emblems/remmina-xdmcp-ssh.png
+%%DATADIR%%/icons/hicolor/22x22/emblems/remmina-sftp.png
+%%NLS%%share/locale/de/LC_MESSAGES/remmina.mo
+%%NLS%%share/locale/el/LC_MESSAGES/remmina.mo
+%%NLS%%share/locale/es/LC_MESSAGES/remmina.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/remmina.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/remmina.mo
+%%NLS%%share/locale/it/LC_MESSAGES/remmina.mo
+%%NLS%%share/locale/lt/LC_MESSAGES/remmina.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/remmina.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/remmina.mo
+%%NLS%%share/locale/pt_PT/LC_MESSAGES/remmina.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/remmina.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/remmina.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/remmina.mo
+share/icons/hicolor/16x16/apps/remmina.png
+share/icons/hicolor/22x22/apps/remmina.png
+share/icons/hicolor/24x24/apps/remmina.png
+share/icons/hicolor/32x32/apps/remmina.png
+share/icons/hicolor/48x48/apps/remmina.png
+share/icons/hicolor/scalable/apps/remmina.svg
+@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
+@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
+@dirrm %%DATADIR%%/icons/hicolor/22x22/actions
+@dirrm %%DATADIR%%/icons/hicolor/22x22/emblems
+@dirrm %%DATADIR%%/icons/hicolor/22x22
+@dirrm %%DATADIR%%/icons/hicolor/16x16/actions
+@dirrm %%DATADIR%%/icons/hicolor/16x16/emblems
+@dirrm %%DATADIR%%/icons/hicolor/16x16
+@dirrm %%DATADIR%%/icons/hicolor
+@dirrm %%DATADIR%%/icons
+@dirrm %%DATADIR%%
@dirrmtry share/applications
@dirrmtry share/pixmaps