aboutsummaryrefslogtreecommitdiffstats
path: root/net/rp-pppoe
diff options
context:
space:
mode:
authorvs <vs@FreeBSD.org>2004-06-24 22:26:50 +0800
committervs <vs@FreeBSD.org>2004-06-24 22:26:50 +0800
commit77b4973817411c9b124abcf5dbce472aea1e82a0 (patch)
tree5e63ee25219d117d3b3e83de202e131e49ca5eec /net/rp-pppoe
parent443a2b1097a833547ce13148a6da6459b6f716e0 (diff)
downloadfreebsd-ports-gnome-77b4973817411c9b124abcf5dbce472aea1e82a0.tar.gz
freebsd-ports-gnome-77b4973817411c9b124abcf5dbce472aea1e82a0.tar.zst
freebsd-ports-gnome-77b4973817411c9b124abcf5dbce472aea1e82a0.zip
Re-add net/rp-pppoe (v 3.5)
PR: ports/68113 Submitted by: Matthias Andree
Diffstat (limited to 'net/rp-pppoe')
-rw-r--r--net/rp-pppoe/Makefile85
-rw-r--r--net/rp-pppoe/distinfo2
-rw-r--r--net/rp-pppoe/pkg-descr10
-rw-r--r--net/rp-pppoe/pkg-plist15
4 files changed, 112 insertions, 0 deletions
diff --git a/net/rp-pppoe/Makefile b/net/rp-pppoe/Makefile
new file mode 100644
index 000000000000..f9d6b096b1c7
--- /dev/null
+++ b/net/rp-pppoe/Makefile
@@ -0,0 +1,85 @@
+# New ports collection makefile for: popular pppd pppoe client
+# Date created: 22 Mar 2001
+# Whom: Mario Sergio Fujikawa Ferreira <liouxFreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= rp-pppoe
+PORTVERSION= 3.5
+CATEGORIES= net
+MASTER_SITES= http://www.roaringpenguin.com/penguin/pppoe/
+
+MAINTAINER= matthias.andree@gmx.de
+COMMENT= "The popular Roaring Penguin's PPPoE software"
+
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_WRKSRC= ${WRKSRC}/src
+BUILD_WRKSRC= ${WRKSRC}/src
+
+MAN5= pppoe.conf.5
+MAN8= adsl-connect.8 adsl-setup.8 adsl-start.8 adsl-status.8 \
+ adsl-stop.8 pppoe-relay.8 pppoe-server.8 pppoe.8
+
+CONFIG_FILES= firewall-masq firewall-standalone pap-secrets \
+ pppoe-server-options pppoe.conf
+DOC_FILES= CHANGES HOW-TO-CONNECT KERNEL-MODE-PPPOE LICENSE \
+ PROBLEMS
+SCRIPT_FILES= adsl-connect adsl-init adsl-setup adsl-start \
+ adsl-status adsl-stop
+.ifndef (NOPORTDOCS)
+PORTDOCS= *
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e "s!/etc/ppp!${PREFIX}/etc/ppp!g" ${WRKSRC}/man/*
+ @${REINPLACE_CMD} -e 's!/etc/ppp!$$(prefix)/etc/ppp!g' \
+ ${WRKSRC}/src/Makefile.in
+.for file in adsl-connect adsl-init adsl-setup adsl-start
+ @${REINPLACE_CMD} -e 's!/etc/+ppp!$${prefix}/etc/ppp!g' \
+ ${WRKSRC}/scripts/${file}.in
+.endfor
+ @${REINPLACE_CMD} -e 's!pty!tty!g' ${WRKSRC}/scripts/adsl-connect.in
+ @${REINPLACE_CMD} -e 's!/var/lock/subsys/adsl!/var/tmp/rp_pppoe_adsl!g' \
+ ${WRKSRC}/scripts/adsl-init.in
+.for f in adsl-status adsl-stop.in
+ @${REINPLACE_CMD} -e "s!/etc/ppp!${PREFIX}/etc/ppp!g" \
+ ${WRKSRC}/scripts/${f}
+.endfor
+
+do-install:
+# Binaries
+.for f in pppoe pppoe-server
+ @${INSTALL_PROGRAM} ${BUILD_WRKSRC}/${f} ${PREFIX}/sbin
+.endfor
+# Configurations
+ @${MKDIR} ${PREFIX}/etc/ppp
+.for f in ${CONFIG_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/configs/${f} \
+ ${PREFIX}/etc/ppp/${f}.sample
+.endfor
+.if !exists(${PREFIX}/etc/ppp/pppoe.conf)
+ ${INSTALL_SCRIPT} ${PREFIX}/etc/ppp/pppoe.conf.sample \
+ ${PREFIX}/etc/ppp/pppoe.conf
+.endif
+# Manual pages
+ @${MKDIR} ${MAN5PREFIX}/man/man5
+.for f in ${MAN5}
+ @${INSTALL_MAN} ${WRKSRC}/man/${f} ${MAN5PREFIX}/man/man5
+.endfor
+ @${MKDIR} ${MAN8PREFIX}/man/man8
+.for f in ${MAN8}
+ @${INSTALL_MAN} ${WRKSRC}/man/${f} ${MAN8PREFIX}/man/man8
+.endfor
+# Scripts
+.for f in ${SCRIPT_FILES}
+ @${INSTALL_SCRIPT} ${WRKSRC}/scripts/${f} ${PREFIX}/sbin
+.endfor
+# Documentation
+.ifndef (NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
+.endif /* NOPORTDOCS */
+
+.include <bsd.port.mk>
diff --git a/net/rp-pppoe/distinfo b/net/rp-pppoe/distinfo
new file mode 100644
index 000000000000..d5ef4a16b443
--- /dev/null
+++ b/net/rp-pppoe/distinfo
@@ -0,0 +1,2 @@
+MD5 (rp-pppoe-3.5.tar.gz) = 97972f8f8f6a3ab9b7070333a6a29c4b
+SIZE (rp-pppoe-3.5.tar.gz) = 189321
diff --git a/net/rp-pppoe/pkg-descr b/net/rp-pppoe/pkg-descr
new file mode 100644
index 000000000000..450300929694
--- /dev/null
+++ b/net/rp-pppoe/pkg-descr
@@ -0,0 +1,10 @@
+PPPoE (Point-to-Point Protocol over Ethernet) is a protocol used
+by many ADSL service providers. Roaring Penguin's PPPoE software
+is a reliable program for connecting unix systems to PPPoE service
+providers without requiring any kernel patches.
+
+Note that this port has had little testing (it works on 5-CURRENT
+to access T-Online in Germany from the client side) and the server side
+is entirely untested.
+
+WWW: http://www.roaringpenguin.com/pppoe/
diff --git a/net/rp-pppoe/pkg-plist b/net/rp-pppoe/pkg-plist
new file mode 100644
index 000000000000..d127ac2a78ad
--- /dev/null
+++ b/net/rp-pppoe/pkg-plist
@@ -0,0 +1,15 @@
+sbin/adsl-connect
+sbin/adsl-init
+sbin/adsl-setup
+sbin/adsl-start
+sbin/adsl-status
+sbin/adsl-stop
+sbin/pppoe
+sbin/pppoe-server
+etc/ppp/firewall-masq.sample
+etc/ppp/firewall-standalone.sample
+etc/ppp/pap-secrets.sample
+etc/ppp/pppoe-server-options.sample
+@unexec if cmp -s %D/etc/ppp/pppoe.conf.sample %D/etc/ppp/pppoe.conf ; then rm %D/etc/ppp/pppoe.conf ; fi
+etc/ppp/pppoe.conf.sample
+@unexec rmdir %D/etc/ppp 2>/dev/null || echo "If you are permanently removing pppoe, you should also ``rm -Rf ${PKG_PREFIX}/etc/ppp'' removing any configuration and password files left." | /usr/bin/fmt