aboutsummaryrefslogtreecommitdiffstats
path: root/net/rsync
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2008-06-26 22:03:48 +0800
committerehaupt <ehaupt@FreeBSD.org>2008-06-26 22:03:48 +0800
commit6fc04dcf088695fc3a7427c0e6ae19fa54b26f25 (patch)
treed6e3e6b06fefae23aa50f1d3a95d3453f6f08394 /net/rsync
parent2dbf2b60ab03cc7cc9d38aef7ed57aadfb3d3f0c (diff)
downloadfreebsd-ports-gnome-6fc04dcf088695fc3a7427c0e6ae19fa54b26f25.tar.gz
freebsd-ports-gnome-6fc04dcf088695fc3a7427c0e6ae19fa54b26f25.tar.zst
freebsd-ports-gnome-6fc04dcf088695fc3a7427c0e6ae19fa54b26f25.zip
Provide an optional "Time limit patch"
PR: 124553 Submitted by: Adrian Thearle <adrian@thearle.com.au>
Diffstat (limited to 'net/rsync')
-rw-r--r--net/rsync/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/net/rsync/Makefile b/net/rsync/Makefile
index 917afe73d14d..d120cff67cd5 100644
--- a/net/rsync/Makefile
+++ b/net/rsync/Makefile
@@ -42,11 +42,20 @@ OPTIONS= POPT_PORT "Use popt from devel/popt instead of bundled one" off \
SSH "Use SSH instead of RSH" on \
FLAGS "File system flags support patch, adds --fileflags" off \
ACL "Add backward-compatibility for the --acls option" off \
- ICONV "Add iconv support" off
+ ICONV "Add iconv support" off \
+ TIMELIMIT "Time limit patch" off
.include <bsd.port.pre.mk>
-.if defined(WITH_ICONV) || defined(WITH_FLAGS) || defined(WITH_ACL) || make(makesum)
+.if !defined(WITHOUT_TIMELIMIT)
+PATCH_STRIP= -p1
+EXTRA_PATCHES+= ${WRKSRC}/patches/time-limit.diff
+.if defined(WITH_FLAGS)
+IGNORE= flags and timelimit can't be both enabled at the same time. Please rerun 'make config' and disable one of them
+.endif
+.endif
+
+.if defined(WITH_ICONV) || defined(WITH_FLAGS) || defined(WITH_ACL) || make(makesum) || defined(WITH_TIMELIMIT)
DISTFILES+= ${PORTNAME}-patches-${PORTVERSION}${EXTRACT_SUFX}
.endif