aboutsummaryrefslogtreecommitdiffstats
path: root/net/rsync
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2008-03-12 22:09:22 +0800
committerehaupt <ehaupt@FreeBSD.org>2008-03-12 22:09:22 +0800
commit80f7bff963ad1a85719f9b330f0a13f60dae6e78 (patch)
tree2004319630ff3dba0b0c0382f719fb67eeb2ee4f /net/rsync
parentf8ad7d2995c438a54c13aaa52f5d32114899aff8 (diff)
downloadfreebsd-ports-gnome-80f7bff963ad1a85719f9b330f0a13f60dae6e78.tar.gz
freebsd-ports-gnome-80f7bff963ad1a85719f9b330f0a13f60dae6e78.tar.zst
freebsd-ports-gnome-80f7bff963ad1a85719f9b330f0a13f60dae6e78.zip
Add optional iconv support
Diffstat (limited to 'net/rsync')
-rw-r--r--net/rsync/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/net/rsync/Makefile b/net/rsync/Makefile
index 402920478da6..e3fcb8ef871f 100644
--- a/net/rsync/Makefile
+++ b/net/rsync/Makefile
@@ -39,10 +39,18 @@ MAN5= rsyncd.conf.5
OPTIONS= POPT_PORT "Use popt from devel/popt instead of bundled one" off \
SSH "Use SSH instead of RSH" on \
FLAGS "File system flags support patch, adds --fileflags" off \
- ACL "Add backward-compatibility for the --acls option" off
+ ACL "Add backward-compatibility for the --acls option" off \
+ ICONV "Add iconv support" off
.include <bsd.port.pre.mk>
+.if defined(WITH_ICONV)
+USE_ICONV= yes
+CONFIGUREDCFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}" CONFIGUREDCFLAGS="${CONFIGUREDCFLAGS}"
+.endif
+
.if defined(WITH_FLAGS)
USE_PERL5_BUILD=yes
PATCH_STRIP= -p1