aboutsummaryrefslogtreecommitdiffstats
path: root/net/rsync
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2012-04-04 05:08:40 +0800
committerehaupt <ehaupt@FreeBSD.org>2012-04-04 05:08:40 +0800
commit1de6e34411bf37d94827560b0fd6f0e9a14bc53e (patch)
treeba2377cfe21f571fe01dcb295201ae3dd00a301f /net/rsync
parent56bc639a39e478e5932413af929a4064db69ab95 (diff)
downloadfreebsd-ports-gnome-1de6e34411bf37d94827560b0fd6f0e9a14bc53e.tar.gz
freebsd-ports-gnome-1de6e34411bf37d94827560b0fd6f0e9a14bc53e.tar.zst
freebsd-ports-gnome-1de6e34411bf37d94827560b0fd6f0e9a14bc53e.zip
Introduce an option that builds rsync with the "detect-renamed" patch. It
detects renamed hierarchies and avoids re-copying the files in those hierarchies. Requested by: "J.R. Oldroyd" <jr@opal.com> (via mail) Feature safe: yes
Diffstat (limited to 'net/rsync')
-rw-r--r--net/rsync/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/net/rsync/Makefile b/net/rsync/Makefile
index 5ab2ba7487df..c14c9ef0a297 100644
--- a/net/rsync/Makefile
+++ b/net/rsync/Makefile
@@ -43,7 +43,8 @@ OPTIONS= POPT_PORT "Use popt from devel/popt instead of bundled one" off \
ATIMES "Preserve access times, adds --atimes" off \
ACL "Add backward-compatibility for the --acls option" off \
ICONV "Add iconv support" off \
- TIMELIMIT "Time limit patch" off
+ TIMELIMIT "Time limit patch" off \
+ RENAMED "Add support for renamed file detection" on
.include <bsd.port.pre.mk>
@@ -66,7 +67,7 @@ IGNORE= flags and atimes can't be enabled simultaneously. Please rerun 'make co
.endif
.endif
-.if defined(WITH_ICONV) || defined(WITH_FLAGS) || defined(WITH_ACL) || make(makesum) || defined(WITH_TIMELIMIT) || defined(WITH_ATIMES)
+.if defined(WITH_ICONV) || defined(WITH_FLAGS) || defined(WITH_ACL) || make(makesum) || defined(WITH_TIMELIMIT) || defined(WITH_ATIMES) || defined(WITH_RENAMED)
DISTFILES+= ${PORTNAME}-patches-${PORTVERSION}${EXTRACT_SUFX}
CFLAGS+= -I${LOCALBASE}/include
.endif
@@ -87,6 +88,11 @@ PATCH_STRIP= -p1
EXTRA_PATCHES+= ${WRKSRC}/patches/fileflags.diff
.endif
+.if defined(WITH_RENAMED)
+PATCH_STRIP= -p1
+EXTRA_PATCHES+= ${WRKSRC}/patches/detect-renamed.diff
+.endif
+
.if defined(WITH_ACL)
PATCH_STRIP= -p1
EXTRA_PATCHES+= ${WRKSRC}/patches/acls.diff