aboutsummaryrefslogtreecommitdiffstats
path: root/net/rsync
diff options
context:
space:
mode:
authorkoitsu <koitsu@FreeBSD.org>2008-07-09 20:44:01 +0800
committerkoitsu <koitsu@FreeBSD.org>2008-07-09 20:44:01 +0800
commit68e32ddc351073dee73e1bad330053dda09201ab (patch)
tree03e66663f86cf69b43dfc699ee0b2b8ce493e45b /net/rsync
parent0bb45aefa8d94f8a4c1b0d6ea22d12b3dc73f26e (diff)
downloadfreebsd-ports-gnome-68e32ddc351073dee73e1bad330053dda09201ab.tar.gz
freebsd-ports-gnome-68e32ddc351073dee73e1bad330053dda09201ab.tar.zst
freebsd-ports-gnome-68e32ddc351073dee73e1bad330053dda09201ab.zip
Add support for --atimes patch, which preserves access times.
Reviewed by: ehaupt Approved by: ehaupt
Diffstat (limited to 'net/rsync')
-rw-r--r--net/rsync/Makefile14
1 files changed, 13 insertions, 1 deletions
diff --git a/net/rsync/Makefile b/net/rsync/Makefile
index b1c7f14918e0..d0c8c5514200 100644
--- a/net/rsync/Makefile
+++ b/net/rsync/Makefile
@@ -40,6 +40,7 @@ MAN5= rsyncd.conf.5
OPTIONS= POPT_PORT "Use popt from devel/popt instead of bundled one" off \
SSH "Use SSH instead of RSH" on \
FLAGS "File system flags support patch, adds --fileflags" off \
+ ATIMES "Preserve access times, adds --atimes" off \
ACL "Add backward-compatibility for the --acls option" off \
ICONV "Add iconv support" off \
TIMELIMIT "Time limit patch" off
@@ -52,9 +53,20 @@ EXTRA_PATCHES+= ${WRKSRC}/patches/time-limit.diff
.if defined(WITH_FLAGS)
IGNORE= flags and timelimit can't be both enabled at the same time. Please rerun 'make config' and disable one of them
.endif
+.if defined(WITH_ATIMES)
+IGNORE= atimes and timelimit can't be enabled simultaneously. Please rerun 'make config' and disable one of them
+.endif
+.endif
+
+.if !defined(WITHOUT_ATIMES)
+PATCH_STRIP= -p1
+EXTRA_PATCHES+= ${WRKSRC}/patches/atimes.diff
+.if defined(WITH_FLAGS)
+IGNORE= flags and atimes can't be enabled simultaneously. Please rerun 'make config' and disable one of them
+.endif
.endif
-.if defined(WITH_ICONV) || defined(WITH_FLAGS) || defined(WITH_ACL) || make(makesum) || defined(WITH_TIMELIMIT)
+.if defined(WITH_ICONV) || defined(WITH_FLAGS) || defined(WITH_ACL) || make(makesum) || defined(WITH_TIMELIMIT) || defined(WITH_ATIMES)
DISTFILES+= ${PORTNAME}-patches-${PORTVERSION}${EXTRACT_SUFX}
.endif