aboutsummaryrefslogtreecommitdiffstats
path: root/net/rtpbreak
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-02-16 18:52:50 +0800
committermiwi <miwi@FreeBSD.org>2008-02-16 18:52:50 +0800
commitcb0ed1a250da27bcc3785dd8cc649c99849e6be5 (patch)
treebc37be80bfea09d7393b135e9c2ee14069f9c405 /net/rtpbreak
parente7c42a258747028e4fa2e04329c30cd5724c017a (diff)
downloadfreebsd-ports-gnome-cb0ed1a250da27bcc3785dd8cc649c99849e6be5.tar.gz
freebsd-ports-gnome-cb0ed1a250da27bcc3785dd8cc649c99849e6be5.tar.zst
freebsd-ports-gnome-cb0ed1a250da27bcc3785dd8cc649c99849e6be5.zip
rtpbreak detects, reconstructs and analyzes any RTP [rfc1889] session through
heuristics over the UDP network traffic. It works well with SIP, H.323, SCCP and any other signaling protocol. In particular, it doesn't require the presence of RTCP packets (voipong needs them) that aren't always transmitted from the recent VoIP clients. WWW: http://xenion.antifork.org/rtpbreak/ PR: ports/120728 Submitted by: Prudhvi Krishna <prudhvikrishna at gmail.com>
Diffstat (limited to 'net/rtpbreak')
-rw-r--r--net/rtpbreak/Makefile28
-rw-r--r--net/rtpbreak/distinfo3
-rw-r--r--net/rtpbreak/pkg-descr7
3 files changed, 38 insertions, 0 deletions
diff --git a/net/rtpbreak/Makefile b/net/rtpbreak/Makefile
new file mode 100644
index 000000000000..c3b6e4ae46a4
--- /dev/null
+++ b/net/rtpbreak/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: rtpbreak
+# Date created: 16 February 2008
+# Whom: Prudhvi Krishna <prudhvikrishna@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= rtpbreak
+PORTVERSION= 1.2
+CATEGORIES= net
+MASTER_SITES= http://xenion.antifork.org/rtpbreak/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= prudhvikrishna@gmail.com
+COMMENT= Detects, reconstructs and analyzes any RTP session
+
+BUILD_DEPENDS= libnet11-config:${PORTSDIR}/net/libnet
+
+MAKE_ARGS+= CFLAGS="-Wall -O3 -I${LOCALBASE}/include/libnet11" \
+ LIBS="-L${LOCALBASE}/lib/libnet11 -lpcap -lnet" \
+ DEFS="-DPATH_MAX=256"
+
+PLIST_FILES= bin/rtpbreak
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/rtpbreak ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/net/rtpbreak/distinfo b/net/rtpbreak/distinfo
new file mode 100644
index 000000000000..599f4a29f7bc
--- /dev/null
+++ b/net/rtpbreak/distinfo
@@ -0,0 +1,3 @@
+MD5 (rtpbreak-1.2.tgz) = 06a0259452c34b406b2b26443f0cf2b9
+SHA256 (rtpbreak-1.2.tgz) = 5231bdbc123462e1b86b2a0c1fdfa608877c051e44e610d73f4c80bb263c2092
+SIZE (rtpbreak-1.2.tgz) = 50902
diff --git a/net/rtpbreak/pkg-descr b/net/rtpbreak/pkg-descr
new file mode 100644
index 000000000000..2092f8873cc4
--- /dev/null
+++ b/net/rtpbreak/pkg-descr
@@ -0,0 +1,7 @@
+rtpbreak detects, reconstructs and analyzes any RTP [rfc1889] session through
+heuristics over the UDP network traffic. It works well with SIP, H.323, SCCP
+and any other signaling protocol. In particular, it doesn't require the presence
+of RTCP packets (voipong needs them) that aren't always transmitted from the
+recent VoIP clients.
+
+WWW: http://xenion.antifork.org/rtpbreak/