aboutsummaryrefslogtreecommitdiffstats
path: root/net/ruby-mpi/Makefile
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2007-08-06 03:01:59 +0800
committerthierry <thierry@FreeBSD.org>2007-08-06 03:01:59 +0800
commit7f1620fdcee5b230e0703a88f9b9849f9ccea493 (patch)
tree6e6740d2856c2df3e000ee5e73e7bb758952b3b2 /net/ruby-mpi/Makefile
parente8cc5c1a12c1a608356c1c1641c3e9148c31f1c5 (diff)
downloadfreebsd-ports-gnome-7f1620fdcee5b230e0703a88f9b9849f9ccea493.tar.gz
freebsd-ports-gnome-7f1620fdcee5b230e0703a88f9b9849f9ccea493.tar.zst
freebsd-ports-gnome-7f1620fdcee5b230e0703a88f9b9849f9ccea493.zip
- Link with gfortran to fix the build with MPICH; (1)
- Use MPICH2 unless WITH_MPICH1 is set; - Add a missing RUN_DEPENDS for mpirun. Reported by: pointyhat via Pav (1)
Diffstat (limited to 'net/ruby-mpi/Makefile')
-rw-r--r--net/ruby-mpi/Makefile15
1 files changed, 12 insertions, 3 deletions
diff --git a/net/ruby-mpi/Makefile b/net/ruby-mpi/Makefile
index e468e57cdb43..976f8c78aaf3 100644
--- a/net/ruby-mpi/Makefile
+++ b/net/ruby-mpi/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mpi
PORTVERSION= 0.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net ruby
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=${PORTNAME}ruby
@@ -18,12 +18,21 @@ DIST_SUBDIR= ruby
MAINTAINER= ports@FreeBSD.org
COMMENT= Ruby binding of MPI (Message Passing Interface)
-BUILD_DEPENDS= ${LOCALBASE}/mpich/lib/libmpich.a:${PORTSDIR}/net/mpich
+BUILD_DEPENDS= ${LOCALBASE}/mpich${MPICH_VER}/lib/libmpich.a:${PORTSDIR}/net/mpich${MPICH_VER}
+RUN_DEPENDS= ${LOCALBASE}/mpich${MPICH_VER}/lib/libmpich.a:${PORTSDIR}/net/mpich${MPICH_VER}
USE_BZIP2= yes
USE_RUBY= yes
HAS_CONFIGURE= yes
-CONFIGURE_ARGS+= --with-mpi-path=${LOCALBASE}/mpich
+CONFIGURE_ARGS+= --with-mpi-path=${LOCALBASE}/mpich${MPICH_VER}
+
+.if defined(WITH_MPICH1)
+USE_FORTRAN= yes
+FORTRANLIBDIR2= `${DIRNAME} \`gfortran42 -print-libgcc-file-name\``/../../../
+CONFIGURE_ENV+= LDFLAGS="-L${FORTRANLIBDIR2} -lgfortran"
+.else
+MPICH_VER= 2
+.endif
MAN1= mpi_ruby.1
MAN3= MPI_Comm.3 MPI_Exception.3 MPI_Group.3 MPI_Keyval.3 MPI_Op.3 MPI_Request.3 \
>- Update to 20140211sunpoet2014-02-152-3/+3 * - Reassign lioux' ports to the heaptabthorpe2014-02-151-1/+1 * - Update to 20140125sunpoet2014-02-062-3/+3 * - Update gimp-help ports to 2.8.1. Polish translation has been removed, newmakc2014-02-012-0/+16 * Remove ispell which is deprecated for long, consider using aspell instead or ...bapt2014-01-296-78/+0 * Support stagebapt2014-01-282-2/+0 * - Update to 20140102sunpoet2014-01-122-3/+3 * - Update to 20131229sunpoet2013-12-302-3/+3 * - Update Calligra Suite to 2.7.5.avilla2013-12-176-11/+8 * - Update to 20131125sunpoet2013-12-092-3/+3 * - use STAGEDIRdinoex2013-11-292-2/+0 * - Update to 20131118sunpoet2013-11-212-3/+3 * - Use single space after WWW:sunpoet2013-11-181-1/+1 * - Update to 20110813sunpoet2013-11-172-3/+3 * Stagifybapt2013-11-041-5/+4 * Stagifybapt2013-11-041-6/+5 * - Update to 4.0.6.jkim2013-10-264-10/+8 * - Update to 20131006sunpoet2013-10-122-3/+3 * - Update to 20131001sunpoet2013-10-042-6/+5 * Add NO_STAGE all over the place in preparation for the staging support (cat: ...bapt2013-09-2117-36/+22 * - Update to 20130902sunpoet2013-09-092-3/+3 * Update to 4.0.5.jkim2013-08-232-8/+8 * KDE3 and QT3 expired on 2013-07-01, remove these ports.rene2013-07-279-4811/+0 * Hopefully finish fixing the l10n ports after r322586 and r322618.rakuco2013-07-101-0/+1 * Fix INDEX by really fixing the kde4-l10n portsbapt2013-07-101-0/+1 * KDE4 l10n fixes.rakuco2013-07-104-6/+2 * Update the KDE Software Compilation to 4.10.5.rakuco2013-07-052-4/+4 * Update to KDE SC 4.10.4, proudly presented by the KDE on FreeBSD team.rakuco2013-07-032-4/+4 * Update to 4.0.4.jkim2013-06-202-8/+8 * KDE/FreeBSD team presents KDE SC 4.10.3 ports!makc2013-05-194-8/+5 * Update to 4.0.3.jkim2013-05-102-8/+8 * Rely on bsdtar to autodetermine the format of the distfiles when possiblebapt2013-04-291-4/+0 * - Convert USE_GETTEXT to USES (part 2)ak2013-04-242-2/+2 * - Update to 20130331sunpoet2013-04-192-4/+5 * Update to 4.0.2.jkim2013-04-172-8/+8 * - Update Calligra and l10n ports to 2.6.2:avilla2013-03-304-14/+10 * KDE/FreeBSD team presents KDE SC 4.10.1 ports!makc2013-03-278-46/+120 * Update to 4.0.1.jkim2013-03-092-8/+8 * Merge from area51 repository:makc2013-02-055-10/+6 * Update to 3.6.5.jkim2013-02-052-8/+8 * KDE/FreeBSD team presents KDE SC 4.9.5 ports!makc2013-02-047-93/+112 * Bump PORTREVISION after DESKTOP_ENTRIES updatemakc2013-01-231-0/+1 * - Deprecate QT3, KDE3 and unmaintained ports depending on them. QT 3.3.8beat2012-12-302-0/+6 * - Update to 3.5.7.jkim2012-10-274-18/+8 * - cleanup commentsdinoex2012-10-132-8/+0 * Cleanup headers of ports created by megarga2012-10-111-5/+0 * - Update to 20121006 (pt_PT) and 2012-06-09 (pt_BR)sunpoet2012-10-113-13/+9 * - Update Calligra Suite to 2.5.2.avilla2012-09-172-4/+4 * - Update Calligra to 2.5.1.avilla2012-09-014-14/+4 * The KDE/FreeBSD team is pleased to announce version 2.5 of Calligra,avilla2012-08-264-30/+6 * - Update to 3.5.6.jkim2012-08-242-8/+8 * - Fix typos in COMMENTcs2012-08-021-1/+1 * - Update LibreOffice and the language packs to 3.5.5.jkim2012-07-182-8/+8 * - Update to 20120711sunpoet2012-07-132-3/+3 * - Update Calligra to 2.4.3.avilla2012-07-052-4/+4 * - The FreeBSD Office team is proud to announce LibreOffice.org 3.5.4 releasefluffy2012-07-012-8/+8 * - Update to 20120611sunpoet2012-06-182-3/+3 * KDE/FreeBSD team presents KDE SC 4.8.4, probably the last release in 4.8.x se...makc2012-06-155-6/+18 * - update png to 1.5.10dinoex2012-06-014-2/+4 * - Remove koffice-i18n ports, as they are not very useful withoutavilla2012-05-319-794/+0 * The KDE/FreeBSD team is pleased to announce Calligra Suite 2.4.2, KDEavilla2012-05-3117-502/+151 * KDE/FreeBSD team presents long awaited KDE SC 4.8.3!makc2012-05-258-56/+206 * - Update to 20120503sunpoet2012-05-062-3/+3 * - upgrade to 3.5.2bapt2012-04-237-0/+44 * - Update to 20120312sunpoet2012-03-142-3/+3 * - Bump PORTREVISION to chase the update of multimedia/libvpxashish2012-02-162-0/+2 * The KDE/FreeBSD team is pleased to announce KDE SC 4.7.4, whichavilla2012-01-253-5/+5 * - Update to 20120118sunpoet2012-01-222-3/+3 * - Update to 20120112sunpoet2012-01-132-3/+3 * - Update to 20111225sunpoet2011-12-282-3/+3 * - Update to 20111207sunpoet2011-12-082-3/+3 * - Update to 20111204sunpoet2011-12-072-3/+3 * - Pass maintainership to office@FreeBSD.orgsunpoet2011-11-292-2/+2 * - Update to 20111126sunpoet2011-11-282-3/+3 * - Update to 20111119sunpoet2011-11-212-3/+3 * The KDE on FreeBSD team is pleased to update the KDE4 ports to 4.7.3.rakuco2011-11-142-4/+4 * - Update to 20111102sunpoet2011-11-072-3/+3 * - Update to 20111025sunpoet2011-10-302-3/+3 * The vast majority of pkg-descr files had the following format when theydougb2011-10-241-2/+0 * The KDE/FreeBSD team is pleased to announce KDE Software Compilationavilla2011-10-175-37/+270 * - Update to 20110928sunpoet2011-10-032-3/+3 * - Update to 20110909sunpoet2011-09-192-3/+3 * - Set DIST_SUBDIR: move dist files to DISTDIR/mythessunpoet2011-08-182-2/+3 * - Set DIST_SUBDIR: move dist files to DISTDIR/hyphensunpoet2011-08-182-2/+3 * - Set DIST_SUBDIR: move dist files to DISTDIR/hunspellsunpoet2011-08-182-4/+5 * - Change MASTER_SITES to my LOCAL to avoid implicit change of non-versionedsunpoet2011-08-184-8/+8 * - Update to 20110814sunpoet2011-08-162-3/+3 * - Update to 20110813sunpoet2011-08-152-4/+3 * - Set WRKSRCsunpoet2011-08-131-1/+2 * - Unify COMMENT and pkg-descrsunpoet2011-08-132-2/+2 * - Use WRKSRCsunpoet2011-08-121-1/+1 * Remove WWW entries from unmaintained ports that return 404 or where the domainehaupt2011-08-031-2/+0 * - Move language prefix to PKGNAMEPREFIXsunpoet2011-07-293-29/+29 * - Fix typosunpoet2011-07-251-1/+1 * Pass matainership to the new office teambapt2011-07-223-3/+3 * Add some locales thesaurusbapt2011-07-214-0/+41 * Add Portuguese hyphenation rulesbapt2011-07-214-0/+35 * Add portuguese and bresilian hunspell dictionnarybapt2011-07-204-0/+49 * Reset maintainership de jure. In fact KDE 3 has not been maintained by our teammakc2011-07-084-4/+4 * Update KDE Software Compilation ports to 4.6.5makc2011-07-085-5/+195 * - remove MD5ohauer2011-07-031-1/+0 * The FreeBSD KDE Team is pleased to announce KDE SC 4.6.4. Read fullavilla2011-06-142-4/+4 * Update KDE Software Compilation ports to 4.6.3makc2011-05-174-4/+102 * - Update KOffice to 2.3.3.avilla2011-04-134-8/+8 * The FreeBSD KDE Team is pleased to announce April updates for KDEavilla2011-04-073-4/+22 * - Update KOffice to 2.3.1.avilla2011-03-258-186/+76 * The FreeBSD KDE Team is pleased to announce KDE SC 4.6.1 and KDE PIMavilla2011-03-256-51/+200 * - Get Rid MD5 supportmiwi2011-03-1910-10/+0 * - Remove unnecessary PKGNAMEPREFIX declarationsunpoet2011-01-094-4/+0 * - The KDE FreeBSD team is proud to announce the release of KDE 4.5.5fluffy2011-01-082-4/+4 * KDE FreeBSD team presents KDE SC 4.5.4.makc2010-12-034-12/+4 * KDE FreeBSD team presents KDE SC 4.5.3.makc2010-11-043-6/+8 * Deprecate md5 in favour of sha256 checksums. md5 checksums will no longererwin2010-10-291-1/+1 * KDE FreeBSD team presents KDE SC 4.5.2.makc2010-10-065-24/+50 * Autotools update. Read ports/UPDATING 20100915 for details.ade2010-09-164-8/+4 * As previously advertised, remove the remaining ports that have nodougb2010-09-056-3266/+0 * KDE FreeBSD team presents KDE SC 4.5.1.makc2010-09-036-1002/+312 * Update KOffice l10n ports to 2.2.2makc2010-08-286-28/+12 * Update distinfo. The distfiles have been re-rolled for some reason.hrs2010-08-161-3/+3