aboutsummaryrefslogtreecommitdiffstats
path: root/net/ruby-socketproxy
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2001-07-20 03:06:03 +0800
committerknu <knu@FreeBSD.org>2001-07-20 03:06:03 +0800
commit7c5bf114fcb7a2301c57ac64d50f8fe02b764aff (patch)
tree5461df9d5c1174759ff6db7e4b6323b30fe04138 /net/ruby-socketproxy
parent56348b8070cda5feb752cce1d377c56e1e065850 (diff)
downloadfreebsd-ports-gnome-7c5bf114fcb7a2301c57ac64d50f8fe02b764aff.tar.gz
freebsd-ports-gnome-7c5bf114fcb7a2301c57ac64d50f8fe02b764aff.tar.zst
freebsd-ports-gnome-7c5bf114fcb7a2301c57ac64d50f8fe02b764aff.zip
Add ruby-tcpsocketpipe, a Ruby library to create I/O pipes for TCP
socket tunneling.
Diffstat (limited to 'net/ruby-socketproxy')
-rw-r--r--net/ruby-socketproxy/Makefile32
-rw-r--r--net/ruby-socketproxy/distinfo1
-rw-r--r--net/ruby-socketproxy/pkg-comment1
-rw-r--r--net/ruby-socketproxy/pkg-descr5
-rw-r--r--net/ruby-socketproxy/pkg-plist3
5 files changed, 42 insertions, 0 deletions
diff --git a/net/ruby-socketproxy/Makefile b/net/ruby-socketproxy/Makefile
new file mode 100644
index 000000000000..a6810dea84d6
--- /dev/null
+++ b/net/ruby-socketproxy/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: Ruby/TCPSocketPipe
+# Date created: 20 July 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tcpsocketpipe
+PORTVERSION= 1.8
+CATEGORIES= net ruby
+MASTER_SITES= http://www.jin.gr.jp/~nahi/Ruby/TCPSocketPipe/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= TCPSocketPipe-${PORTVERSION:S/./_/g}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+RUN_DEPENDS= ${RUBY_SITELIBDIR}/application.rb:${PORTSDIR}/sysutils/ruby-application.rb \
+ ${RUBY_SITELIBDIR}/dump.rb:${PORTSDIR}/converters/ruby-dump.rb
+
+USE_RUBY= yes
+
+NO_BUILD= yes
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/TCPSocketPipe.rb ${RUBY_SITELIBDIR}/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/monitor.rb ${RUBY_EXAMPLESDIR}/${PORTNAME}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/ruby-socketproxy/distinfo b/net/ruby-socketproxy/distinfo
new file mode 100644
index 000000000000..10a2351512e8
--- /dev/null
+++ b/net/ruby-socketproxy/distinfo
@@ -0,0 +1 @@
+MD5 (ruby/TCPSocketPipe-1_8.tar.gz) = 85f67daf99423abf0562ecd88904216c
diff --git a/net/ruby-socketproxy/pkg-comment b/net/ruby-socketproxy/pkg-comment
new file mode 100644
index 000000000000..78f027c4321a
--- /dev/null
+++ b/net/ruby-socketproxy/pkg-comment
@@ -0,0 +1 @@
+A Ruby library to create I/O pipes for TCP socket tunneling
diff --git a/net/ruby-socketproxy/pkg-descr b/net/ruby-socketproxy/pkg-descr
new file mode 100644
index 000000000000..f980208efe0d
--- /dev/null
+++ b/net/ruby-socketproxy/pkg-descr
@@ -0,0 +1,5 @@
+This is Ruby/TCPSocketPipe, a Ruby library to create I/O pipes for TCP
+socket tunneling.
+
+Author: NaHi (NAKAMURA, Hiroshi) <nahi@keynauts.com>
+WWW: http://www.ruby-lang.org/en/raa-list.rhtml?name=TCPSocketPipe
diff --git a/net/ruby-socketproxy/pkg-plist b/net/ruby-socketproxy/pkg-plist
new file mode 100644
index 000000000000..d7e8025f34a5
--- /dev/null
+++ b/net/ruby-socketproxy/pkg-plist
@@ -0,0 +1,3 @@
+%%RUBY_SITELIBDIR%%/TCPSocketPipe.rb
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/tcpsocketpipe/monitor.rb
+%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/tcpsocketpipe